Opened 10 years ago

Closed 10 years ago

#94 closed (fixed)

milestone 1c completion

Reported by: hmussman@bbn.com Owned by: hmussman@bbn.com
Priority: major Milestone: WiMAX: 1c Import a GENI-compliant control framework from the ORBIT project
Component: WIMAX Version: SPIRAL1
Keywords: Cc: hmussman@bbn.com
Dependencies:

Description (last modified by hmussman@bbn.com)

From 1Q09 QSR:

Task 4. System-level integration with OMF/GENI control 4.1 Initial WiMAX system demo with OMF experimental control - done 3/09

Deliverables made: D1. Demonstration of WiMAX base station accessed via ORBIT control interface – March 31, 2009 (features shown at GEC-4 demo in Miami include: experimenter script to set up WiMAX experiment, use of WiMAX as control channel for V2V application, high bandwidth video streaming, mobile devices with both WiFi & WiMAX, GUI)

4.1 System level integration with GENI control As mentioned earlier, the WiMAX BS installed at WINLAB was used to demonstrate system-level capabilities including experimental control via ORBIT interfaces, use of WiMAX clients on mobile devices, high-speed streaming, flow setup and resource allocation, service bit-rate monitoring, etc. The demo showed a realistic experimental scenario where WiMAX is used as a control channel for location aware/opportunistic vehicular communications. This was intended as a first demo for GEC-4, and further work on more extensive control of radio API features, virtualization and performance monitoring is planned for 2Q09.

Per 2Q09 QSR: In terms of key findings, we now have a complete WiMAX experimental setup operating with an FCC experimental license, and have been able to fully integrate this equipment (initially without virtualization) with the ORBIT testbed (i.e. the GENI cluster E framework). This makes it possible for a remote experimenter to use OMF services to run a WiMAX experiment within the ORBIT framework. Further, our initial implementation of the open WiMAX API permits experimenters to access certain L2 parameters of the base station radio including PHY mode settings, RSSI, service class mappings, etc. The example system-level demo using vehicles equipped with dual-mode WiMAX/WiFi radios and GPS shows the feasibility of conducting outdoor experiments with mobility. Ongoing work during 3Q09 will extend this capability to multiple virtual slices operating on the same hardware, and when completed would achieve all the major goals for year 1 of this project. An open design issue to be worked on further is that of fine-grained slice resource management for a WiMAX base station with varying user demands and mobile user signal quality.

Deliverables made: D1. Demonstration of WiMAX base station accessed via ORBIT control interface – March 31, 2009 (features shown at GEC-4 demo in Miami include: experimenter script to set up WiMAX experiment, use of WiMAX as control channel for V2V application, high bandwidth video streaming, mobile devices with both WiFi & WiMAX, GUI)

Change History (5)

comment:1 Changed 10 years ago by hmussman@bbn.com

Status: newassigned

comment:2 Changed 10 years ago by hmussman@bbn.com

Resolution: fixed
Status: assignedclosed

comment:3 Changed 10 years ago by hmussman@bbn.com

Resolution: fixed
Status: closedreopened

comment:4 Changed 10 years ago by hmussman@bbn.com

Description: modified (diff)

comment:5 Changed 10 years ago by hmussman@bbn.com

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.