Opened 8 years ago

Closed 8 years ago

#719 closed (fixed)

Request for GEC10 DEMO/POSTER: Flexible OpenFlow 1.1 switch over Network Processors

Reported by: cherkaoui.omar@uqam.ca Owned by: chaos@bbn.com
Priority: major Milestone:
Component: GPO Version: SPIRAL3
Keywords: GEC10 Cc:
Dependencies:

Description (last modified by Josh Smift)

Brief demo description

In this demo, we show that designing an OpenFlow 1.1-controlled forwarding hardware on network processors (NP) allows a flexible forwarding behavior. In fact, we propose a software design that automatically pushes "on the fly" different forwarding decisions in a NP-based hardware data plane on which we implemented OF1.1. Particularly, we show how long does it take for our proposed software OpenFlow Preprocessor Engine (OPE) to update, at the right time, the multiple memory structures used by the NP hardware to cache the forwarding decisions corresponding to different behaviors/applications mix.

List of equipment that will need AC connections (e.g. laptop, switch hardware prototype, monitor). (Just put in the number of connections needed if your demo description already lists the equipment)

Laptop, projector

Number of wired network connections (include required bandwidth if significant)

None

Number of wireless network connections (include required bandwidth if significant)

One

Number of static addresses needed (if any)

None

Projector (y/n) (Bring your own projectors if feasible)

Yes

Monitor (y/n, specify VGA or DVI) (Specify resolution only if your software has resolution restrictions)

No

Number of posters (max size poster boards are 30" x 40")

One

Description of any special requests (include any non-commercial network connectivity needs, projects you'd like to be located near, etc.)

None

Change History (7)

comment:1 Changed 8 years ago by agosain@bbn.com

Owner: changed from somebody to chaos@bbn.com

comment:2 Changed 8 years ago by cherkaoui.omar@uqam.ca

Summary: Request for GEC10 DEMO: Flexible OpenFlow 1.1 switch over Network ProcessorsRequest for GEC10 DEMO/POSTER: Flexible OpenFlow 1.1 switch over Network Processors

comment:3 Changed 8 years ago by cherkaoui.omar@uqam.ca

Brief demo description

In this demo, we show that designing an OpenFlow 1.1-controlled forwarding hardware on network processors (NP) allows a flexible forwarding behavior. In fact, we propose a software design that automatically pushes "on the fly" different forwarding decisions in a NP-based hardware data plane on which we implemented OF1.1. Particularly, we show how long does it take for our proposed software OpenFlow Preprocessor Engine (OPE) to update, at the right time, the multiple memory structures used by the NP hardware to cache the forwarding decisions corresponding to different behaviors/applications mix.

List of equipment that will need AC connections (e.g. laptop, switch hardware prototype, monitor). (Just put in the number of connections needed if your demo description already lists the equipment)

Laptop, projector

Number of wired network connections (include required bandwidth if significant)

None

Number of wireless network connections (include required bandwidth if significant)

One

Number of static addresses needed (if any)

None

Projector (y/n) (Bring your own projectors if feasible)

Yes

Monitor (y/n, specify VGA or DVI) (Specify resolution only if your software has resolution restrictions)

No

Number of posters (max size poster boards are 30" x 40")

One

Description of any special requests (include any non-commercial network connectivity needs, projects you'd like to be located near, etc.)

None

comment:4 Changed 8 years ago by chaos@bbn.com

Status: newassigned

Thank you for your demo request. We will update this ticket when the resources have been confirmed.

comment:5 in reply to:  3 Changed 8 years ago by Josh Smift

Description: modified (diff)

I'm updating the Description to include the details of the request, since only Trac admins can do that.

comment:6 Changed 8 years ago by chaos@bbn.com

GPO has confirmed that we can support your demo at GEC10.

comment:7 Changed 8 years ago by hdempsey@bbn.com

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.