wiki:GENIRacksHome/InstageniRacks/ConfirmationTestStatus/UtahDDC

University of Utah Downtown Data Center InstaGENI Confirmation Tests

For details about the tests in this page, see the InstaGENI Confirmation Test Plan page.
For site status see the InstaGENI New Site Confirmation Tests Status page.

Note: Omni nick_names for site aggregate used for these tests are:

ig-gpo=,https://instageni.gpolab.bbn.com:12369/protogeni/xmlrpc/am/2.0
ig-of-gpo=,https://foam.gpolab.bbn.com:3626/foam/gapi/1
ig-utahddc=,https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am
ig-of-utahddc=,https://foam.utahddc.geniracks.net:3626/foam/gapi/1

IG-CT-1 - Access to New Site VM resources

Got Aggregate version, which showed AM API V1, V2, and V3 are supported and V2 is default:

$ omni.py listresources -a ig-utahddc -o 
20:25:53 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
20:25:53 INFO     omni: Using control framework portal
20:25:53 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
20:25:53 INFO     omni: Saving output to a file.
20:25:53 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
20:25:56 INFO     omni: Listed advertised resources at 1 out of 1 possible aggregates.
20:25:56 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
20:25:56 INFO     omni:  (PG log url - look here for details on any failures: https://www.utahddc.geniracks.net/spewlogfile.php3?logfile=fc992748cc1ed9dcc23997cd168830b1)
20:25:56 INFO     omni: Writing to 'rspec-utahddc-geniracks-net-protogeni.xml'
20:25:56 INFO     omni:  ------------------------------------------------------------
20:25:56 INFO     omni:  Completed listresources:

  Options as run:
		aggregate: ['ig-utahddc']
		framework: portal
		output: True
		project: ln-prj

  Args: listresources

  Result Summary: Queried resources from 1 of 1 aggregate(s).
Wrote rspecs from 1 aggregate(s) to 1 file(s)
Saved listresources RSpec from 'unspecified_AM_URN' (url 'https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am') to file rspec-utahddc-geniracks-net-protogeni.xml;  
20:25:56 INFO     omni:  ============================================================

$ omni.py getversion -a ig-utahddc
20:27:36 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
20:27:36 INFO     omni: Using control framework portal
20:27:36 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
20:27:36 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
20:27:38 INFO     omni:  (PG log url - look here for details on any failures: https://www.utahddc.geniracks.net/spewlogfile.php3?logfile=6fc5bafdee2d1d196ccfff648105f657)
20:27:38 INFO     omni: AM URN: unspecified_AM_URN (url: https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am) has version: ( (PG log url - look here for details on any failures: https://www.utahddc.geniracks.net/spewlogfile.php3?logfile=6fc5bafdee2d1d196ccfff648105f657).)
20:27:38 INFO     omni: {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',
    'geni_ad_rspec_versions': [   {   'extensions': [],
                                      'namespace': 'http://www.protogeni.net/resources/rspec/0.1',
                                      'schema': 'http://www.protogeni.net/resources/rspec/0.1/ad.xsd',
                                      'type': 'ProtoGENI',
                                      'version': '0.1'},
                                  {   'extensions': [],
                                      'namespace': 'http://www.protogeni.net/resources/rspec/0.2',
                                      'schema': 'http://www.protogeni.net/resources/rspec/0.2/ad.xsd',
                                      'type': 'ProtoGENI',
                                      'version': '0.2'},
                                  {   'extensions': [   'http://www.protogeni.net/resources/rspec/ext/emulab/1'],
                                      'namespace': 'http://www.protogeni.net/resources/rspec/2',
                                      'schema': 'http://www.protogeni.net/resources/rspec/2/ad.xsd',
                                      'type': 'ProtoGENI',
                                      'version': '2'},
                                  {   'extensions': [   'http://www.protogeni.net/resources/rspec/ext/emulab/1'],
                                      'namespace': 'http://www.geni.net/resources/rspec/3',
                                      'schema': 'http://www.geni.net/resources/rspec/3/ad.xsd',
                                      'type': 'GENI',
                                      'version': '3'}],
    'geni_api': 2,
    'geni_api_versions': {   '1': 'https://boss.utahddc.geniracks.net:12369/protogeni/xmlrpc/am/1.0',
                             '2': 'https://boss.utahddc.geniracks.net:12369/protogeni/xmlrpc/am/2.0',
                             '3': 'https://boss.utahddc.geniracks.net:12369/protogeni/xmlrpc/am/3.0'},
    'geni_request_rspec_versions': [   {   'extensions': [],
                                           'namespace': 'http://www.protogeni.net/resources/rspec/0.1',
                                           'schema': 'http://www.protogeni.net/resources/rspec/0.1/request.xsd',
                                           'type': 'ProtoGENI',
                                           'version': '0.1'},
                                       {   'extensions': [],
                                           'namespace': 'http://www.protogeni.net/resources/rspec/0.2',
                                           'schema': 'http://www.protogeni.net/resources/rspec/0.2/request.xsd',
                                           'type': 'ProtoGENI',
                                           'version': '0.2'},
                                       {   'extensions': [   'http://www.protogeni.net/resources/rspec/ext/emulab/1'],
                                           'namespace': 'http://www.protogeni.net/resources/rspec/2',
                                           'schema': 'http://www.protogeni.net/resources/rspec/2/request.xsd',
                                           'type': 'ProtoGENI',
                                           'version': '2'},
                                       {   'extensions': [   'http://www.protogeni.net/resources/rspec/ext/emulab/1'],
                                           'namespace': 'http://www.geni.net/resources/rspec/3',
                                           'schema': 'http://www.geni.net/resources/rspec/3/request.xsd',
                                           'type': 'GENI',
                                           'version': '3'}],
    'hostname': 'boss.utahddc.geniracks.net',
    'hrn': 'utahddcinstageni.cm',
    'interface': 'aggregate',
    'url': 'https://boss.utahddc.geniracks.net:12369/protogeni/xmlrpc/am',
    'urn': 'urn:publicid:IDN+utahddc.geniracks.net+authority+cm'}
20:27:38 INFO     omni:  ------------------------------------------------------------
20:27:38 INFO     omni:  Completed getversion:

  Options as run:
		aggregate: ['ig-utahddc']
		framework: portal
		noGetVersionCache: True
		project: ln-prj

  Args: getversion

  Result Summary: 
Got version for https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am 
20:27:38 INFO     omni:  ============================================================

The InstaGENI version " 'code_tag':'39c7dc5f6b119ff441e556e1547f80258b0923c9'" is the same as the other available InstaGENI sites:

getversion-geni-kettering-edu-protogeniv2.json:         {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',
getversion-instageni-cs-princeton-edu-protogeni.json:   {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',
getversion-instageni-gpolab-bbn-com.json:               {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',
getversion-instageni-northwestern-edu-protogeniv2.json: {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',
getversion-instageni-rnoc-gatech-edu-protogeni.json:    {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',
getversion-lan-sdn-uky-edu-protogeniv2.json:            {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',
getversion-utahddc-geniracks-net-protogeni.json:        {   'code_tag': '39c7dc5f6b119ff441e556e1547f80258b0923c9',

Get list of "available" compute resources:

$ omni.py -a ig-utahddc listresources --available -o

Reviewed Advertisement RSpec and found 18 exclusive nodes and 12 non-exclusive nodes. Verified that Advertisement RSpec only includes available resources.

Created a slice:

$ omni.py createslice IG-CT-1
20:43:10 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
20:43:10 INFO     omni: Using control framework portal
20:43:12 INFO     omni: Created slice with Name IG-CT-1, URN urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-1, Expiration 2013-08-21 00:43:11
20:43:12 INFO     omni:  ------------------------------------------------------------
20:43:12 INFO     omni:  Completed createslice:
  Options as run:
		framework: portal
		project: ln-prj

  Args: createslice IG-CT-1
  Result Summary: Created slice with Name IG-CT-1, URN urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-1, Expiration 2013-08-21 00:43:11
20:43:12 INFO     omni:  ============================================================

Created a 4 VMs sliver using the RSpec IG-CT-1-utahddc-xen.rspec:

$ omni.py createsliver -a ig-utahddc IG-CT-1 IG-CT-1-utahddc-xen.rspec
09:41:27 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
09:41:27 INFO     omni: Using control framework portal
09:41:27 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
09:41:28 INFO     omni: Slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-1 expires on 2013-08-21 00:43:11 UTC
09:41:28 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
09:41:28 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
09:41:28 INFO     omni: Creating sliver(s) from rspec file IG-CT-1-utahddc-xen.rspec for slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-1
09:41:46 INFO     omni:  (PG log url - look here for details on any failures: https://www.utahddc.geniracks.net/spewlogfile.php3?logfile=22fd94ccf78ecad71d0a379f4dddefa3)
09:41:46 INFO     omni: Got return from CreateSliver for slice IG-CT-1 at https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am:
09:41:46 INFO     omni: <!-- Reserved resources for:
	Slice: IG-CT-1
	at AM:
	URN: unspecified_AM_URN
	URL: https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am
 -->
09:41:46 INFO     omni: <rspec xmlns="http://www.geni.net/resources/rspec/3" xmlns:flack="http://www.protogeni.net/resources/rspec/ext/flack/1" xmlns:planetlab="http://www.planet-lab.org/resources/sfa/ext/planetlab/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" type="manifest" xsi:schemaLocation="http://www.geni.net/resources/rspec/3   http://www.geni.net/resources/rspec/3/manifest.xsd">  

  <node client_id="xen1" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="true" component_id="urn:publicid:IDN+utahddc.geniracks.net+node+pc32" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+77">
    <sliver_type name="emulab-xen"/>
    <services> <execute command="sudo apt-get install iperf -y" shell="sh"/> <login authentication="ssh-keys" hostname="pc32.utahddc.geniracks.net" port="31034" username="lnevers"/></services>
    <interface client_id="xen1:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+83" mac_address="0260b50ec171">
      <ip address="192.168.1.1" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pcvm32-1"/><host name="xen1.IG-CT-1.ch-geni-net.utahddc.geniracks.net"/></node>
  <node client_id="xen2" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="true" component_id="urn:publicid:IDN+utahddc.geniracks.net+node+pc32" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+78">
    <sliver_type name="emulab-xen"/>
    <services> <execute command="sudo apt-get install iperf -y" shell="sh"/> <login authentication="ssh-keys" hostname="pc32.utahddc.geniracks.net" port="31035" username="lnevers"/></services>
    <interface client_id="xen2:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+84" mac_address="0216a30e375a">
      <ip address="192.168.1.2" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pcvm32-2"/><host name="xen2.IG-CT-1.ch-geni-net.utahddc.geniracks.net"/></node>
  <node client_id="xen3" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="true" component_id="urn:publicid:IDN+utahddc.geniracks.net+node+pc32" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+79">
    <sliver_type name="emulab-xen"/>
    <services> <execute command="sudo apt-get install iperf -y" shell="sh"/> <login authentication="ssh-keys" hostname="pc32.utahddc.geniracks.net" port="31036" username="lnevers"/></services>
    <interface client_id="xen3:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+85" mac_address="02cf60c7654b">
      <ip address="192.168.1.3" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pcvm32-3"/><host name="xen3.IG-CT-1.ch-geni-net.utahddc.geniracks.net"/></node>
  <node client_id="xen4" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="true" component_id="urn:publicid:IDN+utahddc.geniracks.net+node+pc32" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+80">
    <sliver_type name="emulab-xen"/>
    <services> <execute command="sudo apt-get install iperf -y" shell="sh"/> <login authentication="ssh-keys" hostname="pc32.utahddc.geniracks.net" port="31037" username="lnevers"/></services>
    <interface client_id="xen4:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+86" mac_address="029deba4691b">
      <ip address="192.168.1.4" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pcvm32-4"/><host name="xen4.IG-CT-1.ch-geni-net.utahddc.geniracks.net"/></node>
  <link client_id="lan0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+82">
    <component_manager name="urn:publicid:IDN+utahddc.geniracks.net+authority+cm"/>
    <interface_ref client_id="xen1:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+83"/>
    <interface_ref client_id="xen2:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+84"/>
    <interface_ref client_id="xen3:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+85"/>
    <interface_ref client_id="xen4:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc32:lo0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+86"/>
    <link_type name="lan"/>
  </link>
</rspec>
09:41:46 INFO     omni:  ------------------------------------------------------------
09:41:46 INFO     omni:  Completed createsliver:
  Options as run:
		aggregate: ['ig-utahddc']
		framework: portal
		project: ln-prj

  Args: createsliver IG-CT-1 IG-CT-1-utahddc-xen.rspec
  Result Summary: Got Reserved resources RSpec from utahddc-geniracks-net-protogeni 
09:41:46 INFO     omni:  ============================================================

NOTE: Sliver creation took 22 minutes and 5 seconds.

The following is login information for the sliver:

$ readyToLogin.py -a ig-utahddc IG-CT-1
<...>
User lnevers logs in to xen1 using:
	ssh -p 31034  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc32.utahddc.geniracks.net
User lnevers logs in to xen4 using:
	ssh -p 31037  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc32.utahddc.geniracks.net
User lnevers logs in to xen2 using:
	ssh -p 31035  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc32.utahddc.geniracks.net
User lnevers logs in to xen3 using:
	ssh -p 31036  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc32.utahddc.geniracks.net

Measurements

Log into specified host and collect iperf and ping statistics. All measurements are collected over 60 seconds, using default images and default link bandwidth:

Iperf InstaGENI UtahDDC xen2 to xen1 (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   718 MBytes   100 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   144 MBytes  20.2 Mbits/sec
[  4]  0.0-60.1 sec   144 MBytes  20.2 Mbits/sec
[  7]  0.0-60.1 sec   143 MBytes  20.0 Mbits/sec
[  5]  0.0-60.1 sec   143 MBytes  20.0 Mbits/sec
[  6]  0.0-60.1 sec   145 MBytes  20.2 Mbits/sec
[SUM]  0.0-60.1 sec   720 MBytes   101 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-60.1 sec  78.8 MBytes  11.0 Mbits/sec
[  6]  0.0-60.1 sec  78.5 MBytes  11.0 Mbits/sec
[ 10]  0.0-60.1 sec  65.9 MBytes  9.19 Mbits/sec
[  7]  0.0-60.1 sec  75.9 MBytes  10.6 Mbits/sec
[  8]  0.0-60.1 sec  75.9 MBytes  10.6 Mbits/sec
[ 11]  0.0-60.2 sec  64.6 MBytes  9.01 Mbits/sec
[  9]  0.0-60.2 sec  64.8 MBytes  9.03 Mbits/sec
[  3]  0.0-60.2 sec  78.6 MBytes  11.0 Mbits/sec
[ 12]  0.0-60.2 sec  64.6 MBytes  9.01 Mbits/sec
[  4]  0.0-60.2 sec  74.6 MBytes  10.4 Mbits/sec
[SUM]  0.0-60.2 sec   722 MBytes   101 Mbits/sec

Iperf InstaGENI UtahDDC xen2 to the xen1 (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512765 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   694 MBytes  97.0 Mbits/sec   0.087 ms 17739/512764 (3.5%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from InstaGENI UtahDDC xen2 to the xen1

60 packets transmitted, 60 received, 0% packet loss, time 58997ms
rtt min/avg/max/mdev = 0.216/0.305/0.448/0.067 ms

IG-CT-2 - Access to New Site bare metal and VM resources

Using Xen for VM resources. Create a slice:

$ omni.py createslice IG-CT-2
10:18:18 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
10:18:18 INFO     omni: Using control framework portal
10:18:20 INFO     omni: Created slice with Name IG-CT-2, URN urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-2, Expiration 2013-08-21 14:18:19
10:18:20 INFO     omni:  ------------------------------------------------------------
10:18:20 INFO     omni:  Completed createslice:
  Options as run:
		framework: portal
		project: ln-prj

  Args: createslice IG-CT-2
  Result Summary: Created slice with Name IG-CT-2, URN urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-2, Expiration 2013-08-21 14:18:19
10:18:20 INFO     omni:  ============================================================

Created a sliver with one VM and one Raw PC using RSpec IG-CT-2-utahddc.rspec

$ omni.py createsliver -a ig-utahddc IG-CT-2 IG-CT-2-utahddc.rspec
10:19:06 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
10:19:06 INFO     omni: Using control framework portal
10:19:06 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
10:19:07 INFO     omni: Slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-2 expires on 2013-08-21 14:18:19 UTC
10:19:07 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
10:19:07 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
10:19:07 INFO     omni: Creating sliver(s) from rspec file IG-CT-2-utahddc.rspec for slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-2
10:19:23 INFO     omni:  (PG log url - look here for details on any failures: https://www.utahddc.geniracks.net/spewlogfile.php3?logfile=f9225785d292017592a7b87c79c7a192)
10:19:23 INFO     omni: Got return from CreateSliver for slice IG-CT-2 at https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am:
10:19:23 INFO     omni: <!-- Reserved resources for:
	Slice: IG-CT-2
	at AM:
	URN: unspecified_AM_URN
	URL: https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am
 -->
10:19:23 INFO     omni: <rspec xmlns="http://www.geni.net/resources/rspec/3" xmlns:flack="http://www.protogeni.net/resources/rspec/ext/flack/1" xmlns:planetlab="http://www.planet-lab.org/resources/sfa/ext/planetlab/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" type="manifest" xsi:schemaLocation="http://www.geni.net/resources/rspec/3   http://www.geni.net/resources/rspec/3/manifest.xsd">  

 <node client_id="VM" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="false" component_id="urn:publicid:IDN+utahddc.geniracks.net+node+pc9" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+87">
    <sliver_type name="emulab-xen"/>
    <services> <execute command="sudo apt-get install iperf -y" shell="sh"/> <login authentication="ssh-keys" hostname="pc9.utahddc.geniracks.net" port="30266" username="lnevers"/></services>
    <interface client_id="VM:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc9:eth1" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+91" mac_address="028841f85d85">
      <ip address="192.168.1.1" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pcvm9-2"/><host name="VM.IG-CT-2.ch-geni-net.utahddc.geniracks.net"/></node>
  <node client_id="PC" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="true" component_id="urn:publicid:IDN+utahddc.geniracks.net+node+pc23" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+88">
    <sliver_type name="raw-pc"/>
    <services> <execute command="sudo yum install iperf -y" shell="sh"/> <login authentication="ssh-keys" hostname="pc23.utahddc.geniracks.net" port="22" username="lnevers"/></services>
    <interface client_id="PC:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc23:eth1" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+92" mac_address="0213ed22690f">
      <ip address="192.168.1.2" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pc23"/><host name="PC.IG-CT-2.ch-geni-net.utahddc.geniracks.net"/></node>
  <link client_id="lan0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+90" vlantag="259">
    <component_manager name="urn:publicid:IDN+utahddc.geniracks.net+authority+cm"/>
    <interface_ref client_id="VM:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc9:eth1" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+91"/>
    <interface_ref client_id="PC:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc23:eth1" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+92"/>
    <link_type name="lan"/>
  </link>
</rspec>
10:19:23 INFO     omni:  ------------------------------------------------------------
10:19:23 INFO     omni:  Completed createsliver:

  Options as run:
		aggregate: ['ig-utahddc']
		framework: portal
		project: ln-prj

  Args: createsliver IG-CT-2 IG-CT-2-utahddc.rspec

  Result Summary: Got Reserved resources RSpec from utahddc-geniracks-net-protogeni 
10:19:23 INFO     omni:  ============================================================

NOTE: Sliver creation took 2 minutes and 46 seconds.

Determined login information:

$ readyToLogin.py -a ig-utahddc IG-CT-2
<...>
User lnevers logs in to VM using:
	ssh -p 30266  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc9.utahddc.geniracks.net
User lnevers logs in to PC using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc23.utahddc.geniracks.net

Measurements

Log into specified host and collect iperf and ping statistics. All measurements are collected over 60 seconds, using default images and default link bandwidth:

Iperf InstaGENI UtahDDC PC to VM (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   712 MBytes  99.5 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  6]  0.0-60.0 sec   143 MBytes  20.0 Mbits/sec
[  3]  0.0-60.1 sec   143 MBytes  20.0 Mbits/sec
[  5]  0.0-60.1 sec   143 MBytes  20.0 Mbits/sec
[  7]  0.0-60.1 sec   144 MBytes  20.1 Mbits/sec
[  4]  0.0-60.1 sec   143 MBytes  20.0 Mbits/sec
[SUM]  0.0-60.1 sec   716 MBytes  99.9 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-60.0 sec  66.0 MBytes  9.22 Mbits/sec
[ 10]  0.0-60.1 sec  75.8 MBytes  10.6 Mbits/sec
[  7]  0.0-60.1 sec  65.9 MBytes  9.19 Mbits/sec
[  8]  0.0-60.1 sec  75.8 MBytes  10.6 Mbits/sec
[ 12]  0.0-60.1 sec  76.0 MBytes  10.6 Mbits/sec
[  9]  0.0-60.1 sec  76.0 MBytes  10.6 Mbits/sec
[  5]  0.0-60.2 sec  65.9 MBytes  9.18 Mbits/sec
[  6]  0.0-60.2 sec  66.0 MBytes  9.20 Mbits/sec
[  3]  0.0-60.3 sec  75.9 MBytes  10.6 Mbits/sec
[ 11]  0.0-60.3 sec  75.9 MBytes  10.6 Mbits/sec
[SUM]  0.0-60.3 sec   719 MBytes   100 Mbits/sec

Iperf InstaGENI UtahDDC PC to the VM (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512822 datagrams
[  3] Server Report:
[  3]  0.0-60.1 sec   674 MBytes  94.0 Mbits/sec   0.070 ms 32039/512821 (6.2%)
[  3]  0.0-60.1 sec  1 datagrams received out-of-order

Ping from InstaGENI UtahDDC PC to VM

60 packets transmitted, 60 received, 0% packet loss, time 59000ms
rtt min/avg/max/mdev = 0.316/0.361/0.438/0.032 ms

Iperf InstaGENI UtahDDC VM to PC (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   718 MBytes   100 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-60.0 sec   146 MBytes  20.5 Mbits/sec
[  7]  0.0-60.0 sec   132 MBytes  18.5 Mbits/sec
[  4]  0.0-60.1 sec   148 MBytes  20.7 Mbits/sec
[  6]  0.0-60.1 sec   146 MBytes  20.3 Mbits/sec
[  3]  0.0-60.1 sec   145 MBytes  20.2 Mbits/sec
[SUM]  0.0-60.1 sec   718 MBytes   100 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[ 12]  0.0-60.0 sec  79.1 MBytes  11.1 Mbits/sec
[  3]  0.0-60.1 sec  94.6 MBytes  13.2 Mbits/sec
[ 11]  0.0-60.1 sec  57.5 MBytes  8.03 Mbits/sec
[ 10]  0.0-60.1 sec  86.8 MBytes  12.1 Mbits/sec
[  7]  0.0-60.1 sec  62.8 MBytes  8.76 Mbits/sec
[  8]  0.0-60.2 sec  63.1 MBytes  8.79 Mbits/sec
[  9]  0.0-60.2 sec  47.6 MBytes  6.63 Mbits/sec
[  6]  0.0-60.2 sec  72.1 MBytes  10.0 Mbits/sec
[  5]  0.0-60.3 sec  70.0 MBytes  9.74 Mbits/sec
[  4]  0.0-60.5 sec  84.1 MBytes  11.7 Mbits/sec
[SUM]  0.0-60.5 sec   718 MBytes  99.6 Mbits/sec

Iperf InstaGENI UtahDDC VM to the PC (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512757 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   694 MBytes  97.0 Mbits/sec   0.085 ms 17636/512756 (3.4%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from InstaGENI UtahDDC VM to PC

+ ping 192.168.1.2 -q -c 60
PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.

IG-CT-3 - Multiple sites experiment

Create a slice using OpenVZ hosts:

$ omni.py createslice IG-CT-3
10:49:14 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
10:49:14 INFO     omni: Using control framework portal
10:49:17 INFO     omni: Created slice with Name IG-CT-3, URN urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-3, Expiration 2013-08-21 14:49:15
10:49:17 INFO     omni:  ------------------------------------------------------------
10:49:17 INFO     omni:  Completed createslice:

  Options as run:
		framework: portal
		project: ln-prj
  Args: createslice IG-CT-3
  Result Summary: Created slice with Name IG-CT-3, URN urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-3, Expiration 2013-08-21 14:49:15
10:49:17 INFO     omni:  ============================================================

Create a sliver with one VM at UtahDDC and one VM at GPO using RSpec IG-CT-3-utahddc.rspec. First created the InstaGENI UtahDDC sliver:

$ omni.py createsliver IG-CT-3 -a ig-utahddc IG-CT-3-utahddc.rspec
10:49:58 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
10:49:58 INFO     omni: Using control framework portal
10:49:58 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
10:49:59 INFO     omni: Slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-3 expires on 2013-08-21 14:49:15 UTC
10:49:59 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
10:49:59 INFO     omni: Substituting AM nickname ig-utahddc with URL https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am, URN unspecified_AM_URN
10:49:59 INFO     omni: Creating sliver(s) from rspec file IG-CT-3-utahddc.rspec for slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-3
10:50:14 INFO     omni:  (PG log url - look here for details on any failures: https://www.utahddc.geniracks.net/spewlogfile.php3?logfile=eddc4d8050c6451dc08c94f2ab5a030f)
10:50:14 INFO     omni: Got return from CreateSliver for slice IG-CT-3 at https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am:
10:50:14 INFO     omni: <!-- Reserved resources for:
	Slice: IG-CT-3
	at AM:
	URN: unspecified_AM_URN
	URL: https://utahddc.geniracks.net:12369/protogeni/xmlrpc/am
 -->
10:50:14 INFO     omni: <rspec xmlns="http://www.geni.net/resources/rspec/3" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3                            http://www.geni.net/resources/rspec/3/manifest.xsd" type="manifest">

  <node client_id="VM-1" component_manager_id="urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm" exclusive="false">
    <sliver_type name="emulab-openvz"/>
    <interface client_id="VM-1:if0">
      <ip address="192.168.4.1" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  </node>
  <node client_id="VM-2" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="true" component_id="urn:publicid:IDN+utahddc.geniracks.net+node+pc27" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+93">
    <sliver_type name="emulab-openvz"/>
    <interface client_id="VM-2:if0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+96" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc27:eth0">
      <ip address="192.168.4.2" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pcvm27-1"/><host name="VM-2.IG-CT-3.ch-geni-net.utahddc.geniracks.net"/><services><login authentication="ssh-keys" hostname="pc27.utahddc.geniracks.net" port="30522" username="lnevers"/></services></node>
  <link client_id="gre-tunnel0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+95">
    <component_manager name="urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm"/>
    <component_manager name="urn:publicid:IDN+utahddc.geniracks.net+authority+cm"/>
    <interface_ref client_id="VM-1:if0"/>
    <interface_ref client_id="VM-2:if0" component_id="urn:publicid:IDN+utahddc.geniracks.net+interface+pc27:eth0" sliver_id="urn:publicid:IDN+utahddc.geniracks.net+sliver+96"/>
    <property source_id="VM-1:if0" dest_id="VM-2:if0"/>
    <property source_id="VM-2:if0" dest_id="VM-1:if0"/>
    <link_type name="gre-tunnel"/>
  </link>
</rspec>
10:50:14 INFO     omni:  ------------------------------------------------------------
10:50:14 INFO     omni:  Completed createsliver:

  Options as run:
		aggregate: ['ig-utahddc']
		framework: portal
		project: ln-prj

  Args: createsliver IG-CT-3 IG-CT-3-utahddc.rspec

  Result Summary: Got Reserved resources RSpec from utahddc-geniracks-net-protogeni 
10:50:14 INFO     omni:  ============================================================

Then creates the InstaGENI GPO sliver:

$ omni.py createsliver IG-CT-3 -a ig-gpo IG-CT-3-utahddc.rspec
10:50:24 INFO     omni: Loading config file /home/lnevers/.gcf/omni_config
10:50:24 INFO     omni: Using control framework portal
10:50:24 INFO     omni: Substituting AM nickname ig-gpo with URL https://boss.instageni.gpolab.bbn.com:12369/protogeni/xmlrpc/am/2.0, URN urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm
10:50:25 INFO     omni: Slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-3 expires on 2013-08-21 14:49:15 UTC
10:50:25 INFO     omni: Substituting AM nickname ig-gpo with URL https://boss.instageni.gpolab.bbn.com:12369/protogeni/xmlrpc/am/2.0, URN urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm
10:50:25 INFO     omni: Substituting AM nickname ig-gpo with URL https://boss.instageni.gpolab.bbn.com:12369/protogeni/xmlrpc/am/2.0, URN urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm
10:50:25 INFO     omni: Creating sliver(s) from rspec file IG-CT-3-utahddc.rspec for slice urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-3
10:50:38 INFO     omni:  (PG log url - look here for details on any failures: https://boss.instageni.gpolab.bbn.com/spewlogfile.php3?logfile=fa72cc6d504fc75984d92498959d6ddb)
10:50:38 INFO     omni: Got return from CreateSliver for slice IG-CT-3 at https://boss.instageni.gpolab.bbn.com:12369/protogeni/xmlrpc/am/2.0:
10:50:38 INFO     omni: <!-- Reserved resources for:
	Slice: IG-CT-3
	at AM:
	URN: urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm
	URL: https://boss.instageni.gpolab.bbn.com:12369/protogeni/xmlrpc/am/2.0
 -->
10:50:38 INFO     omni: <rspec xmlns="http://www.geni.net/resources/rspec/3" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3                            http://www.geni.net/resources/rspec/3/manifest.xsd" type="manifest">

  <node client_id="VM-1" component_manager_id="urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm" exclusive="false" component_id="urn:publicid:IDN+instageni.gpolab.bbn.com+node+pc1" sliver_id="urn:publicid:IDN+instageni.gpolab.bbn.com+sliver+9680">
    <sliver_type name="emulab-openvz"/>
    <interface client_id="VM-1:if0" sliver_id="urn:publicid:IDN+instageni.gpolab.bbn.com+sliver+9683" component_id="urn:publicid:IDN+instageni.gpolab.bbn.com+interface+pc1:eth0">
      <ip address="192.168.4.1" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  <rs:vnode xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1" name="pcvm1-11"/><host name="VM-1.IG-CT-3.ch-geni-net.instageni.gpolab.bbn.com"/><services><login authentication="ssh-keys" hostname="pc1.instageni.gpolab.bbn.com" port="31802" username="lnevers"/></services></node>
  <node client_id="VM-2" component_manager_id="urn:publicid:IDN+utahddc.geniracks.net+authority+cm" exclusive="false">
    <sliver_type name="emulab-openvz"/>
    <interface client_id="VM-2:if0">
      <ip address="192.168.4.2" netmask="255.255.255.0" type="ipv4"/>
    </interface>
  </node>
  <link client_id="gre-tunnel0" sliver_id="urn:publicid:IDN+instageni.gpolab.bbn.com+sliver+9682">
    <component_manager name="urn:publicid:IDN+instageni.gpolab.bbn.com+authority+cm"/>
    <component_manager name="urn:publicid:IDN+utahddc.geniracks.net+authority+cm"/>
    <interface_ref client_id="VM-1:if0" component_id="urn:publicid:IDN+instageni.gpolab.bbn.com+interface+pc1:eth0" sliver_id="urn:publicid:IDN+instageni.gpolab.bbn.com+sliver+9683"/>
    <interface_ref client_id="VM-2:if0"/>
    <property source_id="VM-1:if0" dest_id="VM-2:if0"/>
    <property source_id="VM-2:if0" dest_id="VM-1:if0"/>
    <link_type name="gre-tunnel"/>
  </link>
</rspec>
10:50:38 INFO     omni:  ------------------------------------------------------------
10:50:38 INFO     omni:  Completed createsliver:

  Options as run:
		aggregate: ['ig-gpo']
		framework: portal
		project: ln-prj

  Args: createsliver IG-CT-3 IG-CT-3-utahddc.rspec

  Result Summary: Got Reserved resources RSpec from instageni-gpolab-bbn-com 
10:50:38 INFO     omni:  ============================================================


Determined login information at each UtahDDC and GPO aggregate:

$ readyToLogin.py IG-CT-3 -a ig-utahddc 
  ....
VM-2's geni_status is: ready (am_status:ready) 
User lnevers logs in to VM-2 using:
	ssh -p 30522  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc27.utahddc.geniracks.net

$ readyToLogin.py IG-CT-3 -a ig-gpo
  ....
VM-1's geni_status is: ready (am_status:ready) 
User lnevers logs in to VM-1 using:
	ssh -p 31802  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc1.instageni.gpolab.bbn.com

Measurements

Iperf InstaGENI UtahDDC VM-2 to GPO VM-1 (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   425 MBytes  59.4 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   192 MBytes  26.9 Mbits/sec
[  6]  0.0-60.0 sec  85.4 MBytes  11.9 Mbits/sec
[  5]  0.0-60.1 sec  80.9 MBytes  11.3 Mbits/sec
[  4]  0.0-60.1 sec   116 MBytes  16.1 Mbits/sec
[  7]  0.0-60.1 sec  97.1 MBytes  13.5 Mbits/sec
[SUM]  0.0-60.1 sec   571 MBytes  79.7 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  66.8 MBytes  9.33 Mbits/sec
[  8]  0.0-60.0 sec  66.1 MBytes  9.24 Mbits/sec
[ 11]  0.0-60.1 sec  34.4 MBytes  4.80 Mbits/sec
[  4]  0.0-60.1 sec  64.4 MBytes  8.99 Mbits/sec
[  9]  0.0-60.1 sec  47.9 MBytes  6.68 Mbits/sec
[ 12]  0.0-60.2 sec  65.8 MBytes  9.17 Mbits/sec
[ 10]  0.0-60.2 sec  59.1 MBytes  8.24 Mbits/sec
[  5]  0.0-60.2 sec   113 MBytes  15.7 Mbits/sec
[  6]  0.0-60.3 sec  60.9 MBytes  8.47 Mbits/sec
[  7]  0.0-60.3 sec  56.9 MBytes  7.91 Mbits/sec
[SUM]  0.0-60.3 sec   635 MBytes  88.3 Mbits/sec

Iperf InstaGENI UtahDDC VM-2 to GPO VM-1 (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.1 sec   599 MBytes  83.7 Mbits/sec   0.046 ms 85230/512820 (17%)
[  3]  0.0-60.1 sec  1 datagrams received out-of-order

Ping from InstaGENI UtahDDC VM-2 to GPO VM-1

60 packets transmitted, 60 received, 0% packet loss, time 59075ms
rtt min/avg/max/mdev = 80.041/91.332/181.627/21.622 ms

Iperf InstaGENI GPO VM-1 to UtahDDC VM-2 (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.1 sec   199 MBytes  27.7 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  6]  0.0-60.0 sec  80.6 MBytes  11.3 Mbits/sec
[  7]  0.0-60.1 sec  83.0 MBytes  11.6 Mbits/sec
[  5]  0.0-60.1 sec  83.0 MBytes  11.6 Mbits/sec
[  3]  0.0-60.1 sec  63.1 MBytes  8.81 Mbits/sec
[  4]  0.0-60.2 sec  87.6 MBytes  12.2 Mbits/sec
[SUM]  0.0-60.2 sec   397 MBytes  55.4 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  9]  0.0-60.0 sec  44.9 MBytes  6.27 Mbits/sec
[ 11]  0.0-60.1 sec  50.6 MBytes  7.06 Mbits/sec
[  8]  0.0-60.2 sec  40.0 MBytes  5.58 Mbits/sec
[  7]  0.0-60.2 sec  26.8 MBytes  3.73 Mbits/sec
[  4]  0.0-60.2 sec  54.0 MBytes  7.52 Mbits/sec
[ 12]  0.0-60.2 sec  48.2 MBytes  6.72 Mbits/sec
[ 10]  0.0-60.3 sec  38.0 MBytes  5.28 Mbits/sec
[  3]  0.0-60.4 sec  44.0 MBytes  6.11 Mbits/sec
[  6]  0.0-60.6 sec  35.2 MBytes  4.88 Mbits/sec
[  5]  0.0-60.7 sec  35.4 MBytes  4.89 Mbits/sec
[SUM]  0.0-60.7 sec   417 MBytes  57.7 Mbits/sec

Iperf InstaGENI GPO VM-1 to UtahDDC VM-2 (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.2 sec   531 MBytes  73.9 Mbits/sec   9.099 ms 134296/512818 (26%)
[  3]  0.0-60.2 sec  1 datagrams received out-of-order

Ping from InstaGENI GPO VM-1 to UtahDDC VM-2

60 packets transmitted, 60 received, 0% packet loss, time 59088ms
rtt min/avg/max/mdev = 84.420/88.776/113.476/6.498 ms

IG-CT-4 - Multiple sites OpenFlow experiment and interoperability

First create a slice:

$ omni.py createslice IG-CT-4
...
  Result Summary: Created slice with Name IG-CT-4, URN urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-4, Expiration 2013-08-21 17:16:41

Then create slivers at all OpenFlow aggregates. This confirmation test creates a sliver at each of the following aggregates using the RSpec specified. RSpecs can be found here.

$ omni.py createsliver -a of-nlr IG-CT-4 IG-CT-4-openflow-nlr.rspec -V1
$ omni.py createsliver -a of-i2 IG-CT-4 IG-CT-4-openflow-internet2.rspec -V1 
$ omni.py createsliver -a of-gpo IG-CT-4 IG-CT-4-openflow-gpo.rspec  -V1
$ omni.py createsliver -a eg-of-gpo IG-CT-4 IG-CT-4-openflow-eg-gpo.rspec -V1  
$ omni.py createsliver -a ig-of-gpo IG-CT-4 IG-CT-4-openflow-ig-gpo.rspec  -V1
$ omni.py createsliver -a of-uen IG-CT-4 IG-CT-4-openflow-uen.rspec -V1
$ omni.py createsliver -a ig-of-utahddc IG-CT-4 IG-CT-4-openflow-ig-utahddc.rspec -V1 

 

Then create a sliver at each of the compute resource aggregates, RSpecs used can be found RSpecs can be found here.

$ omni.py createsliver -a pg-utah IG-CT-4 IG-CT-4-pg-utah.rspec
$ omni.py createsliver -a ig-gpo IG-CT-4 IG-CT-4-ig-gpo.rspec
$ omni.py createsliver -a eg-gpo IG-CT-4 IG-CT-4-eg-gpo.rspec
$ omni.py createsliver -a ig-utahddc IG-CT-4 IG-CT-4-ig-utahddc.rspec

Determine login for each of compute resources:

$ readyToLogin.py -a ig-utahddc IG-CT-4
<...>
User lnevers logs in to utahddc-ig2 using:
	ssh -p 31291  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc22.utahddc.geniracks.net
User lnevers logs in to utahddc-ig using:
	ssh -p 31290  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc22.utahddc.geniracks.net

$ readyToLogin.py -a ig-gpo IG-CT-4
<...>
User lnevers logs in to gpo-ig using:
	ssh -p 35386  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc1.instageni.gpolab.bbn.com
User lnevers logs in to gpo-ig2 using:
	ssh -p 35387  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc1.instageni.gpolab.bbn.com

$ readyToLogin.py -a pg-utah IG-CT-4
<...>
User lnevers logs in to utah-pg using:
	ssh -p 35642  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc533.emulab.net

$ readyToLogin.py -a eg-gpo IG-CT-4
<...>
User root logs in to VM using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key root@192.1.242.29

Measurements

This section captures measurements collected between the following endpoints:

 1. InstaGENI UtahDDC VM and InstaGENI UtahDDC VM
 2. InstaGENI UtahDDC VM and InstaGENI GPO VM
 3. InstaGENI UtahDDC VM and the PG Utah VM
 4. InstaGENI UtahDDC VM and ExoGENI GPO VM
  1. The measurements collected for InstaGENI UtahDDC VM to the InstaGENI UtahDDC VM:

Iperf InstaGENI UtahDDC VM to InstaGENI UtahDDC VM (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  9.69 GBytes  1.39 Gbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-60.0 sec  7.13 GBytes  1.02 Gbits/sec
[  5]  0.0-60.0 sec  7.13 GBytes  1.02 Gbits/sec
[  6]  0.0-60.0 sec  7.21 GBytes  1.03 Gbits/sec
[  7]  0.0-60.0 sec  6.91 GBytes   989 Mbits/sec
[  3]  0.0-60.0 sec  7.40 GBytes  1.06 Gbits/sec
[SUM]  0.0-60.0 sec  35.8 GBytes  5.12 Gbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[ 12]  0.0-60.0 sec  5.76 GBytes   824 Mbits/sec
[  3]  0.0-60.0 sec  5.96 GBytes   853 Mbits/sec
[  5]  0.0-60.0 sec  5.88 GBytes   842 Mbits/sec
[  6]  0.0-60.0 sec  5.99 GBytes   858 Mbits/sec
[  4]  0.0-60.0 sec  6.03 GBytes   863 Mbits/sec
[  7]  0.0-60.0 sec  6.14 GBytes   878 Mbits/sec
[  9]  0.0-60.0 sec  6.08 GBytes   871 Mbits/sec
[ 11]  0.0-60.0 sec  6.09 GBytes   871 Mbits/sec
[  8]  0.0-60.0 sec  6.19 GBytes   886 Mbits/sec
[ 10]  0.0-60.0 sec  5.91 GBytes   846 Mbits/sec
[SUM]  0.0-60.0 sec  60.0 GBytes  8.59 Gbits/sec

Iperf InstaGENI UtahDDC VM to the InstaGENI UtahDDC VM (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec   0.000 ms    0/512820 (0%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from InstaGENI UtahDDC VM to the InstaGENI UtahDDC VM

60 packets transmitted, 60 received, 0% packet loss, time 58999ms
rtt min/avg/max/mdev = 0.037/0.045/0.069/0.005 ms
  1. The measurements collected for InstaGENI UtahDDC VM to the InstaGENI GPO VM:

Iperf InstaGENI UtahDDC VM to the InstaGENI GPO VM (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.1 sec   197 MBytes  27.5 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-59.8 sec   102 MBytes  14.2 Mbits/sec
[  5]  0.0-60.0 sec  67.9 MBytes  9.49 Mbits/sec
[  7]  0.0-60.0 sec  67.6 MBytes  9.45 Mbits/sec
[  4]  0.0-60.1 sec   102 MBytes  14.3 Mbits/sec
[  6]  0.0-60.4 sec  61.5 MBytes  8.54 Mbits/sec
[SUM]  0.0-60.4 sec   401 MBytes  55.7 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-59.5 sec  65.9 MBytes  9.28 Mbits/sec
[  4]  0.0-59.5 sec  48.9 MBytes  6.89 Mbits/sec
[  7]  0.0-59.8 sec  50.8 MBytes  7.11 Mbits/sec
[ 12]  0.0-59.9 sec  34.8 MBytes  4.86 Mbits/sec
[  8]  0.0-60.0 sec  29.5 MBytes  4.13 Mbits/sec
[  6]  0.0-60.0 sec  41.4 MBytes  5.79 Mbits/sec
[ 10]  0.0-60.0 sec  34.6 MBytes  4.84 Mbits/sec
[  5]  0.0-60.0 sec  31.2 MBytes  4.37 Mbits/sec
[  9]  0.0-60.2 sec  33.9 MBytes  4.72 Mbits/sec
[ 11]  0.0-60.2 sec  38.9 MBytes  5.41 Mbits/sec
[SUM]  0.0-60.2 sec   410 MBytes  57.1 Mbits/sec

Iperf InstaGENI UtahDDC VM to the InstaGENI GPO VM (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-58.1 sec   592 MBytes  85.4 Mbits/sec   0.086 ms 90657/512820 (18%)
[  3]  0.0-58.1 sec  535 datagrams received out-of-order

Ping from InstaGENI UtahDDC VM to the InstaGENI GPO VM

60 packets transmitted, 60 received, 0% packet loss, time 59061ms
rtt min/avg/max/mdev = 267.270/371.055/3216.609/474.816 ms, pipe 4
  1. The measurements collected for InstaGENI UtahDDC VM to the PG Utah VM

Collected: 2013-08-14

Iperf InstaGENI UtahDDC VM to the PG Utah VM (TCP)

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  6.39 GBytes   915 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-59.8 sec  1.40 GBytes   201 Mbits/sec
[  6]  0.0-59.8 sec  1.34 GBytes   193 Mbits/sec
[  3]  0.0-59.8 sec  1.08 GBytes   155 Mbits/sec
[  5]  0.0-60.0 sec  1.45 GBytes   208 Mbits/sec
[  7]  0.0-60.0 sec  1.12 GBytes   161 Mbits/sec
[SUM]  0.0-60.0 sec  6.40 GBytes   916 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-59.9 sec   658 MBytes  92.1 Mbits/sec
[  4]  0.0-59.9 sec   635 MBytes  88.9 Mbits/sec
[  3]  0.0-59.9 sec   681 MBytes  95.3 Mbits/sec
[  9]  0.0-59.9 sec   624 MBytes  87.4 Mbits/sec
[  8]  0.0-59.9 sec   661 MBytes  92.5 Mbits/sec
[  7]  0.0-59.9 sec   718 MBytes   100 Mbits/sec
[  6]  0.0-60.0 sec   655 MBytes  91.6 Mbits/sec
[ 10]  0.0-60.0 sec   671 MBytes  93.8 Mbits/sec
[ 12]  0.0-60.0 sec   619 MBytes  86.5 Mbits/sec
[ 11]  0.0-60.0 sec   630 MBytes  88.0 Mbits/sec
[SUM]  0.0-60.0 sec  6.40 GBytes   916 Mbits/sec

Iperf InstaGENI UtahDDC VM to the PG Utah VM (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-59.8 sec   717 MBytes   101 Mbits/sec   0.005 ms 1651/512820 (0.32%)
[  3]  0.0-59.8 sec  23 datagrams received out-of-order

Ping from InstaGENI UtahDDC VM to the PG Utah VM

60 packets transmitted, 60 received, 0% packet loss, time 59000ms
rtt min/avg/max/mdev = 0.284/7.791/446.129/57.066 ms

  1. The measurements collected for InstaGENI UtahDDC VM to the ExoGENI GPO VM:

Iperf InstaGENI UtahDDC VM to the ExoGENI RENCI VM (TCP)

Collected: 2013-08-14

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.3 sec  29.4 MBytes  4.08 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-59.9 sec  28.0 MBytes  3.92 Mbits/sec
[  4]  0.0-60.3 sec  28.1 MBytes  3.91 Mbits/sec
[  7]  0.0-60.4 sec  27.1 MBytes  3.77 Mbits/sec
[  6]  0.0-60.4 sec  28.2 MBytes  3.92 Mbits/sec
[  5]  0.0-60.4 sec  26.6 MBytes  3.70 Mbits/sec
[SUM]  0.0-60.4 sec   138 MBytes  19.2 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-59.5 sec  26.2 MBytes  3.70 Mbits/sec
[  3]  0.0-59.5 sec  28.8 MBytes  4.05 Mbits/sec
[  6]  0.0-59.8 sec  28.9 MBytes  4.05 Mbits/sec
[  5]  0.0-59.8 sec  27.9 MBytes  3.91 Mbits/sec
[  7]  0.0-60.0 sec  28.0 MBytes  3.92 Mbits/sec
[  9]  0.0-60.1 sec  26.8 MBytes  3.74 Mbits/sec
[  8]  0.0-60.2 sec  26.9 MBytes  3.75 Mbits/sec
[ 10]  0.0-60.3 sec  25.9 MBytes  3.60 Mbits/sec
[ 11]  0.0-60.3 sec  29.1 MBytes  4.05 Mbits/sec
[ 12]  0.0-60.3 sec  26.4 MBytes  3.67 Mbits/sec
[SUM]  0.0-60.3 sec   275 MBytes  38.2 Mbits/sec

Iperf InstaGENI UtahDDC VM to the ExoGENI RENCI VM (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-58.0 sec   588 MBytes  85.0 Mbits/sec   0.108 ms 93406/512820 (18%)
[  3]  0.0-58.0 sec  477 datagrams received out-of-order

Ping from InstaGENI UtahDDC VM to the ExoGENI GPO VM

60 packets transmitted, 60 received, 0% packet loss, time 59086ms
rtt min/avg/max/mdev = 267.523/353.559/2956.748/415.388 ms, pipe 3

IG-CT-5 - Experiment Monitoring

Reviewed content of the GMOC Monitoring page for aggregates, and found both Compute Resources and FOAM aggregates.

Verified that the Utah DDC compute resources aggregate shows up in the list of aggregates and provides Aggregate Name, Type, Last Update, Version, POP, and Organization:

Active slivers:

List of resources:

Aggregate measurements:

The UtahDDC InstaGENI FOAM resources aggregate details:

Active OpenFlow Slivers:

List of OpenFlow Resources in use:

Monitoring shows Aggregate measurement for CPU utilization, Disk Utilization, Network Statistics and OF Datapath and Sliver Statistics:

IG-CT-6 - Administrative Tests

Sent request for administrative account to site contact. Site contact should be from the UtahDDC InstaGENI aggregate page, but page does not exist yet. See instaticket:124. Followed instructions at Admin Accounts on InstaGeni Racks page for account request. A local admin account was create for the emulab-ops group at join group page. Once the administrative account was created and membership to emulab-ops was approved, proceeded to execute administrative tests.

LNM:~$ ssh control.utahddc.geniracks.net
Welcome to Ubuntu precise (development branch) (GNU/Linux 3.2.0-23-generic x86_64)
....

lnevers@control:~$ sudo whoami
root
lnevers@control:~$ 

Also access the boss node:

LNM:~$ ssh control.utahddc.geniracks.net
Permission denied (publickey).
LNM:~$ ssh boss.utahddc.geniracks.net
Last login: Fri Aug 16 07:07:22 2013 from dhcp89-073-116.bbn.com
FreeBSD 9.0-STABLE (TESTBED-XEN) #0: Tue Apr 30 14:24:36 MDT 2013

Welcome to FreeBSD!

To determine whether a file is a text file, executable, or some other type
of file, use

	file filename
		-- Dru <genesis@istar.ca>
[lnevers@boss ~]$ sudo whoami
root
[lnevers@boss ~]$ 

From boss node accessed each of the experiment nodes that support VMs:

[lnevers@boss ~]$ for i in pc1 pc2 pc3 pc4 pc5 pc6 pc7 pc8 pc9 pc10 pc11 pc12; do ssh $i "echo -n '===> Host: ';hostname;sudo whoami;uname -a;echo"; done
Warning: Permanently added 'pc1.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost1.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost1.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc2.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost2.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost2.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc3.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost3.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost3.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc4.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost4.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost4.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc5.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost5.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost5.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc6.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost6.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost6.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc7.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost7.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost7.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc8.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost8.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost8.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc9.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost9.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost9.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc10.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost10.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost10.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc11.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost11.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost11.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc12.utahddc.geniracks.net' (RSA) to the list of known hosts.
===> Host: vhost12.shared-nodes.emulab-ops.utahddc.geniracks.net
root
Linux vhost12.shared-nodes.emulab-ops.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux

[lnevers@boss ~]$ 

In order to access Dedicated Nodes some experiment must be running on the raw-pc device. At the time of this capture, four raw-pc nodes were in use (pc22, pc23, pc27 and pc32):

[lnevers@boss ~]$ sudo ssh pc22
[root@pc22 ~]# sudo whoami
root
[root@pc22 ~]# uname -a
Linux pc22.ig-ct-4.ch-geni-net.utahddc.geniracks.net 2.6.32-042stab049.6.emulab.1 #1 SMP Mon May 21 14:36:04 MDT 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@pc22 ~]# exit
logout
Connection to pc22.utahddc.geniracks.net closed.
[lnevers@boss ~]$ sudo ssh pc23
[root@pc ~]# sudo whoami
root
[root@pc ~]#  uname -a
Linux pc.ig-ct-2.ch-geni-net.utahddc.geniracks.net 2.6.40-4.emulab2.fc15.i686.PAE #1 SMP Tue Feb 26 13:35:12 MST 2013 i686 i686 i386 GNU/Linux
[root@pc ~]# exit
logout
Connection to pc23.utahddc.geniracks.net closed.
[lnevers@boss ~]$ sudo ssh pc27
[root@pc27 ~]# sudo whoami
root
[root@pc27 ~]# uname -a
Linux pc27.ig-ct-3.ch-geni-net.utahddc.geniracks.net 2.6.32-042stab049.6.emulab.1 #1 SMP Mon May 21 14:36:04 MDT 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@pc27 ~]# exit
logout
Connection to pc27.utahddc.geniracks.net closed.
[lnevers@boss ~]$ sudo ssh pc32
Welcome to Ubuntu 12.04 LTS (GNU/Linux 3.2.46 x86_64)

 * Documentation:  https://help.ubuntu.com/
root@pc32:~# sudo whoami
root
root@pc32:~# uname -a
Linux pc32.ig-ct-1.ch-geni-net.utahddc.geniracks.net 3.2.46 #1 SMP Wed Jun 5 15:53:18 MDT 2013 x86_64 x86_64 x86_64 GNU/Linux
root@pc32:~# exit
logout
Connection to pc32.utahddc.geniracks.net closed.
[lnevers@boss ~]$ 

Further verified access by ssh from ops.instageni.gpolab.bbn.com to boss.instageni.gpolab.bbn.com, which is usually restricted for non-admin users:

LNM:~$ ssh ops.utahddc.geniracks.net
Last login: Fri Aug 16 07:06:53 2013 from dhcp89-073-116.bbn.com
FreeBSD 9.0-STABLE (TESTBED-XEN) #0: Tue Apr 30 14:24:36 MDT 2013

Welcome to FreeBSD!

To quickly create an empty file, use "touch filename".
		-- Dru <genesis@istar.ca>
[lnevers@ops ~]$ sudo whoami
root
[lnevers@ops ~]$ ssh boss
The authenticity of host 'boss.utahddc.geniracks.net (155.99.144.4)' can't be established.
ECDSA key fingerprint is bd:05:23:a7:5b:cc:78:c8:8c:a8:d3:e9:f7:27:53:cb.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'boss.utahddc.geniracks.net' (ECDSA) to the list of known hosts.
Last login: Fri Aug 16 07:19:02 2013 from dhcp89-073-116.bbn.com
FreeBSD 9.0-STABLE (TESTBED-XEN) #0: Tue Apr 30 14:24:36 MDT 2013

Welcome to FreeBSD!

To see the last 10 lines of a long file, use "tail filename". To see the
first 10 lines, use "head filename".
		-- Dru <genesis@istar.ca>

[lnevers@boss ~]$ exit
exit
logout
Connection to boss.utahddc.geniracks.net closed.
[lnevers@ops ~]$ exit
logout
Connection to ops.utahddc.geniracks.net closed.

Access infrastructure Switches using documented password. First connect to the switch named procurve1 the control network switch:

[lnevers@boss ~]$ sudo more /usr/testbed/etc/switch.pswd
XXXXXXXXX
[lnevers@boss ~]$ telnet procurve1 
HP J8697A Switch E5406zl
Software revision K.15.06.0017

Copyright (C) 1991-2012 Hewlett-Packard Development Company, L.P.

                   RESTRICTED RIGHTS LEGEND
 Confidential computer software.  Valid license from HP required for possession,
 use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer
 Software, Computer Software Documentation, and Technical Data for Commercial
 Items are licensed to the U.S. Government under vendor's standard commercial
 license.
                   HEWLETT-PACKARD DEVELOPMENT COMPANY, L.P. 
                   20555 State Highway 249, Houston, TX 77070

We'd like to keep you up to date about:
  * Software feature updates
  * New product announcements
  * Special events
Please register your products now at:  www.hp.com/networking/register

Username: manager
Password: 
ddc-procurve1# 
ddc-procurve1#  show version 
Image stamp:    /ws/swbuildm/ec_rel_eureka_qaoff/code/build/btm(ec_rel_eureka_qaoff)
                Apr 20 2012 12:34:21
                K.15.06.0017
                13
Boot Image:     Primary
ddc-procurve1# show running-config 

Running configuration:

; J8697A Configuration Editor; Created on release #K.15.06.0017
; Ver #02:10.0d:1f

hostname "ddc-procurve1" 
module 1 type J9534A 
module 2 type J9536A 
module 3 type J9550A 
module 4 type J9536A 
ip default-gateway 10.1.1.254 
vlan 1 
   name "DEFAULT_VLAN" 
   untagged A1,A4-A24,B1-B22,C1-C24,D1-D22 
   ip address 10.254.254.254 255.255.255.0 
   no untagged A2-A3 
   ip igmp 
   exit 
vlan 11 
   name "control-alternate" 
   untagged A3 
   ip address 10.2.1.253 255.255.255.0 
   exit 
vlan 10 
   name "control-hardware" 
   untagged A2 
   ip address 10.1.1.253 255.255.255.0 
   exit 
no web-management
ip authorized-managers 10.1.1.1 255.255.255.0 access manager
snmp-server community "xxxx" unrestricted
aaa authentication ssh login public-key
aaa authentication ssh enable public-key
management-vlan 10
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password xxx
password xxx

ddc-procurve1#  show vlans 

 Status and Counters - VLAN Information

  Maximum VLANs to support : 256                  
  Primary VLAN : DEFAULT_VLAN     
  Management VLAN : control-hardware 

  VLAN ID Name                             | Status     Voice Jumbo
  ------- -------------------------------- + ---------- ----- -----
  1       DEFAULT_VLAN                     | Port-based No    No   
  10      control-hardware                 | Port-based No    No   
  11      control-alternate                | Port-based No    No   
 

ddc-procurve1# exit
ddc-procurve1> exit
Do you want to log out [y/n]? y
Connection closed by foreign host.
[lnevers@boss ~]$ 

Connect to the switch named procurve2 the dataplane network switch via ssh using the documented password:

[lnevers@boss ~]$ sudo more /usr/testbed/etc/switch.pswd
xxxxxxx
[lnevers@boss ~]$ telnet procurve2
Trying 10.3.1.253...
Connected to procurve2.
Escape character is '^]'.

HP J8697A Switch E5406zl
Software revision K.15.06.5008

Copyright (C) 1991-2012 Hewlett-Packard Development Company, L.P.

                   RESTRICTED RIGHTS LEGEND
 Confidential computer software.  Valid license from HP required for possession,
 use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer
 Software, Computer Software Documentation, and Technical Data for Commercial
 Items are licensed to the U.S. Government under vendor's standard commercial
 license.
                   HEWLETT-PACKARD DEVELOPMENT COMPANY, L.P. 
                   20555 State Highway 249, Houston, TX 77070

We'd like to keep you up to date about:
  * Software feature updates
  * New product announcements
  * Special events
Please register your products now at:  www.hp.com/networking/register

Username: manager
Password: 


ddc-es-tor-q15-1#  show version 
Image stamp:    /ws/swbuildm/of_bridge_qaoff/code/build/btm(of_bridge_qaoff)
                Feb 18 2012 11:26:28
                K.15.06.5008
                79
Boot Image:     Primary
ddc-es-tor-q15-1# show running-config 

Running configuration:

; J8697A Configuration Editor; Created on release #K.15.06.5008
; Ver #02:10.0d:1f

hostname "ddc-es-tor-q15-1" 
max-vlans 2048 
module 1 type J9534A 
module 2 type J9548A 
module 3 type J9535A 
module 4 type J9550A 
module 5 type J9550A 
module 6 type J9534A 
interface A1 
   name "CHPC Managment - note VLAN Translation" 
exit
interface A4 
   speed-duplex auto-1000 
exit
interface A5 
   speed-duplex auto-1000 
exit
interface A6 
   speed-duplex auto-1000 
exit
interface A7 
   speed-duplex auto-1000 
exit
interface A8 
   speed-duplex auto-1000 
exit
interface A9 
   speed-duplex auto-1000 
exit
interface A10 
   speed-duplex auto-1000 
exit
interface A11 
   speed-duplex auto-1000 
exit
interface A12 
   speed-duplex auto-1000 
exit
interface B1 
   speed-duplex auto-1000 
exit
interface B2 
   speed-duplex auto-1000 
exit
interface B3 
   speed-duplex auto-1000 
exit
interface B4 
   speed-duplex auto-1000 
exit
interface B5 
   speed-duplex auto-1000 
exit
interface B6 
   speed-duplex auto-1000 
exit
interface B7 
   speed-duplex auto-1000 
exit
interface B8 
   speed-duplex auto-1000 
exit
interface B9 
   speed-duplex auto-1000 
exit
interface B10 
   speed-duplex auto-1000 
exit
interface B11 
   speed-duplex auto-1000 
exit
interface B12 
   speed-duplex auto-1000 
exit
interface B13 
   speed-duplex auto-1000 
exit
interface B14 
   speed-duplex auto-1000 
exit
interface B15 
   speed-duplex auto-1000 
exit
interface B16 
   speed-duplex auto-1000 
exit
interface B17 
   speed-duplex auto-1000 
exit
interface B18 
   speed-duplex auto-1000 
exit
interface B22 
   name "procurve-pgeni-uen port b22" 
exit
interface D1 
   speed-duplex auto-1000 
exit
interface D2 
   speed-duplex auto-1000 
exit
interface D3 
   speed-duplex auto-1000 
exit
interface D4 
   speed-duplex auto-1000 
exit
interface D5 
   speed-duplex auto-1000 
exit
interface D6 
   speed-duplex auto-1000 
exit
interface D7 
   speed-duplex auto-1000 
exit
interface D8 
   speed-duplex auto-1000 
exit
interface D9 
   speed-duplex auto-1000 
exit
interface D13 
   disable
   speed-duplex auto-1000 
exit
interface D15 
   disable
   speed-duplex auto-1000 
exit
interface D21 
   disable
   speed-duplex auto-1000 
exit
interface D23 
   disable
   speed-duplex auto-1000 
exit
interface D24 
   disable
   speed-duplex auto-1000 
exit
interface E1 
   disable
   speed-duplex auto-1000 
exit
interface E4 
   disable
   speed-duplex auto-1000 
exit
interface E5 
   disable
   speed-duplex auto-1000 
exit
interface E6 
   disable
   speed-duplex auto-1000 
exit
interface E7 
   disable
   speed-duplex auto-1000 
exit
interface E8 
   disable
   speed-duplex auto-1000 
exit
interface E9 
   disable
   speed-duplex auto-1000 
exit
interface E13 
   speed-duplex auto-1000 
exit
interface E16 
   speed-duplex auto-1000 
exit
interface E17 
   disable
   speed-duplex auto-1000 
exit
interface E18 
   disable
   speed-duplex auto-1000 
exit
interface E22 
   disable
   speed-duplex auto-1000 
exit
interface E23 
   disable
   speed-duplex auto-1000 
exit
interface E24 
   disable
   speed-duplex auto-1000 
exit
interface F7 
   disable
   speed-duplex auto-1000 
exit
interface F13 
   disable
   speed-duplex auto-1000 
exit
interface F16 
   disable
   speed-duplex auto-1000 
exit
interface F19 
   disable
   speed-duplex auto-1000 
exit
ip default-gateway 10.240.0.1 
vlan 1 
   name "DEFAULT_VLAN" 
   forbid A4-A12,B1-B18,D1-D9 
   untagged A3,A13-A24,B19-B21,C1-C24,D10-D24,E1-E12,E14-E15,E17-E24,F1-F24 
   no untagged A1-A2,A4-A12,B1-B18,B22,D1-D9,E13,E16 
   no ip address 
   exit 
vlan 2 
   name "CHPC_Management" 
   untagged A1 
   ip address 10.240.0.5 255.255.254.0 
   jumbo 
   exit 
vlan 10 
   name "control-hardware" 
   untagged A2 
   ip address 10.3.1.253 255.255.255.0 
   jumbo 
   exit 
vlan 1750 
   name "_9" 
   tagged B22,E13 
   no ip address 
   exit 
vlan 257 
   name "_14" 
   untagged A4-A12,B1-B18,D1-D9 
   no ip address 
   exit 
vlan 258 
   name "_17" 
   tagged A4,A7,A10,B1,B4,B7,B10,B13,B16,D1,D4,D7 
   no ip address 
   exit 
vlan 259 
   name "_33" 
   tagged B16,E16 
   no ip address 
   exit 
no web-management
ip dns server-address priority 1 155.101.3.11
ip dns server-address priority 2 155.101.3.12
openflow
   vlan 1750
      enable
      controller "tcp:10.3.1.7:6633" fail-secure on
      exit
   exit
snmp-server community "xxx" unrestricted
aaa authentication ssh login public-key
aaa authentication ssh enable public-key
management-vlan 10
no autorun
no dhcp config-file-update
no dhcp image-file-update
password xxx
password xxx

ddc-es-tor-q15-1#  show vlans  

 Status and Counters - VLAN Information

  Maximum VLANs to support : 2048                 
  Primary VLAN : DEFAULT_VLAN    
  Management VLAN : control-hardware

  VLAN ID Name                             | Status     Voice Jumbo
  ------- -------------------------------- + ---------- ----- -----
  1       DEFAULT_VLAN                     | Port-based No    No   
  2       CHPC_Management                  | Port-based No    Yes  
  10      control-hardware                 | Port-based No    Yes  
  257     _14                              | Port-based No    No   
  258     _17                              | Port-based No    No   
  259     _33                              | Port-based No    No   
  1750    _9                               | Port-based No    No   
 

ddc-es-tor-q15-1# show vlans 1750

 Status and Counters - VLAN Information - VLAN 1750

  VLAN ID : 1750   
  Name : _9                              
  Status : Port-based
  Voice : No 
  Jumbo : No 

  Port Information Mode     Unknown VLAN Status    
  ---------------- -------- ------------ ----------
  B22              Tagged   Learn        Up        
  E13              Tagged   Learn        Up        
 

ddc-es-tor-q15-1# exit
ddc-es-tor-q15-1> exit
Do you want to log out [y/n]? 
Connection closed by foreign host.

Access the FOAM VM and gather information for version

LNM:~$ ssh foam.utahddc.geniracks.net
Welcome to Ubuntu 12.04.2 LTS (GNU/Linux 3.2.0-51-generic x86_64)
...

lnevers@foam:~$ sudo foamctl admin:get-version  --passwd-file=/etc/foam.passwd 
{
 "version": "0.12.0"
}
lnevers@foam:~$ 

Check FOAM configuration for site.admin.email, geni.site-tag, email.from settings:

lnevers@foam:~$ foamctl config:get-value --key="site.admin.email"  --passwd-file=/etc/foam.passwd 
{
 "value": null
}
lnevers@foam:~$ foamctl config:get-value --key="geni.site-tag"  --passwd-file=/etc/foam.passwd 
{
 "value": "foam.utahddc.geniracks.net"
}
lnevers@foam:~$ foamctl config:get-value --key="email.from"  --passwd-file=/etc/foam.passwd 
{
 "value": "stoller@flux.utah.edu"
}
lnevers@foam:~$ foamctl config:get-value --key="email.from"  --passwd-file=/etc/foam.passwd 
{
 "value": "stoller@flux.utah.edu"
}
lnevers@foam:~$ foamctl config:get-value --key="geni.approval.approve-on-creation"  --passwd-file=/etc/foam.passwd 
{
 "value": 2
}

Show FOAM slivers and details for one sliver:

lnevers@foam:~$ foamctl geni:list-slivers --passwd-file=/etc/foam.passwd
{
 "slivers": [
  {
   "status": "approved", 
   "flowvisor_slice": "66224f75-e941-40c8-844b-ed43e7c1feeb", 
   "slice_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+tuptymon", 
   "pend_reason": [], 
   "deleted": "False", 
   "user": "urn:publicid:IDN+pgeni.gpolab.bbn.com+user+tupty", 
   "creation": "2013-08-13 21:48:32.067376+00:00", 
   "enabled": true, 
   "uuid": "66224f75-e941-40c8-844b-ed43e7c1feeb", 
   "id": 3, 
   "expiration": "2013-10-10 00:00:00+00:00", 
   "sliver_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+tuptymon:66224f75-e941-40c8-844b-ed43e7c1feeb", 
   "ref": null, 
   "email": "tupty@pgeni.gpolab.bbn.com", 
   "desc": "tuptymon OpenFlow resources at UEN InstaGENI."
  }, 
  {
   "status": "approved", 
   "flowvisor_slice": "af6fa175-e927-479d-982d-72a2a81124c9", 
   "slice_urn": "urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-4", 
   "pend_reason": [], 
   "deleted": "False", 
   "user": "urn:uuid:5702673f-cc62-4729-9efd-3b7bd3db4bc9", 
   "creation": "2013-08-14 17:27:09.045538+00:00", 
   "enabled": true, 
   "uuid": "af6fa175-e927-479d-982d-72a2a81124c9", 
   "id": 4, 
   "expiration": "2013-08-21 17:16:41+00:00", 
   "sliver_urn": "urn:publicid:IDN+ch.geni.net:ln-prj+slice+IG-CT-4:af6fa175-e927-479d-982d-72a2a81124c9", 
   "ref": null, 
   "email": "lnevers@bbn.com", 
   "desc": "New Site Confirmation Test IG-CT-4 "
  }
 ]
}
lnevers@foam:~$ 

Access the FlowVisor VM and gather version information:

LNM:~$ ssh flowvisor.utahddc.geniracks.net
Welcome to Ubuntu 12.04.2 LTS (GNU/Linux 3.2.0-51-generic x86_64)
..
lnevers@flowvisor:~$ sudo whoami
root

Check the FlowVisor version, list of devices, get details for a device, list of active slices, and details for one of the slices:

lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd ping hello
Got reply:
PONG(fvadmin): FV version=flowvisor-0.8.17::hello

# Devices
lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd listDevices
Device 0: 06:d6:24:be:05:fe:43:00


lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd listDevices
Device 0: 06:d6:24:be:05:fe:43:00
lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd getDeviceInfo 06:d6:24:be:05:fe:43:00
nPorts=4
portList=46,65534,37,109
dpid=06:d6:24:be:05:fe:43:00
remote=/10.3.1.7:6633-->/10.3.1.253:55760
portNames=B22(46),local(65534),B13(37),E13(109)


#Slices
lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd listSlices
Slice 0: fvadmin
Slice 1: 66224f75-e941-40c8-844b-ed43e7c1feeb
Slice 2: af6fa175-e927-479d-982d-72a2a81124c9
lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd getSliceInfo af6fa175-e927-479d-982d-72a2a81124c9
Got reply:
drop_policy=exact
connection_1=06:d6:24:be:05:fe:43:00-->/155.99.144.7:40575-->mallorea.gpolab.bbn.com/192.1.249.185:33020
contact_email=lnevers@bbn.com
controller_hostname=mallorea.gpolab.bbn.com
controller_port=33020
creator=fvadmin
lnevers@flowvisor:~$ 

Check the FlowVisor setting:

lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd dumpConfig /tmp/flowvisor-config
lnevers@flowvisor:~$ more /tmp/flowvisor-config 
{
   "flowvisor": [
      {
         "api_webserver_port": 8080,
         "api_jetty_webserver_port": -1,
         "checkpointing": false,
         "listen_port": 6633,
         "track_flows": false,
         "stats_desc_hack": false,
         "run_topology_server": false,
         "logging": "NOTE",
         "log_ident": "flowvisor",
         "log_facility": "LOG_LOCAL7",
         "version": "flowvisor-0.9",
         "host": "localhost",
         "default_flood_perm": "fvadmin",
         "config_name": "default"
      }
   ],
   "Slice": [
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "fvadmin",
         "creator": "fvadmin",
         "passwd_crypt": "xxx",
         "passwd_salt": "xxx",
         "controller_hostname": "none",
         "controller_port": 0,
         "contact_email": "fvadmin@localhost",
         "drop_policy": "exact",
         "lldp_spam": true
      },
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "66224f75-e941-40c8-844b-ed43e7c1feeb",
         "creator": "fvadmin",
         "passwd_crypt": "a607b328e60906ee1dab40b0e75d0f89",
         "passwd_salt": "926389911",
         "controller_hostname": "naxos.gpolab.bbn.com",
         "controller_port": 31750,
         "contact_email": "tupty@pgeni.gpolab.bbn.com",
         "drop_policy": "exact",
         "lldp_spam": true
      },
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "af6fa175-e927-479d-982d-72a2a81124c9",
         "creator": "fvadmin",
         "passwd_crypt": "1e548deddb524a1e5140da0ceefa68b6",
         "passwd_salt": "-515041710",
         "controller_hostname": "mallorea.gpolab.bbn.com",
         "controller_port": 33020,
         "contact_email": "lnevers@bbn.com",
         "drop_policy": "exact",
         "lldp_spam": true
      }
   ],
   "FlowSpaceRule": [
      {
         "dpid": "6d624be05fe4300",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2048,
         "nw_src": 171048960,
         "nw_dst": 171048960,
         "wildcards": 3412207,
         "slice_action": [
            {
               "66224f75-e941-40c8-844b-ed43e7c1feeb": 4
            }
         ]
      },
      {
         "dpid": "6d624be05fe4300",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2054,
         "nw_src": 171048960,
         "nw_dst": 171048960,
         "wildcards": 3412207,
         "slice_action": [
            {
               "66224f75-e941-40c8-844b-ed43e7c1feeb": 4
            }
         ]
      },
      {
         "dpid": "6d624be05fe4300",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2048,
         "nw_src": 170527488,
         "nw_dst": 170527488,
         "wildcards": 3279087,
         "slice_action": [
            {
               "af6fa175-e927-479d-982d-72a2a81124c9": 4
            }
         ]
      },
      {
         "dpid": "6d624be05fe4300",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2054,
         "nw_src": 170527488,
         "nw_dst": 170527488,
         "wildcards": 3279087,
         "slice_action": [
            {
               "af6fa175-e927-479d-982d-72a2a81124c9": 4
            }
         ]
      }
   ]
}

Verify alerts for the compute resource Aggregate Manager are being reported to the GPO Tango GENI Nagios monitoring and that the majority of alerts have a status of "OK". Other statuses may be encountered and are verified with activities, outages or known issues for the site.

Verify alerts for the FOAM Aggregate Manager are being reported to the GPO Tango GENI Nagios monitoring and that the majority of alerts have a status of "OK". Other statuses may be encountered and are verified with activities, outages or known issues for the site.


Email help@geni.net for GENI support or email me with feedback on this page!
Last modified 6 years ago Last modified on 10/17/13 17:17:16

Attachments (11)