wiki:GENIRacksHome/InstageniRacks/AcceptanceTestStatus/IG-MON-2

Version 16 (modified by lnevers@bbn.com, 7 years ago) (diff)

--

Detailed test plan for IG-MON-2: GENI Software Configuration Inspection Test

This page captures status for the test case IG-MON-2, which verifies the ability to determine software configuration in the InstaGENI racks. For overall status see the InstaGENI Acceptance Test Status page.

Last update: 2013-03-05

Test Status

Step State Tickets Notes
1 Color(green,Pass)?
2 Color(green,Pass)?
3 Color(#98FB98,Pass: most criteria)?FOAM-352
4


State Legend Description
Color(green,Pass)? Test completed and met all criteria
Color(#98FB98,Pass: most criteria)? Test completed and met most criteria. Exceptions documented
Color(red,Fail)? Test completed and failed to meet criteria.
Color(yellow,Complete)? Test completed but will require re-execution due to expected changes
Color(orange,Blocked)? Blocked by ticketed issue(s).
Color(#63B8FF,In Progress)? Currently under test.


Test Plan Steps

Step 1: determine experimental node allocations

This step will verify the ability to determine VM in use as well as VMs available as follows:

  • On boss and ops, use available system data sources (process listings, monitoring output, system logs, etc) and/or AM administrative interfaces (Emulab UI, testbed database) to determine the experimental state of each node.
  • For each OpenVZ node found, determine what operating system that node makes available to users.

As a site admin login to https://boss.instageni.gpolab.bbn.com, select "red dot" mode and select pulldown "Experimentation"->"Node Status", which will show this page:

.

On the resulting page select "physical" from the tabular view listing across the top of the panel. This will show all physical systems in the rack, along with the OS running on those nodes.

The above shows:

  • pc3 is in used by an experiment (EID) named "jbstmp"
  • pc4 and pc5 are available
  • pc1 and pc2 are part of the "shared-nodes" experiment used to reserve the PCs that provide VMs.

To determine what VMs are in use, while still in the Experimentation"->"Node Status" page (in red dot mode) select "virtual" from the tabular view across the top of the panel, which will provide a list of VMs in use in the rack:

If further information is needed for any of the VMs on the "virtual" table, simply click on the VM "ID" and all VM information will be shown.

Step 2: determine rack VLAN configuration

Determine all VLANs available to experimenters. For each available VLAN, determine whether it is available for exclusive OpenFlow control. This step verifies that the site administrator can determine how many VLANs are available for use and which are for OpenFlow only.

$ omni.py listresources -a ig-gpo -o

The output file show the following OpenFlow VLANs:

  <rspec_shared_vlan xmlns="http://www.geni.net/resources/rspec/ext/shared-vlan/1">    
      <available name="mesoscale-openflow"/>    
      <available name="exclusive-openflow-1755"/>    
      <available name="exclusive-openflow-1756"/>    
      <available name="exclusive-openflow-1757"/>    
      <available name="exclusive-openflow-1758"/>    
      <available name="exclusive-openflow-1759"/>    
      <available name="L2-ping-tutorial"/>    
  </rspec_shared_vlan>  

The following VLAN are available on the switch "procurve2" (dataplane switch) for stitching use:

      <node id="urn:publicid:IDN+instageni.gpolab.bbn.com+node+procurve2">        
                            <vlanRangeAvailability>                    3747-3749                  </vlanRangeAvailability>                  
                            <vlanTranslation>                    false                  </vlanTranslation>                  
      <node id="urn:publicid:IDN+instageni.gpolab.bbn.com+node+procurve2">        
                            <vlanRangeAvailability>                    2644-2649                  </vlanRangeAvailability>                  
                            <vlanTranslation>                    false                  </vlanTranslation>                              

Additional information can be determined by logging into the dataplane switch and showing VLAN information:

$ ssh boss.instageni.gpolab.com
[lnevers@boss ~]$ sudo more /usr/testbed/etc/switch.pswd
[lnevers@boss ~]$ ssh manager@procurve2

manager@procurve2's password: 

HP-E5406zl# show vlans 

 Status and Counters - VLAN Information

  Maximum VLANs to support : 256                  
  Primary VLAN : DEFAULT_VLAN    
  Management VLAN : control-hardware

  VLAN ID Name                             | Status     Voice Jumbo
  ------- -------------------------------- + ---------- ----- -----
  1       DEFAULT_VLAN                     | Port-based No    No   
  10      control-hardware                 | Port-based No    No   
  257     _8                               | Port-based No    No   
  1750    _11                              | Port-based No    No   
  1755    _347                             | Port-based No    No   
  1756    _348                             | Port-based No    No   
  1757    _349                             | Port-based No    No   
  1758    _350                             | Port-based No    No   
  1759    _351                             | Port-based No    No   
  3705    _222                             | Port-based No    No   
  3742    _481                             | Port-based No    No   
 
HP-E5406zl# show vlans 1750

 Status and Counters - VLAN Information - VLAN 1750

  VLAN ID : 1750   
  Name : _11                             
  Status : Port-based
  Voice : No 
  Jumbo : No 

  Port Information Mode     Unknown VLAN Status    
  ---------------- -------- ------------ ----------
  E1               Tagged   Learn        Up        
  E4               Tagged   Learn        Up        
  E5               Tagged   Learn        Up        
  E23              Tagged   Learn        Up        
  E24              Tagged   Learn        Up        

The overall configuration can also be shown on the switch to determine configured VLAN information as well as details for the OpenFlow VLANs:

HP-E5406zl# show running-config 
<...>
vlan 1 
   name "DEFAULT_VLAN" 
   forbid E3,E6 
   untagged A1-A24,E7-E19,E21-E22 
   no untagged E1-E6,E20,E23-E24 
   no ip address 
   exit 
vlan 10 
   name "control-hardware" 
   untagged E20 
   ip address 10.2.1.253 255.255.255.0 
   ip address 10.3.1.253 255.255.255.0 
   exit 
vlan 1750 
   name "_11" 
   tagged E1,E4-E5,E23-E24 
   no ip address 
   exit 
vlan 3705 
   name "_222" 
   tagged E23-E24 
   no ip address 
vlan 1755 
   name "_347" 
   tagged E23-E24 
   no ip address 
   exit 
vlan 1756 
   name "_348" 
   tagged E23-E24 
   no ip address 
   exit 
vlan 1757 
   name "_349" 
   tagged E23-E24 
   no ip address 
   exit 
vlan 1758 
   name "_350" 
   tagged E23-E24 
   no ip address 
   exit 
vlan 1759 
   name "_351" 
   tagged E23-E24 
   no ip address 
   exit 
vlan 257 
   name "_8" 
   untagged E3,E6 
   tagged E1-E2,E4-E5 
   no ip address 
   exit 
vlan 3742 
   name "_481" 
   tagged E1,E4,E24 
   no ip address 
   exit 
<...>
openflow
   vlan 1750
      enable
      controller "tcp:10.3.1.7:6633" fail-secure on
      exit
   vlan 1755
      enable
      controller "tcp:10.3.1.7:6633"
      exit
   vlan 1756
      enable
      controller "tcp:10.3.1.7:6633"
      exit
   vlan 1757
      enable
      controller "tcp:10.3.1.7:6633"
      exit
   vlan 1758
      enable
      controller "tcp:10.3.1.7:6633"
      exit
   vlan 1759
      enable
      controller "tcp:10.3.1.7:6633"
      exit
   exit

Step 3: determine which GENI SAs are trusted by InstaGENI AM

This step verified that an experimenter can use the trusted SAs and that the site administrator can determine the full set of trusted GENI Slice Authorities:

Use Omni tools with pgeni.gpolab.bbn.com credentials to query the GPO rack. The omni_config is defined as follows:

[omni]
default_cf = pg
users = lnevers
# ---------- Users ----------
[lnevers]
urn = urn:publicid:IDN+pgeni.gpolab.bbn.com+user+lnevers
keys = /home/lnevers/.ssh/id_rsa.pub
# ---------- Frameworks ----------
[pg]
type = pg
ch = https://www.emulab.net:12369/protogeni/xmlrpc/ch
sa = https://www.pgeni.gpolab.bbn.com:443/protogeni/xmlrpc/sa
cert = /home/lnevers/.ssl/pgeni/encrypted-cleartext.pem
key = /home/lnevers/.ssl/pgeni/encrypted-cleartext.pem

Create a slice and a sliver at the GPO InstaGENI:

$ omni.py createslice ln-pgeni-cred
$ omni.py createsliver  ln-pgeni-cred -a ig-gpo  ./insta-gpo-1vm.rspec 
<...>
INFO:omni:Slice urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+ln-pgeni-cred expires on 2013-03-06 21:58:49 UTC
<..>

The Slice urn shows the pgeni.gpolab.bbn.com SA was used to reserve resources within the rack. Before proceeding delete the sliver:

$ omni.py deletesliver  ln-pgeni-cred -a ig-gpo 

To verify support for PG Utah SA, modify the omni_config to use emulab as a default framwork and selcte the urn for the emulab account:

[omni]
default_cf = emulab 
users = lnevers
# ---------- Users ----------
[lnevers]
urn = urn:publicid:IDN+emulab.net+user+lnevers
keys = /home/lnevers/.ssh/id_rsa.pub
# ---------- Frameworks ----------
[emulab]
type = pg
ch = https://www.emulab.net:12369/protogeni/xmlrpc/ch
sa = https://www.emulab.net:12369/protogeni/xmlrpc/sa
cert = ~/.ssl/protogeni/encrypted-cleartext.pem
key = ~/.ssl/protogeni/encrypted-cleartext.pem
verbose=false

Create a new slice with the PG Utah SA credentials and sliver:

$ omni.py createslice ln-pgutah-cred
$ omni.py createsliver ln-pgutah-cred -a ig-gpo ./insta-gpo-1vm.rspec 
<...>
INFO:omni:Slice urn:publicid:IDN+emulab.net+slice+ln-pgutah-cred expires within 1 day on 2013-03-06 03:06:59 UTC
<...>

The Slice urn shows the emulab.net SA was used to reserve resources within the rack.

As an administrator determine ways to show Slice authorities for InstaGENI Compute and FOAM aggregates:

  • For InstaGENI compute resources aggregate there is one central definition for trusted slice authorities, which available at https://www.emulab.net/protogeni/authorities/salist.txt. All InstaGENI racks use this global list of Trusted Authorities. <<<TODO, determine if this information can be shown within the GPO Rack>>>
  • FOAM trusts root certificates and certificates to be configured for trust are placed in /opt/foam/etc/gcf-ca-certs, but presence of a certificate in this directory does not mean that the trust is configured. Since there is no way to show all trusted roots at this time created FOAM ticket FOAM-352 bug.

Step 4: determine rack OpenFlow state

Login to Data plane switch to show OpenFlow configuration and flows:

$ ssh boss.instageni.gpolab.com
[lnevers@boss ~]$ sudo more /usr/testbed/etc/switch.pswd
[lnevers@boss ~]$ ssh manager@procurve2

manager@procurve2's password: 

HP-E5406zl# show openflow
HP-E5406zl# show openflow 

 Openflow Configuration

  Openflow aggregate VLANs [Disabled] :           
  Openflow aggregate management VlanId [0] : 0     
  Openflow second aggregate management VlanId [0] : 0     
  Openflow aggregate configuration VlanId [0] : 0     

  VID  State HW  Active controller Pseudo-URL                       Conn
  ---- ----- --- -------------------------------------------------- ----
  1750 On    On  tcp:10.3.1.7:6633                                  Yes 
  1755 On    On  tcp:10.3.1.7:6633                                  Yes 
  1756 On    On  tcp:10.3.1.7:6633                                  Yes 
  1757 On    On  tcp:10.3.1.7:6633                                  Yes 
  1758 On    On  tcp:10.3.1.7:6633                                  Yes 
  1759 On    On  tcp:10.3.1.7:6633                                  Yes 

HP-E5406zl# show openflow 1750 flows

 Openflow flows - VLAN 1750

Flow 1
 Incoming Port      : 120               HW acceleration    : Yes
 Destination MAC    : 02fd27-710df7     Source MAC         : 0026b9-7e6cc8
 VLAN ID            : 65535             VLAN Priority      : 0
 Source IP          : 10.50.1.100       Destination IP     : 10.50.2.5
 IP Protocol        : ICMP              IP ToS bits        : 0
 ICMP Type          : 8                 ICMP Code          : 0
 Duration           : 2s secs           Priority           : 65535
 Idle Timeout       : 5 secs            Hard Timeout       : 0 secs
 Packet Count       : 2                 Bytes Count        : 98
 Actions            : output:97

Flow 2
 Incoming Port      : 97                HW acceleration    : Yes
 Destination MAC    : 0026b9-7e6cc8     Source MAC         : 02fd27-710df7
 VLAN ID            : 65535             VLAN Priority      : 0
 Source IP          : 10.50.2.5         Destination IP     : 10.50.1.100
 IP Protocol        : ICMP              IP ToS bits        : 0
 ICMP Type          : 8                 ICMP Code          : 0
 Duration           : 1275960s secs     Priority           : 65535
 Idle Timeout       : 5 secs            Hard Timeout       : 0 secs
 Packet Count       : 1268221           Bytes Count        : 98
 Actions            : output:120

Flow 3
 Incoming Port      : 97                HW acceleration    : Yes
 Destination MAC    : 0026b9-7e6cc8     Source MAC         : 02fd27-710df7
 VLAN ID            : 65535             VLAN Priority      : 0
 Source IP          : 10.50.2.5         Destination IP     : 10.50.1.100
 IP Protocol        : ICMP              IP ToS bits        : 0
 ICMP Type          : 0                 ICMP Code          : 0
 Duration           : 2s secs           Priority           : 65535
 Idle Timeout       : 5 secs            Hard Timeout       : 0 secs
 Packet Count       : 2                 Bytes Count        : 98
 Actions            : output:120

Flow 4
 Incoming Port      : 120               HW acceleration    : Yes
 Destination MAC    : 02fd27-710df7     Source MAC         : 0026b9-7e6cc8
 VLAN ID            : 65535             VLAN Priority      : 0
 Source IP          : 10.50.1.100       Destination IP     : 10.50.2.5
 IP Protocol        : ICMP              IP ToS bits        : 0
 ICMP Type          : 0                 ICMP Code          : 0
 Duration           : 1275960s secs     Priority           : 65535
 Idle Timeout       : 5 secs            Hard Timeout       : 0 secs
 Packet Count       : 1268221           Bytes Count        : 98
 Actions            : output:97

HP-E5406zl# show openflow version

 Openflow Version

  HP Networking OpenFlow Agent Version 2.02w.
  Based on Open vSwitch Reference Source code Version 1.0.0.
  Switch software Version K.15.06.5008.

HP-E5406zl# 

Login to FlowVisor host and show active slices, flows and FlowVisor configuration:

LNM:~$ ssh flowvisor.instageni.gpolab.bbn.com

lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd listSlices
Slice 0: fvadmin
Slice 1: 8a0abd6f-0f5a-469f-91d2-c7f990b8494e
Slice 2: a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7
Slice 3: b7850c93-110f-4e63-a121-26f3449dac44
Slice 4: 03f03910-1176-428b-b00f-d4d4ddaab9ab
Slice 5: 33a83d5f-4da1-4d98-8095-8b62623c26b1

lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd listFlowSpace
Got reply:
rule 0: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x800,nw_dst=10.42.15.0/24,nw_src=10.42.15.0/24]],actionsList=[Slice:8a0abd6f-0f5a-469f-91d2-c7f990b8494e=4],id=[13],priority=[2000],]
rule 1: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x806,nw_dst=10.42.15.0/24,nw_src=10.42.15.0/24]],actionsList=[Slice:8a0abd6f-0f5a-469f-91d2-c7f990b8494e=4],id=[14],priority=[2000],]
rule 2: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x800,nw_dst=10.42.16.0/24,nw_src=10.42.16.0/24]],actionsList=[Slice:a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7=4],id=[15],priority=[2000],]
rule 3: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x806,nw_dst=10.42.16.0/24,nw_src=10.42.16.0/24]],actionsList=[Slice:a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7=4],id=[16],priority=[2000],]
rule 4: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x800,nw_dst=10.50.0.0/16,nw_src=10.50.0.0/16]],actionsList=[Slice:b7850c93-110f-4e63-a121-26f3449dac44=4],id=[21],priority=[2000],]
rule 5: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x806,nw_dst=10.50.0.0/16,nw_src=10.50.0.0/16]],actionsList=[Slice:b7850c93-110f-4e63-a121-26f3449dac44=4],id=[22],priority=[2000],]
rule 6: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x800,nw_dst=10.42.11.0/24,nw_src=10.42.11.0/24]],actionsList=[Slice:03f03910-1176-428b-b00f-d4d4ddaab9ab=4],id=[79],priority=[2000],]
rule 7: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x806,nw_dst=10.42.11.0/24,nw_src=10.42.11.0/24]],actionsList=[Slice:03f03910-1176-428b-b00f-d4d4ddaab9ab=4],id=[80],priority=[2000],]
rule 8: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x800,nw_dst=10.42.13.0/24,nw_src=10.42.13.0/24]],actionsList=[Slice:33a83d5f-4da1-4d98-8095-8b62623c26b1=4],id=[87],priority=[2000],]
rule 9: FlowEntry[dpid=[06:d6:84:34:97:c6:c9:00],ruleMatch=[OFMatch[dl_type=0x806,nw_dst=10.42.13.0/24,nw_src=10.42.13.0/24]],actionsList=[Slice:33a83d5f-4da1-4d98-8095-8b62623c26b1=4],id=[88],priority=[2000],]

lnevers@flowvisor:~$ fvctl --passwd-file=/etc/flowvisor.passwd dumpConfig /tmp/flowvisor-config
lnevers@flowvisor:~$ more /tmp/flowvisor-config
{
   "flowvisor": [
      {
         "api_webserver_port": 8080,
         "api_jetty_webserver_port": -1,
         "checkpointing": false,
         "listen_port": 6633,
         "track_flows": false,
         "stats_desc_hack": false,
         "run_topology_server": false,
         "logging": "NOTE",
         "log_ident": "flowvisor",
         "log_facility": "LOG_LOCAL7",
         "version": "flowvisor-0.9",
         "host": "localhost",
         "default_flood_perm": "fvadmin",
         "config_name": "default"
      }
   ],
   "Slice": [
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "fvadmin",
         "creator": "fvadmin",
         "passwd_crypt": "xxxxxx",
         "passwd_salt": "xxxxxx",
         "controller_hostname": "none",
         "controller_port": 0,
         "contact_email": "fvadmin@localhost",
         "drop_policy": "exact",
         "lldp_spam": true
      },
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "8a0abd6f-0f5a-469f-91d2-c7f990b8494e",
         "creator": "fvadmin",
         "passwd_crypt": "xxxx",
         "passwd_salt": "xxx",
         "controller_hostname": "naxos.gpolab.bbn.com",
         "controller_port": 33015,
         "contact_email": "jbs@pgeni.gpolab.bbn.com",
         "drop_policy": "exact",
         "lldp_spam": true
      },
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7",
         "creator": "fvadmin",
         "passwd_crypt": "xxxx",
         "passwd_salt": "xxxx",
         "controller_hostname": "naxos.gpolab.bbn.com",
         "controller_port": 33016,
         "contact_email": "jbs@pgeni.gpolab.bbn.com",
         "drop_policy": "exact",
         "lldp_spam": true
      },
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "b7850c93-110f-4e63-a121-26f3449dac44",
         "creator": "fvadmin",
         "passwd_crypt": "xxxx",
         "passwd_salt": "-xxx",
         "controller_hostname": "naxos.gpolab.bbn.com",
         "controller_port": 31750,
         "contact_email": "tupty@pgeni.gpolab.bbn.com",
         "drop_policy": "exact",
         "lldp_spam": true
      },
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "03f03910-1176-428b-b00f-d4d4ddaab9ab",
         "creator": "fvadmin",
         "passwd_crypt": "xxx",
         "passwd_salt": "xxx",
         "controller_hostname": "mallorea.gpolab.bbn.com",
         "controller_port": 33020,
         "contact_email": "lnevers@pgeni.gpolab.bbn.com",
         "drop_policy": "exact",
         "lldp_spam": true
      },
      {
         "config_name": "default",
         "flowmap_type": "federated",
         "name": "33a83d5f-4da1-4d98-8095-8b62623c26b1",
         "creator": "fvadmin",
         "passwd_crypt": "xxxx",
         "passwd_salt": "-xxx",
         "controller_hostname": "mallorea.gpolab.bbn.com",
         "controller_port": 33017,
         "contact_email": "lnevers@bbn.com",
         "drop_policy": "exact",
         "lldp_spam": true
      }
   ],
   "FlowSpaceRule": [
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2048,
         "nw_src": 170528512,
         "nw_dst": 170528512,
         "wildcards": 3279087,
         "slice_action": [
            {
               "8a0abd6f-0f5a-469f-91d2-c7f990b8494e": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2054,
         "nw_src": 170528512,
         "nw_dst": 170528512,
         "wildcards": 3279087,
         "slice_action": [
            {
               "8a0abd6f-0f5a-469f-91d2-c7f990b8494e": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2048,
         "nw_src": 170528768,
         "nw_dst": 170528768,
         "wildcards": 3279087,
         "slice_action": [
            {
               "a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2054,
         "nw_src": 170528768,
         "nw_dst": 170528768,
         "wildcards": 3279087,
         "slice_action": [
            {
               "a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2048,
         "nw_src": 171048960,
         "nw_dst": 171048960,
         "wildcards": 3412207,
         "slice_action": [
            {
               "b7850c93-110f-4e63-a121-26f3449dac44": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2054,
         "nw_src": 171048960,
         "nw_dst": 171048960,
         "wildcards": 3412207,
         "slice_action": [
            {
               "b7850c93-110f-4e63-a121-26f3449dac44": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2048,
         "nw_src": 170527488,
         "nw_dst": 170527488,
         "wildcards": 3279087,
         "slice_action": [
            {
               "03f03910-1176-428b-b00f-d4d4ddaab9ab": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2054,
         "nw_src": 170527488,
         "nw_dst": 170527488,
         "wildcards": 3279087,
         "slice_action": [
            {
               "03f03910-1176-428b-b00f-d4d4ddaab9ab": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2048,
         "nw_src": 170528000,
         "nw_dst": 170528000,
         "wildcards": 3279087,
         "slice_action": [
            {
               "33a83d5f-4da1-4d98-8095-8b62623c26b1": 4
            }
         ]
      },
      {
         "dpid": "6d6843497c6c900",
         "priority": 2000,
         "in_port": 0,
         "dl_type": 2054,
         "nw_src": 170528000,
         "nw_dst": 170528000,
         "wildcards": 3279087,
         "slice_action": [
            {
               "33a83d5f-4da1-4d98-8095-8b62623c26b1": 4
            }
         ]
      }
   ]
}
lnevers@flowvisor:~$ 

Login to FOAM host to show configuration and active flows:

<<INSERT CONFIG>>>

lnevers@foam:~$ foamctl geni:list-slivers --passwd-file=/etc/foam.passwd
{
 "slivers": [
  {
   "status": "Approved", 
   "sliver_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+jbs15:8a0abd6f-0f5a-469f-91d2-c7f990b8494e", 
   "creation": "2012-12-14 04:00:28.080797+00:00", 
   "pend_reason": null, 
   "expiration": "2013-06-15 23:00:00+00:00", 
   "deleted": "False", 
   "user": "urn:publicid:IDN+pgeni.gpolab.bbn.com+user+jbs", 
   "slice_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+jbs15", 
   "enabled": true, 
   "email": "jbs@pgeni.gpolab.bbn.com", 
   "flowvisor_slice": "8a0abd6f-0f5a-469f-91d2-c7f990b8494e", 
   "desc": "JBS 15 OpenFlow resources at BBN InstaGENI.", 
   "ref": null, 
   "id": 3, 
   "uuid": "8a0abd6f-0f5a-469f-91d2-c7f990b8494e"
  }, 
  {
   "status": "Approved", 
   "sliver_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+jbs16:a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7", 
   "creation": "2012-12-14 04:20:35.194373+00:00", 
   "pend_reason": null, 
   "expiration": "2013-06-15 23:00:00+00:00", 
   "deleted": "False", 
   "user": "urn:publicid:IDN+pgeni.gpolab.bbn.com+user+jbs", 
   "slice_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+jbs16", 
   "enabled": true, 
   "email": "jbs@pgeni.gpolab.bbn.com", 
   "flowvisor_slice": "a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7", 
   "desc": "JBS 16 OpenFlow resources at BBN InstaGENI.", 
   "ref": null, 
   "id": 4, 
   "uuid": "a92990b6-1ede-4dd7-b6f6-7b4a4bd36fd7"
  }, 
  {
   "status": "Approved", 
   "sliver_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+tuptymon:b7850c93-110f-4e63-a121-26f3449dac44", 
   "creation": "2013-01-04 20:37:52.926324+00:00", 
   "pend_reason": null, 
   "expiration": "2013-05-30 00:00:00+00:00", 
   "deleted": "False", 
   "user": "urn:publicid:IDN+pgeni.gpolab.bbn.com+user+tupty", 
   "slice_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+tuptymon", 
   "enabled": true, 
   "email": "tupty@pgeni.gpolab.bbn.com", 
   "flowvisor_slice": "b7850c93-110f-4e63-a121-26f3449dac44", 
   "desc": "tuptymon OpenFlow resources at BBN InstaGENI.", 
   "ref": null, 
   "id": 9, 
   "uuid": "b7850c93-110f-4e63-a121-26f3449dac44"
  }, 
  {
   "status": "Approved", 
   "sliver_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+IG-CT-4:03f03910-1176-428b-b00f-d4d4ddaab9ab", 
   "creation": "2013-03-01 17:14:31.208891+00:00", 
   "pend_reason": null, 
   "expiration": "2013-03-08 00:00:00+00:00", 
   "deleted": "False", 
   "user": "urn:publicid:IDN+pgeni.gpolab.bbn.com+user+lnevers", 
   "slice_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+IG-CT-4", 
   "enabled": true, 
   "email": "lnevers@pgeni.gpolab.bbn.com", 
   "flowvisor_slice": "03f03910-1176-428b-b00f-d4d4ddaab9ab", 
   "desc": "New Site Confirmation Test IG-CT-4 ", 
   "ref": null, 
   "id": 39, 
   "uuid": "03f03910-1176-428b-b00f-d4d4ddaab9ab"
  }, 
  {
   "status": "Approved", 
   "sliver_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+SHORT-IG-CT-4:33a83d5f-4da1-4d98-8095-8b62623c26b1", 
   "creation": "2013-03-04 18:50:51.555551+00:00", 
   "pend_reason": null, 
   "expiration": "2013-03-08 00:00:00+00:00", 
   "deleted": "False", 
   "user": "urn:publicid:IDN+pgeni.gpolab.bbn.com+user+lnevers", 
   "slice_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+SHORT-IG-CT-4", 
   "enabled": true, 
   "email": "lnevers@bbn.com", 
   "flowvisor_slice": "33a83d5f-4da1-4d98-8095-8b62623c26b1", 
   "desc": "OpenFlow Experiment Example", 
   "ref": null, 
   "id": 41, 
   "uuid": "33a83d5f-4da1-4d98-8095-8b62623c26b1"
  }
 ]
}
lnevers@foam:~$ 

Attachments (3)

Download all attachments as: .zip