Opened 5 years ago

Closed 5 years ago

#1351 closed (fixed)

SCS: 2 hop path has no dependencies

Reported by: Aaron Helsinger Owned by: xyang@maxgigapop.net
Priority: major Milestone:
Component: STITCHING Version: SPIRAL7
Keywords: Cc:
Dependencies:

Description

A circuit from Utah DDC to PG Utah shows no dependencies between the hops at the SCS. One of those should depend on the other, though it doesn't matter which.

Attachments (1)

ddc_emulab.rspec (2.0 KB) - added by Aaron Helsinger 5 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by Aaron Helsinger

Presumably the issue is that there is no heuristic for the case where hops on 2 facing AMs both do not do VLAN translation. In such a case 1 needs to depend on the other. Perhaps pick the one that has fewer VLANs to pick from, or which has more other stitching ports that do not do translation (on the theory that tags are more constrained there).

Attached request RSpec illustrates the problem.

Changed 5 years ago by Aaron Helsinger

Attachment: ddc_emulab.rspec added

comment:2 Changed 5 years ago by xyang@maxgigapop.net

Resolution: fixed
Status: newclosed

Added tie breaker for between non-translation aggregates that have equal number of hops and equal VLAN range size.

Note: See TracTickets for help on using tickets.