Opened 5 years ago

Closed 5 years ago

#1347 closed (fixed)

ION allocates VLAN not in requested range

Reported by: lnevers@bbn.com Owned by: lnevers@bbn.com
Priority: major Milestone:
Component: STITCHING Version: SPIRAL7
Keywords: GENI Network Stitching Cc: xyang@maxgigapop.net
Dependencies:

Description

In a scenario that includes Rutgers and UKYPKS2 connected by two links errors are reported for the ION createsliver that show that VLANs not in the requested ranges are used. The command output:

$ stitcher.py createsliver loop-rut-pks23 /home/lnevers/gcf-test/stitch-test/stitch-loop-ig-rut-ig-pks2.rspec --ionRetryIntervalSecs 120 --ionStatusIntervalSecs 60 -o
...

14:19:48 INFO    : Calling SCS...
14:19:50 INFO    : Multi-AM reservation will include resources from these aggregates:
14:19:50 INFO    : 	<Aggregate ukypks2-ig>
14:19:50 INFO    : 	<Aggregate rutgers-ig>
14:19:50 INFO    : 	<Aggregate ion>
14:19:50 INFO    : Stitcher doing createsliver at <Aggregate ukypks2-ig>...
14:20:48 INFO    : ... Allocation at <Aggregate ukypks2-ig> complete.
14:20:49 INFO    : Stitcher doing createsliver at <Aggregate rutgers-ig>...
14:21:41 INFO    : ... Allocation at <Aggregate rutgers-ig> complete.
14:21:41 INFO    : Stitcher doing createsliver at <Aggregate ion>...
14:22:27 INFO    : DCN AM <Aggregate ion>: must wait for status ready....
14:22:27 INFO    : Pausing 60 seconds to let circuit become ready...
14:23:43 ERROR   : <Aggregate ion> gave VLAN 3733 for hop <Hop u'urn:publicid:IDN+ion.internet2.edu+interface+rtr.wash:xe-0/2/2:rutgers-ig' on path u'link2'> which is not in our request 3739
14:23:43 ERROR   : <Aggregate ion> gave VLAN 3730 for hop <Hop u'urn:publicid:IDN+ion.internet2.edu+interface+rtr.wash:xe-0/2/2:rutgers-ig' on path u'link'> which is not in our request 3735
14:23:43 ERROR   : <Aggregate ion> gave VLAN 1836 for hop <Hop u'urn:publicid:IDN+ion.internet2.edu+interface+rtr.atla:xe-0/1/3:ukypks2-ig' on path u'link2'> which is not in our request 1843
14:23:43 ERROR   : <Aggregate ion> gave VLAN 1834 for hop <Hop u'urn:publicid:IDN+ion.internet2.edu+interface+rtr.atla:xe-0/1/3:ukypks2-ig' on path u'link'> which is not in our request 1849
14:23:43 INFO    : ... Allocation at <Aggregate ion> complete.
14:23:43 WARNING : Stitching failed but will retry: VLAN was unavailable at <Aggregate ion> and not enough available VLAN tags at <Hop u'urn:publicid:IDN+ion.internet2.edu+interface+rtr.wash:xe-0/2/2:rutgers-ig' on path u'link2'> to try again locally. Try again from the SCS
14:23:43 INFO    : Deleting existing reservations...

...

}}}}

The command completed on the next attempt without any problem. Attaching request and manifest RSpecs along with stitcher logs and full command output.

Attachments (4)

loop-rut-pks23-manifest-rspec-ion-internet2-edu.xml (13.0 KB) - added by lnevers@bbn.com 5 years ago.
loop-rut-pks23-createsliver-request-11-ion-internet2-edu.xml (8.2 KB) - added by lnevers@bbn.com 5 years ago.
loop-rut-pks23-log.txt (4.1 KB) - added by lnevers@bbn.com 5 years ago.
stitcher.log.1 (290.3 KB) - added by lnevers@bbn.com 5 years ago.

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by lnevers@bbn.com

Changed 5 years ago by lnevers@bbn.com

Attachment: loop-rut-pks23-log.txt added

Changed 5 years ago by lnevers@bbn.com

Attachment: stitcher.log.1 added

comment:1 Changed 5 years ago by lnevers@bbn.com

On 10/9/14 3:20 PM, Aaron Helsinger wrote:

The request sent to the ION AM listed suggested and available both as a single tag (3739 as in the first hop below). But the manifest gave a different tag. An AM problem.

comment:2 Changed 5 years ago by xyang@maxgigapop.net

Owner: changed from somebody to xyang@maxgigapop.net
Status: newassigned

comment:3 Changed 5 years ago by xyang@maxgigapop.net

Cc: xyang@maxgigapop.net added
Owner: changed from xyang@maxgigapop.net to lnevers@bbn.com

Problem cannot be reproduced. There could be multiple rounds of createsliver for the same slice while the stitcher manipulates VLANs in the rspec. Need to verify if the manifest is really from request of same round.

comment:4 Changed 5 years ago by lnevers@bbn.com

Status: assignedaccepted

Working on reproducing the problem

comment:5 Changed 5 years ago by lnevers@bbn.com

Resolution: fixed
Status: acceptedclosed

Re-ran test case 15 times and the request worked correctly on each attempt. Cannot reproduce, closing ticket.

Note: See TracTickets for help on using tickets.