Opened 6 years ago

Closed 6 years ago

#1052 closed (fixed)

Support ExoGENI RSpec with free form URN formats

Reported by: xyang@maxgigapop.net Owned by: Aaron Helsinger
Priority: major Milestone:
Component: MAXSCS Version: SPIRAL5
Keywords: Cc: lnevers@bbn.com, tlehman@maxgigapop.net, xyang@maxgigapop.net
Dependencies:

Description

Across-the-board changes have been done to support "free form" URN formats.

Most URNs in main body and stitching extension use node+x, switchport+x:y and interface+x:y or interface+x:y:z format. Here x:y:z represents hierarchical node:port:link names separated by a colon sign. There should be no extra colon sign in node (x), port (y) and link (z) names.

Attached is an !ExoGENI Ad RSpec that does not support this representation. All existing topology data structure, Ad parsing, ID / object lookup, request and reply formatting etc. logic has to be changed to handle this case.

Extensive code changes have been made to the test SCS on the oingo host. The NICTA-ExoGENI topology has been added to SCS. Limited tests have been done. More extensive regression tests may be done along with the ongoing stitching client tests. We can keep this open as continuing work.

Attachments (1)

rspec-nicta-exogeni-net-v1.xml (8.1 KB) - added by xyang@maxgigapop.net 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by xyang@maxgigapop.net

comment:1 Changed 6 years ago by Aaron Helsinger

Resolution: fixed
Status: newclosed

This seems to be working. If specific issues are found, open a new ticket.

Note: See TracTickets for help on using tickets.