Opened 7 years ago

Closed 7 years ago

#1021 closed (fixed)

malformed request results in malformed manifest

Reported by: Aaron Helsinger Owned by: xyang@maxgigapop.net
Priority: major Milestone:
Component: I2AM Version: SPIRAL5
Keywords: Cc: tlehman@maxgigapop.net, ckotil@grnoc.iu.edu
Dependencies:

Description

I submitted a request RSpec to the ION AM with only a stitching extension, no matching <link> element. The return manifest was </rspec> - that's the whole thing.

Instead, an error should have been raised.

Change History (3)

comment:1 Changed 7 years ago by xyang@maxgigapop.net

Status: newassigned

I am getting the following on my own test ION AM, which is different than the reported above.

"Asked http://alpha.dragon.maxgigapop.net:12346 to reserve resources. No manifest Rspec returned. : CreateSliver: Internal API error: Destination 'urn:publicid:IDN+ion.internet2.edu+interface+rtr.newy:xe-0/1/2:nyu' is not valid end point - check the Ad RSpec."

Chad,

Can you update the AM code first and then let's see where we are?

Also add link urn:publicid:IDN+ion.internet2.edu+interface+rtr.newy:xe-0/1/2:nyu into the topology if it is not there yet.

comment:2 Changed 7 years ago by Aaron Helsinger

Wait, I don't want the nyu endpoint in the topology. The whole idea was that I was trying to request something that the ION AM should not be giving me. My next step was going to be an al2s endpoint.

comment:3 Changed 7 years ago by xyang@maxgigapop.net

Resolution: fixed
Status: assignedclosed

Could not reproduce the issue. Close the ticket.

Note: See TracTickets for help on using tickets.