Opened 9 years ago

Closed 9 years ago

#47 closed (fixed)

Creating a sliver with 2 BBN VMs and 2 RCI VMs results in 4 hosts at BBN Rack

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone: EG-EXP-4
Component: Experiment Version: SPIRAL4
Keywords: sliver creation Cc:
Dependencies:

Description

Created an experiment named EG-EXP-4-exp2a, which includes a topology with 4 VMs, 2 @bbnvmsite and 2 @rcivmsite. No problems were reported during the sliver creation.

When checking the sliver manifest, the client ids show that both RENCI and BBN VMs are allocated, but the hosts addresses in the sliver manifest RSpec allocated are all for BBN rack addresses:

<node client_id="7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#bbnvm2"
component_id="urn:publicid:IDN+geni-orca.renci.org+bbnvmsite.rdf#bbnvmsite/Domain" 
exclusive="true" sliver_id="urn:publicid:IDN+geni-orca.renci.org+sliver+urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+EG-EXP-4-exp2a+7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#bbnvm2">    
<login authentication="ssh-keys" hostname="192.1.242.12" port="22" username="root"/>     
 

<node client_id="7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#bbnvm1" 
component_id="urn:publicid:IDN+geni-orca.renci.org+bbnvmsite.rdf#bbnvmsite/Domain" 
exclusive="true" sliver_id="urn:publicid:IDN+geni-orca.renci.org+sliver+urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+EG-EXP-4-exp2a+7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#bbnvm1">    
<login authentication="ssh-keys" hostname="192.1.242.11" port="22" username="root"/>      

<node client_id="7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#rcivm1" 
component_id="urn:publicid:IDN+geni-orca.renci.org+rcivmsite.rdf#rcivmsite/Domain" 
exclusive="true" sliver_id="urn:publicid:IDN+geni-orca.renci.org+sliver+urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+EG-EXP-4-exp2a+7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#rcivm1">    
<login authentication="ssh-keys" hostname="192.1.242.13" port="22" username="root"/>      

<node client_id="7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#rcivm2" 
component_id="urn:publicid:IDN+geni-orca.renci.org+rcivmsite.rdf#rcivmsite/Domain" 
exclusive="true" sliver_id="urn:publicid:IDN+geni-orca.renci.org+sliver+urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+EG-EXP-4-exp2a+7e95c2a1-e6df-4f0d-b070-e02ca40f5d7e#rcivm2">    
<login authentication="ssh-keys" hostname="192.1.242.7" port="22" username="root"/>      

These are all BBN rack addresses, not RENCI rack (152.54.14.x).

Attaching the Request RSpec and the resulting sliver manifest. Experiment EG-EXP-4-exp2a is left running.

Attachments (2)

EG-EXP-4-exp2.rspec (2.7 KB) - added by lnevers@bbn.com 9 years ago.
EG-EXP-4-exp2a-rspec-geni-renci-org-11443-orca.xml (5.8 KB) - added by lnevers@bbn.com 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by lnevers@bbn.com

Attachment: EG-EXP-4-exp2.rspec added

Changed 9 years ago by lnevers@bbn.com

comment:1 Changed 9 years ago by lnevers@bbn.com

Capturing comments from email exchange previous to 6/6 meeting:

On 6/5/12 7:56 PM, Luisa Nevers wrote:

EG-EXP-4:

  • Ticket 47 - Creating a sliver with 2 BBN VMs and 2 RCI VMs results in 4 hosts in the BBN Rack. This problem is reproducible and is blocking to this test case.

On 6/6/12 10:28 AM, Ilia Baldine wrote:

Ticket 47: the rspec converter does not handle this type of a request properly. You can do this in flukes using two node groups and have a broadcast link for one of the groups.

In general rspec conversion issues related to the new functionality to support acceptance testing we just added will be resolved next week. This does not include stitching rspec work as that will take longer and based on my understanding is not as high priority as supporting acceptance tests.

comment:2 Changed 9 years ago by lnevers@bbn.com

Updating the ticket to capture the current behaviour of the createsliver with the same rspec that requests the following:

  • 2 VMs at BBN and 2 VMs at RENCI.
  • Each of the VMs have a connection to network 172.16.2.0.
  • Additionally both BBN VMs have an additional interface on 172.16.3.0.

The createsliver now reports the following:

Asked https://geni.renci.org:11443/orca/xmlrpc to reserve resources. No manifest Rspec 
returned. ERROR: Exception encountered: orca.ndl.NdlException: BroadcastConnection 
e0254a0d-fef8-4f6e-b6ae-8a396107f27f#site2site cannot be split between domains 

As explained by Ilia's earlier comment, a broadcast link is only supported via flukes,

comment:3 Changed 9 years ago by ibaldin@renci.org

This isn't entirely accurate. Broadcast links are supported in RSpec as well (implicitly - you don't have to specify this in RSpec, because the converter determines this automatically). The limitation is, as stated in the error above, that broadcast links cannot be split between domains. Only point-to-point links can be split.

comment:4 Changed 9 years ago by lnevers@bbn.com

Ilia, Sorry that I missed the nuance about the broadcast link restriction being across racks in my comment. Although, the error message does capture it, so there should be no confusion for the experimenter. :-).

comment:5 Changed 9 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

This ticket should have been closed when the last comment was added, no issue remains.

Note: See TracTickets for help on using tickets.