Opened 9 years ago

Closed 9 years ago

#97 closed (fixed)

Northwestern procurve2 switch configuration inconsistencies

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone:
Component: Experiment Version: SPIRAL5
Keywords: confirmation tests Cc: jim-chen@northwestern.edu
Dependencies:

Description

As part of the InstaGENI Confirmation testing there is a check to verify that the new site switch configuration is somewhat consistent with the existing GPO switch configuration.

The Northwestern rack data plane switch procurve2 differs for VLAN configuration on GPO, there are 4 differences below, please provide and explanation for each.

Note: I am ignoring interface name differences, but expect that the configuration is consistent for number of ports and settings configured for a VLAN

  1. Northwestern had one network for VLAN 10:
    vlan 10 
    name "control-hardware" 
    untagged A20 
    ip address 10.3.1.253 255.255.255.0
    
    while GPO has 2 network for the same VLAN 10:
    vlan 10 
    name "control-hardware" 
    untagged E20 
    ip address 10.2.1.253 255.255.255.0 
    ip address 10.3.1.253 255.255.255.0 
    
  1. GPO has 4 VLANs (1, 10, 257, 1750) while Northwestern has 6 VLANs (1, 10, 257, 258, 259, 1750).
  1. Northwestern VLAN 1 includes:
     vlan 1 
     name "DEFAULT_VLAN" 
     forbid A3,A6 
     untagged A4-A5,A7-A12,A14-A19,A21-A23 
     no untagged A1-A3,A6,A13,A20,A24 
     no ip address 
    
    While GPO VLAN 1 includes ranges that do not quite match:
    vlan 1 
    name "DEFAULT_VLAN" 
    forbid E1-E3,E5-E6 
    untagged A1-A24,E7-E19,E21-E22 
    tagged E23 
    no untagged E1-E6,E20,E24 
    no ip address 
    
  1. Northwestern VLAN 1750 includes:
     vlan 1750 
     name "_11" 
     tagged E4,E24 
     no ip address 
    
    While GPO VLAN 1750 includes:
    vlan 1750 
    name "_3" 
    tagged A1-A2,A24 
    no ip address 
    

Change History (1)

comment:1 Changed 9 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

Adding email exchange that took place outside this ticket:

On 2/19/13 1:29 PM, Leigh Stoller wrote:

The Northwestern rack data plane switch procurve2 differs for VLAN configuration on GPO, there are 4 differences below, please provide and explanation for each.

Sorry, that cannot be done; Every switch on every rack will be different from the moment it is installed and people start using the rack. Others on this list can probably provide clarification if needed.

Lbs

On 2/19/13 1:52 PM, Nicholas Bastin wrote:

On Tue, Feb 19, 2013 at 1:03 PM, GENI: instageni <trac@geni.net> wrote:

As part of the InstaGENI Confirmation testing there is a check to verify that the new site switch configuration is somewhat consistent with the existing GPO switch configuration.

The NW configuration is sufficiently consistent with every other deployment. All site topologies are going to be at least slightly different (and thus generate config differences, including for mundane things like what slot the card is plugged into), so we probably should not do this test, but rather just make sure that the functional requirements are met without caring about how.

-- Nick

This ticket is being closed, expected level of consistency will not take place at each site.

Note: See TracTickets for help on using tickets.