Opened 9 years ago

Closed 9 years ago

#9 closed (fixed)

creating 4 node linear sliver fails with <Fault -32600: 'Internal Error executing CreateSliver'>

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone:
Component: AM Version: SPIRAL4
Keywords: AM API Cc:
Dependencies:

Description

Created a 4 VMs linear topology which failed with the following error:

ERROR:omni.protogeni:Call for Create Sliver urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+pglinear at https://boss.utah.geniracks.net/protogeni/xmlrpc/am/2.0 failed. Server says: <Fault -32600: 'Internal Error executing CreateSliver'>

The sliver failed around 9:40 and the slice was named "pglinear". The rspec used is attached.

Attachments (1)

insta-4vm-linear-insta-utah.rspec (2.4 KB) - added by lnevers@bbn.com 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by lnevers@bbn.com

comment:1 Changed 9 years ago by lnevers@bbn.com

On 5/7/12 9:59 AM, Leigh Stoller wrote:

#9: creating 4 node linear sliver fails with <Fault -32600: #'Internal Error executing CreateSliver?'>

So the problem is that the experimental switch in the rack is frozen. We have noticed that the procurve 6600 that came in the rack has a problem of some kind; About once a week it freezes up and has to be reset by hand.

The RPC error is caused by some bitrot in the failure path, which I will fix today.

We have a spare 5400 chasis but no line card. We are hoping to get a line card from someplace so that we can switch over, but not sure when that is going to happen.

Note to Utah people; when someone arrives at the office, please reset the 6600 (second from the top of the rack). Might have to unplug it from the front; I noticed the reset button no longer does anything.

Lbs


On 5/7/12 4:48 PM, Robert Ricci wrote:

And to be clear on the subject of the 5400: no other rack is going to have the problematic 6600. This was changed on the bill of materials after our rack shipped, and getting the linecard for the 5400 will give our rack the same hardware that future racks will have.

On 7 May 2012, at 7:59, Leigh Stoller wrote:

We have a spare 5400 chasis but no line card. We are hoping to get a line card from someplace so that we can switch over, but not sure when that is going to happen.


The aggregate seems to be off line, will try again tomorrow:

ERROR:omni.protogeni:Call for Create Sliver urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+insta4linear at https://boss.utah.geniracks.net/protogeni/xmlrpc/am/2.0 failed. Server says: <Fault 503: 'CM temporarily offline; please try again later'>

If I should not re-try please let me know.

comment:2 Changed 9 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

Re-ran the experiment with the 4 VM linear topology and it was successful. Was able to exchange end-to-end traffic on the assigned VMs. Since the ticket was originally intended to cover the 4 node linear experiment, it is being closed.

Note: See TracTickets for help on using tickets.