Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#84 closed (fixed)

Utah FOAM sliver is both "configuring" and "approved'

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone:
Component: Experiment Version: SPIRAL5
Keywords: Cc:
Dependencies:

Description

Successfully created a sliver IG-EXP-6-exp2 at the Utah InstaGENI FOAM, which is attached to this ticket.

After the sliver was approved, checked the sliverstatus which showed that the sliver was "configuring" and "approved" for the past 30 minutes.

INFO:omni:{
  "geni_status": "configuring", 
  "geni_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+IG-EXP-6-exp2:8c6ca8df-757b-4628-aae7-52a81f64cbc6", 
  "foam_pend_reason": null, 
  "foam_expires": "2013-01-11 00:00:00+00:00", 
  "geni_resources": [
    {
      "geni_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+IG-EXP-6-exp2:8c6ca8df-757b-4628-aae7-52a81f64cbc6", 
      "geni_error": "", 
      "geni_status": "configuring"
    }
  ], 
  "foam_status": "Approved"
}

Attachments (1)

IG-EXP-6-exp2-openflow-ig-utah.rspec (1.3 KB) - added by lnevers@bbn.com 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by lnevers@bbn.com

comment:1 Changed 9 years ago by lnevers@bbn.com

While trying to get a listresources for the Utah IG FOAM got the following failures:

$ ./src/omni.py listresources -a ig-of-utah  -V1
INFO:omni:Loading config file /home/lnevers1/.gcf/omni_config
INFO:omni:Using control framework pg
INFO:omni:Substituting AM nickname ig-of-utah with URL https://foam.utah.geniracks.net:3626/foam/gapi/1, URN unspecified_AM_URN
INFO:omni:Substituting AM nickname ig-of-utah with URL https://foam.utah.geniracks.net:3626/foam/gapi/1, URN unspecified_AM_URN
ERROR:omni.protogeni:Call for List Resources at https://foam.utah.geniracks.net:3626/foam/gapi/1 failed. Server says: <Fault 1: "<type 'exceptions.Exception'>:">
WARNING:omni:No resource listing returned!
INFO:omni:Listed advertised resources at 0 out of 1 possible aggregates.
INFO:omni:Substituting AM nickname ig-of-utah with URL https://foam.utah.geniracks.net:3626/foam/gapi/1, URN unspecified_AM_URN
WARNING:omni:No RSpec returned from foam-utah-geniracks-net
INFO:omni:<!-- Resources at AM:
	URN: unspecified_AM_URN
	URL: https://foam.utah.geniracks.net:3626/foam/gapi/1
 -->
INFO:omni:<!-- No valid RSpec returned. -->
INFO:omni: ------------------------------------------------------------
INFO:omni: Completed listresources:

  Options as run:
		aggregate: ['ig-of-utah']
		api_version: 1
		framework: pg

  Args: listresources

  Result Summary: Queried resources from 0 of 1 aggregate(s).
No resources from AM https://foam.utah.geniracks.net:3626/foam/gapi/1: <Fault 1: "<type 'exceptions.Exception'>:"> (missing result) 

comment:2 Changed 9 years ago by chaos@bbn.com

Our nagios just started failing to run listresources against foam.utah.geniracks.net. Could flowvisor be down?

comment:3 Changed 9 years ago by nick.bastin@gmail.com

Resolution: fixed
Status: newclosed

comment:4 Changed 9 years ago by lnevers@bbn.com

Verified that the problem is resolved, ticket is already closed.

Note: See TracTickets for help on using tickets.