Opened 9 years ago

Closed 9 years ago

#7 closed (fixed)

creating a sliver with one raw-pc and one VM fails with a "Could not verify topo" error

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone:
Component: AM Version: SPIRAL4
Keywords: Cc:
Dependencies:

Description

Using an rspec that includes 1 VM and one raw pc results in a create sliver failure that reports:

  Result Summary: Slice urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+instadoh expires within 1 day(s) on 2012-05-02 19:13:25 UTC
Asked https://boss.utah.geniracks.net/protogeni/xmlrpc/am/2.0 to reserve resources. No manifest Rspec returned. Could not verify topo 

Following is the RSpec used, which passes rspeclint:

<?xml version="1.0" encoding="UTF-8"?>
<rspec xmlns="http://www.protogeni.net/resources/rspec/2"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://www.protogeni.net/resources/rspec/2 http://www.protogeni.net/resources/rspec/2/request.xsd"
       type="request" >

 <node client_id="VM" component_manager_id="urn:publicid:IDN+utah.geniracks.net+authority+cm" exclusive="false">
    <sliver_type name="emulab-openvz"/>
    <interface client_id="VM:if0">
    </interface>
  </node>
  <node client_id="PC" component_manager_id="urn:publicid:IDN+utah.geniracks.net+authority+cm" exclusive="true">
    <sliver_type name="raw-pc"/>
    <interface client_id="PC:if0">
    </interface>
  </node>
  <link client_id="lan0">
    <component_manager name="urn:publicid:IDN+utah.geniracks.net+authority+cm"/>
    <interface_ref client_id="VM:if0"/>
    <interface_ref client_id="PC:if0"/>
    <property source_id="VM:if0" dest_id="PC:if0"/>
    <property source_id="PC:if0" dest_id="VM:if0"/>
    <link_type name="lan"/>
  </link>
</rspec>

Change History (2)

comment:1 Changed 9 years ago by lnevers@bbn.com

On 5/2/12 5:52 PM, Leigh Stoller wrote:

Okay, why don't you try this one again please ... I think it will work.

Lbs

Just re-ran the sliver creation with the 1 VM and 1 raw pc rspec and was able to create the slivers. I then tried to login to the hosts and ports assigned:

'hostname': 'pc2.utah.geniracks.net', 'port': 30010
'hostname': 'pc5.utah.geniracks.net', 'port': 22,

but is does not work for the VM:

lnevers@sendaria:~$ ssh pc5.utah.geniracks.net
[lnevers@pc ~]$ exit
Connection to pc5.utah.geniracks.net closed.

lnevers@sendaria:~$ ssh pc2.utah.geniracks.net -p 30010
ssh: connect to host pc2.utah.geniracks.net port 30010: Connection refused
lnevers@sendaria:~$ 

comment:2 Changed 9 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

On 5/2/12 6:48 PM, Leigh Stoller wrote:

Odd, I just tried it and it worked. Can you ping pc2 for me, and tell me what the IP address is?

{98} boss$ sudo ssh pc2.utah.geniracks.net -p 30010 Last login: Thu May 3 02:45:17 2012 from boss.utah.geniracks.net [root@VM ~]#

I just tried to login again and I can exchange traffic between the hosts. Sorry, I did not wait long enough. This problem is solved. Closing ticket.

Note: See TracTickets for help on using tickets.