Opened 7 years ago

Closed 7 years ago

#57 closed (fixed)

Unable to login to one of 4 requested VMs.

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone:
Component: Experiment Version: SPIRAL5
Keywords: node access Cc:
Dependencies:

Description

In a scenario where 4 VMs are requested, I am not able to login to one of the VMs.

I have ran into this problem on two separate instances of a 4 VMs sliver. The most current failure occurred on a sliver named IG-CT-1, where I am not able to login to the VM associated with port 30780 on pc3.utah.geniracks.net even though the VM is listed as "ready".

Change History (4)

comment:1 Changed 7 years ago by lnevers@bbn.com

I tried a third sliver with the same 4 VMs RSpec and once again, I am not able to login to one of the VMs. This third sliver is named "IG-CT-1a" and the VM where login fails is port 31036 on pc5.utah.geniracks.net.

comment:2 Changed 7 years ago by lnevers@bbn.com

I realized that I did not explain what I meant by "not being able to login", sorry!

Each of the nodes that failed prompt me to enter a password when I try to login. The ssh keys are not in place. Both slivers are still running, IG-CT-1 & IG-CT-1a.

comment:3 Changed 7 years ago by lnevers@bbn.com

On 11/5/12 5:36 PM, Leigh Stoller wrote:

I installed a fix that Jon made last week. Lets see how it goes now. 
Go ahead and kill off the existing slices and try again please.

Thanks
Lbs

I have set up the 4 VMs sliver twice (IG-CT-1 & IG-CT-1a). The sliver named IG-CT-1 shows the problem with VM-3 prompting for a password. (VM-3=port 30780 on pc3.utah.geniracks.net). The second sliver IG-CT-1a does not and all nodes are accessible.

comment:4 Changed 7 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

Fixes have been applied to the InstaGENI rack to address this problem. There have been stress tests by Jonathan Duerig that used 25 slices which did not show the problem.

I also set up 30 experiments using the 4VM RSpec that originally showed this problem and I have been able to login to each of the 120 VM reserved. This problem is solved, closing ticket.

Note: See TracTickets for help on using tickets.