Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#22 closed task (fixed)

Integrate Labwiki with GENI Portal using OpenID

Reported by: johren@bbn.com Owned by: jack.hong@nicta.com.au
Priority: major Milestone: GEC17
Component: Portal Version: Sprint2
Keywords: Cc:
Dependencies:

Description

Labwiki will use OpenID to authenticate the user using their GENI Portal account.

Jack will work with Tom and Aaron to interface with the Portal's OpenID provider.

Change History (6)

comment:1 Changed 8 years ago by johren@bbn.com

Email from Tom Mitchell on 6/15: Hi Jack,

Our OpenID provider URL is https://portal.geni.net/server/server.php . I can provide additional info if you need it, but that should be all we need to establish a connection.

In order for you to use it, you'll need an account on the GPO Identity Provider. You can apply for an account at https://portal.geni.net/idp/request.html

Cheers, Tom

comment:2 Changed 8 years ago by johren@bbn.com

Email from Jack on 6/16:

Thanks Tom. Already applied for the account and waiting for the outcome. I will let you know after the testing.

comment:3 Changed 8 years ago by jack.hong@nicta.com.au

Integration with generic OpenID auth has been implemented in Labwiki, and has been deployed here: 221.199.209.241:4000

It has been tested with Google OpenID and accounts from myopenid.com (another openid provider).

The issue left is that GENI's OpenID server is not redirecting to labwiki correctly due to its internal setup, it has been confirmed by Marshall and Tom.

Shall we resolve this ticket and open a new one regarding GENI's openid server, or just leave it as it is.

J.

comment:4 Changed 8 years ago by johren@bbn.com

We can leave this ticket open and reassign it to Aaron if he has the remaining work.

comment:5 Changed 8 years ago by jack.hong@nicta.com.au

Resolution: fixed
Status: newclosed

Issue regarding GENI openid has been resolved.

comment:6 Changed 8 years ago by johren@bbn.com

Milestone: GEC17
Note: See TracTickets for help on using tickets.