Opened 8 years ago

Last modified 8 years ago

#21 reopened task

OML upgrade on Fedora 15. Refer Ticket #17

Reported by: divyashri.bhat@gmail.com Owned by: divyashri.bhat@gmail.com
Priority: minor Milestone: GEC19
Component: Authentication/Authorization Version: Backlog
Keywords: OML Cc:
Dependencies:

Description

Can OML 2.10 be made compatible with Fedora 15, which is currently being used on InstaGENI containers?
The GLIBC 2.15 cannot be installed on Fedora 15 and this is supposedly necessary for OML 2.10.

Change History (13)

comment:1 Changed 8 years ago by Christoph.Dwertmann@nicta.com.au

Can you install OML from source? Instructions are here: http://mytestbed.net/projects/oml/wiki/BuildingSource

comment:2 Changed 8 years ago by johren@bbn.com

Version: Sprint3GEC17

comment:3 Changed 8 years ago by Christoph.Dwertmann@nicta.com.au

Divyashri,

have you tried using the f17 packages we provide?

Any chance you can upgrade your distro?

Do you run 32bit or 64bit Fedora?

Kind regards,

Christoph Dwertmann

comment:4 Changed 8 years ago by johren@bbn.com

Owner: changed from Christoph.dwertmann@nicta.com.au to divyashri.bhat@gmail.com
Priority: majorminor

comment:5 Changed 8 years ago by johren@bbn.com

Version: GEC17Backlog

comment:6 Changed 8 years ago by johren@bbn.com

Milestone: GEC18

comment:7 Changed 8 years ago by johren@bbn.com

Version: BacklogSprint2

comment:8 Changed 8 years ago by johren@bbn.com

Version: Sprint2Backlog

Moving back to BackLog? per discussion on status call this morning. We are waiting to see how the Xen support shakes out on InstaGENI.

comment:9 Changed 8 years ago by johren@bbn.com

Milestone: GEC18GEC19

comment:10 Changed 8 years ago by Christoph.Dwertmann@nicta.com.au

Resolution: fixed
Status: newclosed

Packages of OML and OML apps are now available for 32bit f14 and f15: http://oml.mytestbed.net/projects/oml/wiki/Installation#Fedora-14-38-15

Can someone please test them on InstaGENI and report back? Ticket on mytestbed is here: http://mytestbed.net/issues/1354

comment:11 Changed 8 years ago by divyashri.bhat@gmail.com

I ran a couple of tests on the InstaGENI f15 image. A sample program which displays the date ran without any problems.

I am having a few issues with the ping-oml2 application.

[root@nodeE dbhat]# env -i /usr/bin/ping-oml2 -a 192.168.6.12 -c 30 --oml-config /tmp/f40665c6-9478-4c59-b79b-df182a37cc21-1385798310.xml
/usr/bin/ping-oml2:91: undefined (?...) sequence: /^\d+ bytes from (?<host>.*): icmp_seq=(?<icmp_seq>\d+) ttl=(?<ttl>\d+) time=(?<time>[0-9.]+) (?<timeunit>[a-zA-Z]+)/
/usr/bin/ping-oml2:96: undefined (?...) sequence: /^(?<transmitted>\d+).*transmitted, (?<received>\d+).*received, (?<loss>[0-9.]+)%.*loss, time (?<time>[0-9.]+) *(?<timeunit>[a-zA-Z]+)/
/usr/bin/ping-oml2:102: undefined (?...) sequence: /rtt.*= (?<min>[0-9.]+)\/(?<avg>[0-9.]+)\/(?<max>[0-9.]+)\/(?<mdev>[0-9.]+) (?<timeunit>[a-zA-Z]+)/

The packages are installed as shown below

[root@nodeE dbhat]# yum list | grep "oml"
liboml2.i686                            2.10.1-1                       @OML     
oml2.i686                               2.10.1-1                       @OML     
oml2-apps.i686                          2.10.0-1                       @OML     
oml2-server.i686                        2.10.1-1                       @OML     
eclipse-m2m-qvtoml.noarch               3.0.0-2.fc15                   fedora   
liboml2-devel.i686                      2.10.1-1                       OML      
oml2-apps-debuginfo.i686                2.10.0-1                       OML      
oml2-devel.i686                         2.10.1-1                       OML      
photoml.noarch                          0.28-1.fc15                    fedora   
[root@nodeE dbhat]# yum list | grep "omf"
aajohan-comfortaa-fonts.noarch          2.002-5.fc15                   updates  
gallery2-customfield.noarch             2.3.2-1.fc15                   updates  
genromfs.x86_64                         0.5.2-6.fc15                   fedora   
p0rn-comfort.noarch                     0.0.4-11.fc15                  fedora   
trac-customfieldadmin-plugin.noarch     0.2.5-0.2.svn9652.fc15         fedora   

comment:12 Changed 8 years ago by johren@bbn.com

Resolution: fixed
Status: closedreopened

I'm just reopening while this is being tested and verified so it doesn't fall off the list (closed tickets are not displayed).

comment:13 Changed 8 years ago by Christoph.Dwertmann@nicta.com.au

The ping-oml2 script that was shipped with OML apps 2.10 does not support Ruby 1.8. FC15 however does not ship Ruby 1.9. The latest ping-oml2 script brings back 1.8 compatibility.

Please use the ping-oml2 script from the oml4r ruby gem. You can delete /usr/bin/ping-oml2 and then run "gem install oml4r".

Note: See TracTickets for help on using tickets.