Opened 8 years ago

Last modified 8 years ago

#104 new defect

Error downloading measurement data using iDrop

Reported by: dbhat@bbn.com Owned by: shuang@renci.org
Priority: major Milestone: GEC21
Component: iRODS Version: Sprint3
Keywords: Cc:
Dependencies:

Description

As an admin user with my Environment configured to user gimiadmin I am able to view files being pushed by users in all directories.

However, when I configure my irodsEnv from my user profile as shown in the iRODs Account page on the GENI Portal, I am unable to see the file I just dumped from LabWiki.

GENI User name: dbhat
iRODs Username: geni-dbhat1

I have permission to:

1) icd into my directory, i.e,
icd /geniRenci/home/geni-dbhat1:

C- /geniRenci/home/geni-dbhat1/experimentScripts

2) icd into a project which I am a member of , e.g.,
icd /geniRenci/home/geni-GIMITesting I don't have permission to:

1) icd into the experiment context inside the Project, e.g.,
icd /geniRenci/home/geni-GIMITesting/ProductionServer No such directory (collection): /geniRenci/home/geni-GIMITesting/ProductionServer.

2) Since my .sql dump exists in the experiment context which I do not have permission to access, I am unable to see that as well.

Change History (7)

comment:1 Changed 8 years ago by dbhat@bbn.com

Jeanne suggested to use:

icd /geniRenci/home/gimiadmin/geni-GIMITesting/ProductionServer

This was working. I was able to use iget to download my experiment data and view them on my local machine.

Couple of things that were duplicated:
a) There was a directory geni-GIMITesting (project) in /geniRenci/home/ and /geniRenci/home/gimiadmin
b) There was a directory ProductionServer (Experiment Context) in /geniRenci/home/gimiadmin and /geniRenci/home/geni-GIMITesting as well.

In iDrop, when I tried to download my experiment data (path: /geniRenci/home/gimiadmin/geni-GIMITesting/ProductionServer) I got the following error:

Executing action [index] of controller [org.irods.mydrop.controller.FileController] caused exception: Runtime error executing action 

comment:2 Changed 8 years ago by shuang@renci.org

Were /geniRenci/home/gimiadmin/geni-GIMITesting/ and /geniRenci/home/geni-GIMITesting/ created via the geni portal? Which one is the right one to use? I see /geniRenci/home/geni-GIMITesting/ is empty, should I remove it? We are looking into the iDrop error.

comment:3 Changed 8 years ago by johren@bbn.com

/geniRenci/home/gimiadmin/geni-GIMITesting is the right one to use. I was going to ask the same question about /geniRenci/home/geni-GIMITesting/. I'm not sure why and by whom this directory/collection is created. I think we could remove these, but I would like to understand how they are being created.

I believe they get created when a new project is created. I will try it out again today and look at some old emails to confirm.

comment:4 Changed 8 years ago by johren@bbn.com

Summary: iRODs permissions for userError downloading measurement data using iDrop

Changed summary to reflect the iDrop error rather than iRODS permission issue.

comment:5 Changed 8 years ago by johren@bbn.com

Latest email thread:

I haven’t seen him at Renci since last Friday. I would just send him an email pointing him to that collection and asking him to give it a shot from iDrop at his earliest convenience (no pressure!). He has access to the gimiadmin account, right?

My understanding is that this is iDrop desktop and I assume Divya is using the latest version, etc...

On Aug 12, 2014, at 11:50 AM, Shu Huang <shuang@renci.org> wrote:

> Yes. I agree. Will you be able to catch him and describe the problem to him? Or we can set up a meeting and discuss this together. -Shu
> On Aug 11, 2014, at 5:17 PM, de Torcy, Antoine <adetorcy@email.unc.edu> wrote:
>
>> Sounds like we’re going to have to get Mike in the loop then. Shu?
>>
>> On Aug 11, 2014, at 1:21 PM, Divyashri Bhat <dbhat@umass.edu> wrote:
>>
>>> It looks like the iRODS environment is exactly the same on the iDrop and icommands side. The resource is demoResc on both.
>>>
>>> Thanks,
>>> Divya
>>> ________________________________
>>> From: de Torcy, Antoine [adetorcy@email.unc.edu]
>>> Sent: Monday, August 11, 2014 11:11 AM
>>> To: Divyashri Bhat
>>> Cc: Jeanne Ohren; Shu Huang; Divyashri Bhat
>>> Subject: Re: [GENI: gimi] #104: iRODs permissions for user
>>>
>>> No problem. By anything particular I meant is it a mounted or linked collection, but I don’t think it is. Just to make sure I would also check that your iRODS environment (including resource) is exactly the same with iDrop and with the icommands when you access that collection.
>>>
>>> On Aug 11, 2014, at 10:29 AM, Divyashri Bhat <divyashri.bhat@gmail.com<mailto:divyashri.bhat@gmail.com>> wrote:
>>>
>>> I see. Thanks for looking into this Antoine.
>>>
>>> I am not sure I understand what you mean by anything particular. Should I check for date of creation, amount of subfolders, etc?
>>>
>>> I will also try with other directories and see if I get the same error.
>>>
>>>
>>>
>>> On Mon, Aug 11, 2014 at 10:20 AM, de Torcy, Antoine <adetorcy@email.unc.edu<mailto:adetorcy@email.unc.edu>> wrote:
>>> OK. That would seem to confirm that the issue is with iDrop. Is there anything particular about this collection?
>>>
>>>
>>> On Aug 11, 2014, at 10:05 AM, Divyashri Bhat <divyashri.bhat@gmail.com<mailto:divyashri.bhat@gmail.com>> wrote:
>>>
>>> Thanks Jeanne.
>>>
>>> Yes, the directories and files are accessible using icommands.
>>>
>>>
>>> On Mon, Aug 11, 2014 at 9:46 AM, Jeanne Ohren <johren@bbn.com<mailto:johren@bbn.com>> wrote:
>>>
>>> Yes, I do believe these directories are accessible with icommands.  They were in my test case.
>>> Forwarding to Divya at a different address so she can confirm.
>>>
>>> --Jeanne
>>>
>>> On 8/8/14, 7:49 AM, de Torcy, Antoine wrote:
>>> Correct, Mike wrote iDrop. Can you access these directories with the icommands?
>>>
>>>
>>> On Aug 7, 2014, at 11:08 PM, Shu Huang <shuang@renci.org<mailto:shuang@renci.org>> wrote:
>>>
>>> Hi Antoine,
>>>
>>> Is Mike the author of iDrop? The runtime error seems like a bug? I saw some errors like:
>>> readMsgHeader:header read- read 0 bytes, expect 4, status = -4000
>>> and
>>> readStartupPack: readMsgHeader error. status = -4009 status = -4009 SYS_HEADER_READ_LEN_ERR, Bad file descriptor
>>>
>>> Thanks,
>>> Shu
>>>

comment:6 Changed 8 years ago by johren@bbn.com

Divya confirmed this was the iDrop web interface.

Log shows file not found.

Mike Conway is investigating.

comment:7 Changed 8 years ago by dbhat@bbn.com

I tested a fix that Mike and Shu pushed out to the iweb interface. It works great for me. I am able to download my experiment data from iDrop. The file that I tried downloading was for an already existing experiment.

I will test this for new experiment data and the close the ticket.

Note: See TracTickets for help on using tickets.