Version 1 (modified by, 9 years ago) (diff)


To create packages necessary for pip installation.

  1. To get the dependencies of a python package to install, the pip version needs to be 1.1 or greater, pip --version
  1. We generally have an issue with that because the pip that gets installed is version 1.0. Refer to this page:
  1. To get the packages and dependencies with pip 1.1 or greater:
       mkdir ARL-PYTHON
       pip install --download ./ARL-PYTHON celery

  1. Once all the tar files are in that directory, testing of what order the files need to be installed needs to be done. It is best to try this in an Ubuntu VM, since the pip installed on the offline

site will be pip 1.0.

  1. So for flask, this is the order:
cd /home/gram

tar xvzf ARL-PYTHON.tgz  (should get an ARL-PYTHON directory)

pip install ./ARL-PYTHON/Werkzeug-0.9.6.tar.gz
pip install ./ARL-PYTHON/itsdangerous-0.24.tar.gz
pip install ./ARL-PYTHON/Jinja2-2.7.3.tar.gz
pip install ./ARL-PYTHON/Flask-0.10.1.tar.gz