Changes between Version 14 and Version 15 of GeniApiCredentials


Ignore:
Timestamp:
08/28/12 12:45:35 (7 years ago)
Author:
Aaron Helsinger
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • GeniApiCredentials

    v14 v15  
    122122
    123123AM API v3 standardized some additional elements of credentials and certificates. The new requirements with AM API v3 are documented on this page, and known as "geni_sfa v3". This section defines the changes from the old format, now known as geni_sfa v2.
     124
     125'''Note''': AM API v3 added requirements on [wiki:GeniApiIdentifiers URNs] and [wiki:GeniApiCertificates certificates], as well as credentials. A credential is only `geni_sfa` version `3` if all contained certificates and URNs are AM API v3 compliant. Experimenters with existing certificates that are not AM API v3 compliant will only get `geni_sfa` version `2` credentials, unless they first get a new user certificate. As a result, most aggregates should accept both `geni_sfa` version `3` and version `2` credentials.
    124126
    125127The full set of changes proposed and accepted is documented here: http://groups.geni.net/geni/wiki/GAPI_AM_API_V3_DELTAS#Adopted:ChangeSetK:Standardizecertificatesandcredentials