Changes between Version 17 and Version 18 of GENIRacksHome/OpenGENIRacks/RaspberryPIs/DiversityNotes


Ignore:
Timestamp:
06/10/16 14:07:53 (5 years ago)
Author:
rrhain@bbn.com
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • GENIRacksHome/OpenGENIRacks/RaspberryPIs/DiversityNotes

    v17 v18  
    55== Install Node.js and NPM ==
    66
     7
     8{{{
     9sudo apt-get upgrade
     10sudo apt-get update
     11}}}
     12You might need to removed the old nodered, which might not be the package we want
    713{{{
    814sudo apt-get remove nodered
    915sudo apt-get remove nodejs nodejs-legacy
    1016sudo apt-get remove npm
     17}}}
     18And then get the latest node source and install
     19{{{
    1120curl -sL https://deb.nodesource.com/setup_4.x | sudo bash -
    12 sudo apt-get install -y build-essential python-dev nodejs npm
    13 sudo apt-get update
    14 sudo apt-get install -y build-essential python-dev nodejs npm
    15 sudo apt-get install -y build-essential python-dev nodejs
    16 sudo apt-get install -y npm
    17 node -v
    18 sudo apt-get upgrade
    19 sudo apt-get update
    20 sudo apt-get install -y build-essential python-dev nodejs npm
    21 sudo apt-get install npm
     21sudo apt-get install -y build-essential python-dev nodejs
     22}}}
     23npm seems to come with nodejs.  When trying to do an apt-get install npm, I get an error.
     24Running with
     25{{{
     26
     27node --version
     28v4.4.5
     29
     30npm --version
     312.15.5
     32
     33}}}
     34
     35
     36Here is an alternate way to install, but the above method seemed to work.
     37{{{
    2238wget http://node-arm.herokuapp.com/node_latest_armhf.deb
    2339sudo dpkg -i node_latest_armhf.deb