wiki:GENIRacksHome/OpenGENIRacks/ConfirmationTestStatus/GPO

Version 20 (modified by lnevers@bbn.com, 5 years ago) (diff)

--

GENI Project Office (GPO) OpenGENI Confirmation Tests

For details about the tests in this page, see the OpenGENI Confirmation Tests page.
For site status see the OpenGENI New Site Confirmation Tests Status page.

Note: Omni nick_names for site aggregates used for these tests are:

gpo-og=urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am,https://bbn-cam-ctrl-1.gpolab.bbn.com:5002

OG-CT-1 - Access to New Site VM resources

Got Aggregate version, which showed AM API V1, V2, and V3 are supported and V2 is default:

$  omni getversion -a gpo-og 
12:33:49 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
12:33:49 INFO    : Loading config file /home/lnevers/.gcf/omni_config
12:33:49 INFO    : Using control framework portal
12:33:49 INFO    : Member Authority is https://ch.geni.net/MA (from config)
12:33:49 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
12:33:49 INFO    : Substituting AM nickname gpo-og with URL https://bbn-cam-ctrl-1.gpolab.bbn.com:5002, URN urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am
12:33:50 INFO    : AM gpo-og URN: urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am (url: https://bbn-cam-ctrl-1.gpolab.bbn.com:5002) has version:
12:33:50 INFO    : {   'GRAM_version': '3.33',
    'geni_ad_rspec_versions': [   {   'extensions': [],
                                      'namespace': 'http://www.geni.net/resources/rspec/3',
                                      'schema': 'http://www.geni.net/resources/rspec/3/ad.xsd',
                                      'type': 'geni',
                                      'version': '3'}],
    'geni_am_type': 'GRAM',
    'geni_am_urn': 'urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am',
    'geni_api': 2,
    'geni_api_versions': {   '2': 'https://bbn-cam-ctrl-1.gpolab.bbn.com:5002',
                             '3': 'https://bbn-cam-ctrl-1.gpolab.bbn.com:5001'},
    'geni_request_rspec_versions': [   {   'extensions': [],
                                           'namespace': 'http://www.geni.net/resources/rspec/3',
                                           'schema': 'http://www.geni.net/resources/rspec/3/request.xsd',
                                           'type': 'geni',
                                           'version': '3'}]}
12:33:50 INFO    :  ------------------------------------------------------
12:33:50 INFO    :  Completed getversion:

  Options as run:
		aggregate: ['gpo-og']
		framework: portal
		noGetVersionCache: True
		project: ln-test

  Args: getversion

  Result Summary: 
Got version for gpo-og
 
12:33:50 INFO    :  ======================================================

The OpenGENI version is the same as the other available OpenGENI sites:

Site OpenGENI GRAM Version
GPO 'GRAM_version': '3.33'
Clemson 'GRAM_version': '3.33'

Get list of "available" compute resources:

$ omni -a gpo-og listresources --available -o

Verified that Advertisement RSpec only includes available resources, as requested:

$ egrep "node comp|available now" rspec-bbn-cam-ctrl-1-gpolab-bbn-com.xml 
<node component_name="bbn-cam-cmpe-1" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" component_id="urn:publicid:IDN+bbn-cam-ctrl-1+node+bbn-cam-cmpe-1" exclusive="false">
<node component_name="bbn-cam-cmpe-2" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" component_id="urn:publicid:IDN+bbn-cam-ctrl-1+node+bbn-cam-cmpe-2" exclusive="false">
<node component_id="" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" exclusive="false">

Created a slice:

$ omni createslice OG-CT-1
09:50:39 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
09:50:39 INFO    : Loading config file /home/lnevers/.gcf/omni_config
09:50:39 INFO    : Using control framework portal
09:50:39 INFO    : Member Authority is https://ch.geni.net/MA (from config)
09:50:39 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
09:50:40 INFO    : Slice OG-CT-1 already existed - returning existing slice
09:50:40 INFO    : Created slice with Name OG-CT-1, URN urn:publicid:IDN+ch.geni.net:ln-test+slice+OG-CT-1, Expiration 2014-09-01 16:45:21+00:00
09:50:40 INFO    :  ------------------------------------------------------
09:50:40 INFO    :  Completed createslice:

  Options as run:
		framework: portal
		project: ln-test

  Args: createslice OG-CT-1

  Result Summary: Created slice with Name OG-CT-1, URN urn:publicid:IDN+ch.geni.net:ln-test+slice+OG-CT-1, Expiration 2014-09-01 16:45:21+00:00
 
09:50:40 INFO    :  ======================================================

Created a 4 VMs sliver using the RSpec OG-CT-1-gpo.rspec:

$  omni createsliver -a gpo-og OG-CT-1 OG-CT-1-gpo.rspec
09:51:02 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
09:51:02 INFO    : Loading config file /home/lnevers/.gcf/omni_config
09:51:02 INFO    : Using control framework portal
09:51:02 INFO    : Member Authority is https://ch.geni.net/MA (from config)
09:51:02 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
09:51:02 INFO    : Substituting AM nickname gpo-og with URL https://bbn-cam-ctrl-1.gpolab.bbn.com:5002, URN urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am
09:51:03 INFO    : Slice urn:publicid:IDN+ch.geni.net:ln-test+slice+OG-CT-1 expires on 2014-09-01 16:45:21 UTC
09:51:03 INFO    : Creating sliver(s) from rspec file OG-CT-1-gpo.rspec for slice urn:publicid:IDN+ch.geni.net:ln-test+slice+OG-CT-1
09:51:58 INFO    : Got return from CreateSliver for slice OG-CT-1 at gpo-og:
09:51:58 INFO    : <?xml version="1.0" ?>
09:51:58 INFO    :   <!-- Reserved resources for:
	Slice: OG-CT-1
	at AM:
	URN: urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am
	URL: https://bbn-cam-ctrl-1.gpolab.bbn.com:5002
 -->
09:51:58 INFO    :   
<rspec type="manifest" xmlns="http://www.geni.net/resources/rspec/3" xmlns:flack="http://www.protogeni.net/resources/rspec/ext/flack/1" xmlns:planetlab="http://www.planet-lab.org/resources/sfa/ext/planetlab/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3   http://www.geni.net/resources/rspec/3/manifest.xsd">  
      <node client_id="VM1" component_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+node+bbn-cam-cmpe-1" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" exclusive="false" sliver_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+sliver+vmf9940603-72b6-4cc8-86df-aec859a056b0">    
            <sliver_type name="m1.small">      
                  <disk_image name="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+imageubuntu-12.04" os="Linux" version="12"/>      
            </sliver_type>    
            <services>      
                  <execute command="sudo apt-get install iperf -y" shell="sh"/>      
            </services>    
            <interface client_id="VM1:if0" mac_address="fa:16:3e:96:1d:8f">      
                  <ip address="192.168.1.1" netmask="255.255.255.0" type="ip"/>      
            </interface>    
            <host name="VM1"/>    
            <services>      
                  <login authentication="ssh-keys" hostname="192.1.243.5" port="3004" username="lnevers"/>      
            </services>    
      </node>  
      <node client_id="VM2" component_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+node+bbn-cam-cmpe-2" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" exclusive="false" sliver_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+sliver+vm38122621-feee-4e9e-b45c-b639eda48b36">    
            <sliver_type name="m1.small">      
                  <disk_image name="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+imageubuntu-12.04" os="Linux" version="12"/>      
            </sliver_type>    
            <services>      
                  <execute command="sudo apt-get install iperf -y" shell="sh"/>      
            </services>    
            <interface client_id="VM2:if0" mac_address="fa:16:3e:8a:a8:09">      
                  <ip address="192.168.1.2" netmask="255.255.255.0" type="ip"/>      
            </interface>    
            <host name="VM2"/>    
            <services>      
                  <login authentication="ssh-keys" hostname="192.1.243.5" port="3003" username="lnevers"/>      
            </services>    
      </node>  
      <node client_id="VM3" component_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+node+bbn-cam-cmpe-1" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" exclusive="false" sliver_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+sliver+vmdd9b3966-c926-4a66-9c34-ec8390729071">    
            <sliver_type name="m1.small">      
                  <disk_image name="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+imageubuntu-12.04" os="Linux" version="12"/>      
            </sliver_type>    
            <services>      
                  <execute command="sudo apt-get install iperf -y" shell="sh"/>      
            </services>    
            <interface client_id="VM3:if0" mac_address="fa:16:3e:b7:e9:51">      
                  <ip address="192.168.1.3" netmask="255.255.255.0" type="ip"/>      
            </interface>    
            <host name="VM3"/>    
            <services>      
                  <login authentication="ssh-keys" hostname="192.1.243.5" port="3002" username="lnevers"/>      
            </services>    
      </node>  
      <node client_id="VM4" component_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+node+bbn-cam-cmpe-2" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" exclusive="false" sliver_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+sliver+vme5e6c4ca-4781-4e1d-bf1d-0d9c4bbc77a6">    
            <sliver_type name="m1.small">      
                  <disk_image name="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+imageubuntu-12.04" os="Linux" version="12"/>      
            </sliver_type>    
            <services>      
                  <execute command="sudo apt-get install iperf -y" shell="sh"/>      
            </services>    
            <interface client_id="VM4:if0" mac_address="fa:16:3e:50:cf:8e">      
                  <ip address="192.168.1.4" netmask="255.255.255.0" type="ip"/>      
            </interface>    
            <host name="VM4"/>    
            <services>      
                  <login authentication="ssh-keys" hostname="192.1.243.5" port="3005" username="lnevers"/>      
            </services>    
      </node>  
      <link client_id="lan0" component_manager_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am" sliver_id="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+sliver+link8d52de1d-7670-4927-91cb-8da52b752022" vlantag="1002">    
            <component_manager name="urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am"/>    
            <interface_ref client_id="VM1:if0"/>    
            <interface_ref client_id="VM2:if0"/>    
            <interface_ref client_id="VM3:if0"/>    
            <interface_ref client_id="VM4:if0"/>    
            <link_type name="lan"/>    
      </link>  
</rspec>
09:51:58 INFO    :  ------------------------------------------------------
09:51:58 INFO    :  Completed createsliver:

  Options as run:
		aggregate: ['gpo-og']
		framework: portal
		project: ln-test

  Args: createsliver OG-CT-1 OG-CT-1-gpo.rspec

  Result Summary: Got Reserved resources RSpec from bbn-cam-ctrl-1-gpolab-bbn-com 
09:51:58 INFO    :  ======================================================

The following is login information for the sliver:

$ readyToLogin -a gpo-og OG-CT-1
<...>
VM4's geni_status is: ready 
User lnevers logs in to VM4 using:
	ssh -p 3005  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@192.1.243.5

VM2's geni_status is: ready 
User lnevers logs in to VM2 using:
	ssh -p 3003  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@192.1.243.5

VM3's geni_status is: ready 
User lnevers logs in to VM3 using:
	ssh -p 3002  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@192.1.243.5

VM1's geni_status is: ready 
User lnevers logs in to VM1 using:
	ssh -p 3004  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@192.1.243.5

Measurements

Log into specified host and collect iperf and ping statistics. All measurements are collected over 60 seconds, using default images and default link bandwidth:

Iperf OpenGENI GPO VM-2 to VM-1 (TCP) - TCP window size: 23.5 KByte (default)

Collected: 2014-08-26

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  15.5 GBytes  2.21 Gbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-60.0 sec  2.67 GBytes   383 Mbits/sec
[  3]  0.0-60.0 sec  2.77 GBytes   396 Mbits/sec
[  6]  0.0-60.0 sec  2.68 GBytes   384 Mbits/sec
[  7]  0.0-60.0 sec  3.02 GBytes   433 Mbits/sec
[  5]  0.0-60.0 sec  3.04 GBytes   435 Mbits/sec
[SUM]  0.0-60.0 sec  14.2 GBytes  2.03 Gbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  7]  0.0-60.0 sec  1.37 GBytes   197 Mbits/sec
[  9]  0.0-60.0 sec  1.37 GBytes   196 Mbits/sec
[  4]  0.0-60.0 sec  1.38 GBytes   198 Mbits/sec
[  6]  0.0-60.0 sec  1.38 GBytes   198 Mbits/sec
[  8]  0.0-60.0 sec  1.38 GBytes   197 Mbits/sec
[ 10]  0.0-60.0 sec  1.36 GBytes   195 Mbits/sec
[  3]  0.0-60.0 sec  1.39 GBytes   199 Mbits/sec
[ 12]  0.0-60.0 sec  1.39 GBytes   200 Mbits/sec
[  5]  0.0-60.0 sec  1.36 GBytes   194 Mbits/sec
[ 11]  0.0-60.0 sec  1.41 GBytes   201 Mbits/sec
[SUM]  0.0-60.0 sec  13.8 GBytes  1.97 Gbits/sec

Iperf OpenGENI GPO VM-2 to the VM-1 (UDP) - UDP buffer size: 224 KByte (default)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec   0.001 ms   37/512820 (0.0072%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from OpenGENI GPO VM-2 to the VM-1

60 packets transmitted, 60 received, 0% packet loss, time 58997ms
rtt min/avg/max/mdev = 0.330/0.433/0.800/0.067 ms

OG-CT-2 - Access to New Site bare metal and VM resources

There is no support for bare metal nodes in the OpenGENI Racks, this test is a place holder for future addition of this type of resource.

OG-CT-3 - Multiple sites experiment

Created a slice:

$ omni createslice OG-CT-3
08:40:46 INFO    : Downloaded latest `agg_nick_cache` from 'http://trac.gpolab.bbn.com/gcf/raw-attachment/wiki/Omni/agg_nick_cache' and copied to '/home/lnevers/.gcf/agg_nick_cache'.
08:40:46 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
08:40:46 INFO    : Loading config file /home/lnevers/.gcf/omni_config
08:40:46 INFO    : Using control framework portal
08:40:46 INFO    : Member Authority is https://ch.geni.net/MA (from config)
08:40:46 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
08:40:47 INFO    : Created slice with Name OG-CT-3, URN urn:publicid:IDN+ch.geni.net:ln-test+slice+OG-CT-3, Expiration 2014-09-09 12:40:47+00:00
08:40:47 INFO    :  ------------------------------------------------------
08:40:47 INFO    :  Completed createslice:

  Options as run:
		framework: portal
		project: ln-test

  Args: createslice OG-CT-3

  Result Summary: Created slice with Name OG-CT-3, URN urn:publicid:IDN+ch.geni.net:ln-test+slice+OG-CT-3, Expiration 2014-09-09 12:40:47+00:00
 
08:40:47 INFO    :  ======================================================

Create a stitched sliver with one VM container at GPO and one VM container at Clemson using RSpec OG-CT-3-gpo.rspec.

$ stitcher createsliver OG-CT-3 ./OG-CT-3-gpo.rspec 
08:40:59 INFO    : Configured logging from file /home/lnevers/gcf-2.6-oess/src/gcf/stitcher_logging.conf
08:41:01 INFO    : Reading slice OG-CT-3 credential...
08:41:01 INFO    : Slice urn:publicid:IDN+ch.geni.net:ln-test+slice+OG-CT-3 expires on 2014-09-09 12:40:47 UTC
08:41:01 INFO    : Using SCS at http://nutshell.maxgigapop.net:8081/geni/xmlrpc
08:41:01 INFO    : Calling SCS...
08:41:04 INFO    : Multi-AM reservation will include resources from these aggregates:
08:41:04 INFO    : 	<Aggregate urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am>
08:41:04 INFO    : 	<Aggregate urn:publicid:IDN+clemson-clemson-control-1.clemson.edu+authority+am>
08:41:04 INFO    : 	<Aggregate ion>
08:41:04 INFO    : Stitcher doing createsliver at <Aggregate urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am>...
08:41:04 WARNING : Requested API version 2, but AM https://bbn-cam-ctrl-1.gpolab.bbn.com:5001 uses version 3. Same aggregate talks API v2 at a different URL: https://bbn-cam-ctrl-1.gpolab.bbn.com:5002
08:41:28 INFO    : ... Allocation at <Aggregate urn:publicid:IDN+bbn-cam-ctrl-1.gpolab.bbn.com+authority+am> complete.
08:41:28 INFO    : Stitcher doing createsliver at <Aggregate urn:publicid:IDN+clemson-clemson-control-1.clemson.edu+authority+am>...
08:41:29 WARNING : Requested API version 2, but AM https://clemson-clemson-control-1.clemson.edu:5001 uses version 3. Same aggregate talks API v2 at a different URL: https://clemson-clemson-control-1.clemson.edu:5002
08:42:14 INFO    : ... Allocation at <Aggregate urn:publicid:IDN+clemson-clemson-control-1.clemson.edu+authority+am> complete.
08:42:14 INFO    : Stitcher doing createsliver at <Aggregate ion>...
08:43:01 INFO    : DCN AM <Aggregate ion>: must wait for status ready....
08:43:01 INFO    : Pausing 30 seconds to let circuit become ready...
08:43:39 INFO    : DCN circuit 115171 is ready at <Aggregate ion>
08:43:46 INFO    : Getting credential from file /tmp/slice-ch-geni-net-ln-test-OG-CT-3-for-lnevers-cred.xml
08:43:46 INFO    : ... Allocation at <Aggregate ion> complete.
08:43:46 INFO    : All aggregates are complete.
08:43:46 INFO    : Your resources expire at 2014-09-03 12:42:18 (UTC). 
08:43:46 INFO    : Saved combined reservation RSpec at 3 AMs to file '/home/lnevers/gcf-test/gramrspec/GPO/OG-CT-3-manifest-rspec-stitching-combined.xml'
Success: Reserved resources in slice OG-CT-3 at 3 Aggregates (including 1 intermediate aggregate(s) not in the original request), creating 1 stitched link(s).

Determined login information at each GPO and Clemson aggregate:

$ readyToLogin OG-CT-3 -a gpo-og 
  ....
GPO-OG's geni_status is: ready 
User lnevers logs in to GPO-OG using:
	ssh -p 3000  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@192.1.243.5

$ readyToLogin OG-CT-3 -a clemson-og
  ....
CLEM-OG's geni_status is: ready 
User lnevers logs in to CLEM-OG using:
	ssh -p 3000  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@130.127.88.101

No connectivity - ticket 1287

OG-CT-4 - Multiple sites OpenFlow experiment and interoperability

OG-CT-5 - Experiment Monitoring

OG-CT-6 - Administrative Tests

Sent request for administrative account to site contact from the GPO OpenGENI aggregate page. Followed instructions at the OpenGENI Rack Administrative Accounts page. Once the administrative account was created, proceeded to execute administrative tests.

LNM:~$ ssh bbn-cam-ctrl-1.gpolab.bbn.com
Welcome to Ubuntu 12.04.4 LTS (GNU/Linux 3.5.0-49-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

  System information as of Tue Sep  2 08:56:46 EDT 2014

  System load:  0.25               Users logged in:      2
  Usage of /:   2.1% of 296.80GB   IP address for eth2:  10.10.5.100
  Memory usage: 1%                 IP address for eth3:  10.10.8.100
  Swap usage:   0%                 IP address for eth1:  10.10.6.100
  Processes:    305                IP address for br-ex: 192.1.243.2

  Graph this data and manage this system at:
    https://landscape.canonical.com/

81 packages can be updated.
54 updates are security updates.

New release '14.04.1 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: Tue Sep  2 08:49:45 2014 from dhcp89-73-116.bbn.com

lnevers@bbn-cam-ctrl-1:~$ sudo whoami
[sudo] password for lnevers: 
root
lnevers@bbn-cam-ctrl-1:~$ uname -a
Linux bbn-cam-ctrl-1 3.5.0-49-generic #74~precise1-Ubuntu SMP Fri May 2 21:32:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
lnevers@bbn-cam-ctrl-1:~$ 

Used the GPO OG Rack Details to determine the IP addresses for the compute hosts. From Control node accessed each of the experiment nodes that support VMs:

lnevers@bbn-cam-ctrl-1:~$ ssh 10.10.8.101
Welcome to Ubuntu 12.04.4 LTS (GNU/Linux 3.5.0-49-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

  System information as of Tue Sep  2 10:58:32 EDT 2014

  System load:  0.34               Users logged in:      0
  Usage of /:   0.9% of 422.79GB   IP address for eth2:  10.10.5.101
  Memory usage: 1%                 IP address for eth3:  10.10.8.101
  Swap usage:   0%                 IP address for eth1:  10.10.6.101
  Processes:    257                IP address for br-ex: 192.1.243.3

  Graph this data and manage this system at:
    https://landscape.canonical.com/

81 packages can be updated.
51 updates are security updates.

New release '14.04.1 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: Tue Sep  2 09:08:46 2014 from bbn-cam-ctrl-1
lnevers@bbn-cam-cmpe-1:~$ sudo whoami
[sudo] password for lnevers: 
root
lnevers@bbn-cam-cmpe-1:~$ uname -a
Linux bbn-cam-cmpe-1 3.5.0-49-generic #74~precise1-Ubuntu SMP Fri May 2 21:32:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
lnevers@bbn-cam-cmpe-1:~$ exit
logout
Connection to 10.10.8.101 closed.
lnevers@bbn-cam-ctrl-1:~$ ssh 10.10.8.102
Welcome to Ubuntu 12.04.4 LTS (GNU/Linux 3.5.0-49-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

  System information as of Tue Sep  2 10:59:18 EDT 2014

  System load:  0.0                Users logged in:      0
  Usage of /:   0.8% of 422.79GB   IP address for eth2:  10.10.5.102
  Memory usage: 1%                 IP address for eth3:  10.10.8.102
  Swap usage:   0%                 IP address for eth1:  10.10.6.102
  Processes:    252                IP address for br-ex: 192.1.243.4

  Graph this data and manage this system at:
    https://landscape.canonical.com/

81 packages can be updated.
51 updates are security updates.

New release '14.04.1 LTS' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: Tue Sep  2 09:09:12 2014 from bbn-cam-ctrl-1
lnevers@bbn-cam-cmpe-2:~$ sudo whoami
[sudo] password for lnevers: 
root
lnevers@bbn-cam-cmpe-2:~$ uname -a
Linux bbn-cam-cmpe-2 3.5.0-49-generic #74~precise1-Ubuntu SMP Fri May 2 21:32:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
lnevers@bbn-cam-cmpe-2:~$ 

Access infrastructure switches as admin user. First connect to the PowerConnect 7048 Switch the control network switch:

lnevers@bbn-cam-ctrl-1:~$ ssh 10.10.8.201
lnevers@10.10.8.201's password: 

console>show version

Image Descriptions 

 image1 : default image 
 image2 :  


 Images currently available on Flash 

unit  image1       image2       current-active     next-active       
----- ------------ ------------ ----------------- ----------------- 

1     4.2.2.3      4.2.2.3      image1             image1            

console>

console>ena
Password:*********

console#show running-config 

!Current Configuration:
!System Description "PowerConnect 7048, 4.2.2.3, VxWorks 6.6"
!System Software Version 4.2.2.3
!System Operational Mode "Normal"
!
configure
vlan database
vlan 100,200,300,2500
vlan routing 1 1
exit
vlan 100
name "Management"
exit
vlan 200
name "Control"
exit
vlan 300
name "External"
exit
ip telnet server disable
slot 1/0 5    ! PowerConnect 7048
                 
stack
member 1 5    ! PCT7048
exit
interface out-of-band
ip address 10.10.8.201 255.255.255.0 0.0.0.0
exit
interface vlan 1
exit
username "xxx" password xxx privilege 15 encrypted
crypto key pubkey-chain ssh
user-key "xx" rsa
key-string row  xxx

exit
line ssh
enable authentication enableList
exit
ip ssh server
ip ssh pubkey-auth
!
interface Gi1/0/1
switchport mode trunk
switchport trunk allowed vlan 2500
exit
!
interface Gi1/0/2
switchport mode trunk
switchport trunk allowed vlan 2500
exit
!
interface Gi1/0/3
switchport mode trunk
switchport trunk allowed vlan 2500
exit
!
interface Gi1/0/13
switchport access vlan 200
exit
!                  
interface Gi1/0/14
switchport access vlan 200
exit
!
interface Gi1/0/15
switchport access vlan 200
exit
!
interface Gi1/0/16
switchport access vlan 200
exit
!
interface Gi1/0/17
switchport access vlan 200
exit
!
interface Gi1/0/18
switchport access vlan 200
exit
!
interface Gi1/0/19                 
switchport access vlan 200
exit
!
interface Gi1/0/20
switchport access vlan 200
exit
!
interface Gi1/0/25
switchport access vlan 300
exit
!
interface Gi1/0/26
switchport access vlan 300
exit
!
interface Gi1/0/27
switchport access vlan 300
exit
!
interface Gi1/0/29
switchport access vlan 300
exit
!
interface Gi1/0/37
switchport access vlan 300
exit
!
interface Gi1/0/48
switchport access vlan 300
exit
enable password xxx encrypted
exit

console#
console#show vlan

VLAN   Name                             Ports          Type          
-----  ---------------                  -------------  --------------
1      default                          Po1-128,       Default                
                                        Gi1/0/4-12,
                                        Gi1/0/21-24,
                                        Gi1/0/28,
                                        Gi1/0/30-36,
                                        Gi1/0/38-47
100    Management                                      Static                 
200    Control                          Gi1/0/13-20    Static                 
300    External                         Gi1/0/25-27,   Static                 
                                        Gi1/0/29,
                                        Gi1/0/37,
                                        Gi1/0/48
2500   VLAN2500                         Gi1/0/1-3      Static                 
console#exit

console>exitConnection to 10.10.8.201 closed.
lnevers@bbn-cam-ctrl-1:~$ 

Connect to the Force10 OpenFlow Switch for the dataplane network:

lnevers@bbn-cam-ctrl-1:~$ ssh 10.10.8.200
lnevers@10.10.8.200's password: 
FTOS>ena
Password: 
FTOS#show version
Dell Force10 Real Time Operating System Software
Dell Force10 Operating System Version: 2.0
Dell Force10 Application Software Version: 9.1(0.0)
Copyright (c) 1999-2012 by Dell Inc. All Rights Reserved.
Build Time: Tue Feb 26 20:02:06 2013
Build Path: /sites/sjc/work/build/toolSpaces/tools03/E9-1-0/SW/SRC
FTOS uptime is 1 week(s), 3 day(s), 21 hour(s), 56 minute(s)

System image file is "system://A"

System Type: S4810 
Control Processor: Freescale QorIQ P2020 with 2147483648 bytes of memory.

128M bytes of boot flash memory.

  1 52-port GE/TE/FG (SE)
 48 Ten GigabitEthernet/IEEE 802.3 interface(s)
  4 Forty GigabitEthernet/IEEE 802.3 interface(s)
FTOS#
FTOS#show vlan 

Codes: * - Default VLAN, G - GVRP VLANs, R - Remote Port Mirroring VLANs, P - Primary, C - Community, I - Isolated
       O - Openflow
Q: U - Untagged, T - Tagged
   x - Dot1x untagged, X - Dot1x tagged
   o - OpenFlow untagged, O - OpenFlow tagged
   G - GVRP tagged, M - Vlan-stack, H - VSN tagged
   i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

    NUM    Status    Description                     Q Ports
*   1      Active                                    U Te 0/0-3
O   1000   Active                                    T Te 0/0-2
O   1001   Active                                    T Te 0/0-2
O   1002   Active                                    T Te 0/0-2
O   1003   Active                                    T Te 0/0-2
O   1004   Active                                    T Te 0/0-2

<...1005-2627 not captured here>

O   2628   Active                                    T Te 0/0-3
O   2629   Active                                    T Te 0/0-3
O   2630   Active                                    T Te 0/0-3
FTOS#          

FTOS#show running-config 
Current Configuration ...
! Version 9.1(0.0)
! Last configuration change at Wed Aug 27 09:18:45 2014 by gram
! Startup-config last updated at Wed Aug 27 09:18:51 2014 by gram
!
boot system stack-unit 0 primary system: A:
boot system stack-unit 0 secondary system: B:
boot system stack-unit 0 default system: A:
boot system gateway 192.1.243.1
!
redundancy auto-synchronize full
!
hardware watchdog
!
service timestamps log datetime localtime show-timezone
!
hostname FTOS
!
cam-acl l2acl 2 ipv4acl 0 ipv6acl 0 ipv4qos 2 l2qos 1 l2pt 0 ipmacacl 0 vman-qos 0 ecfmacl 0 openflow 8 fcoeacl 0 iscsioptacl 0
!
cam-acl-vlan vlanopenflow 1 vlaniscsi 1 
!
enable password 7 xx
!
username xx password 7 xx
!
enable restricted 7 xxx
!
stack-unit 0 provision S4810
!
interface TenGigabitEthernet 0/0
 no ip address
 portmode hybrid
 switchport
 flowcontrol rx on tx off 
 no shutdown
!
interface TenGigabitEthernet 0/1
 no ip address
 portmode hybrid
 switchport
 flowcontrol rx on tx off 
 no shutdown
!
interface TenGigabitEthernet 0/2
 no ip address
 portmode hybrid
 switchport
 flowcontrol rx on tx off 
 no shutdown
!
interface TenGigabitEthernet 0/3
 no ip address
 portmode hybrid
 switchport
 flowcontrol rx on tx off 
 no shutdown
!
interface TenGigabitEthernet 0/4
 no ip address
 flowcontrol rx on tx off 
 no shutdown
!

<...hundreds of lines not captured here...>

Access to the iDRAC controller:

lnevers@bbn-cam-ctrl-1:~$ ssh lnevers@10.10.8.10
/admin1-> racadm
racadm>> getversion
 Bios Version             = 1.3.6

 iDRAC Version            = 1.23.23

 USC Version              = 1.0.8.42

racadm>> 

racadm>> getsysinfo

Lom0_macs = 14; Lom1_macs = 0, Max macs per device = 66

RAC Information:
RAC Date/Time           = 09/05/2014 13:49:05
Firmware Version        = 1.23.23
Firmware Build          = 01
Last Firmware Update    = 11/06/2012 14:59:03
Hardware Version        = 0.01
MAC Address             = E0:DB:55:05:F0:28

Common settings:
Register DNS RAC Name   = 0
DNS RAC Name            = idrac-JST7WV1
Current DNS Domain      = 
Domain Name from DHCP   = 0

IPv4 settings:
Enabled                 = 1
Current IP Address      = 10.10.8.10
Current IP Gateway      = 192.168.124.10
Current IP Netmask      = 255.255.255.0
DHCP Enabled            = 0
Current DNS Server 1    = 0.0.0.0
Current DNS Server 2    = 0.0.0.0
DNS Servers from DHCP   = 0

IPv6 settings:
Enabled                 = 0
Current IP Address 1    = ::
Current IP Gateway      = ::
Autoconfig              = 1
Link Local IP Address   = ::
Current IP Address 2    = ::
Current IP Address 3    = ::
Current IP Address 4    = ::
Current IP Address 5    = ::
Current IP Address 6    = ::
Current IP Address 7    = ::
Current IP Address 8    = ::
Current IP Address 9    = ::
Current IP Address 10   = ::
Current IP Address 11   = ::
Current IP Address 12   = ::
Current IP Address 13   = ::
Current IP Address 14   = ::
Current IP Address 15   = ::
DNS Servers from DHCPv6 = 0
Current DNS Server 1    = ::
Current DNS Server 2    = ::

System Information:
System Model            = PowerEdge R620
System Revision         = I
System BIOS Version     = 1.3.6
Service Tag             = JST7WV1
Express Svc Code        = 43100995357
Host Name               = 
OS Name                 = 
Power Status            = ON
Fresh Air Capable       = Yes

Watchdog Information:
Recovery Action         = None
Present countdown value = 15 seconds
Initial countdown value = 15 seconds

Embedded NIC MAC Addresses:
NIC.Integrated.1-1-1    Ethernet                = 90:B1:1C:0F:F2:E7
                        iSCSI                   = 90:B1:1C:0F:F2:E8
                        FIP                     = 90:B1:1C:0F:F2:E8
                        WWN                     = 20:00:90:B1:1C:0F:F2:E8
                        WWPN                    = 20:01:90:B1:1C:0F:F2:E8
NIC.Integrated.1-2-1    Ethernet                = 90:B1:1C:0F:F2:E9
                        iSCSI                   = 90:B1:1C:0F:F2:EA
                        FIP                     = 90:B1:1C:0F:F2:EA
                        WWN                     = 20:00:90:B1:1C:0F:F2:EA
                        WWPN                    = 20:01:90:B1:1C:0F:F2:EA
NIC.Integrated.1-3-1    Ethernet                = 90:B1:1C:0F:F2:EB
                        WWN                     = 90:B1:1C:0F:F2:EB
NIC.Integrated.1-4-1    Ethernet                = 90:B1:1C:0F:F2:ED
                        WWN                     = 90:B1:1C:0F:F2:ED

racadm>> 

racadm>> getled
LED State :    Not-Blinking
racadm>> 

racadm>> getsensorinfo

Sensor Type : POWER
<Sensor Name>                   <Status>                 <Type>         
PS1 Status                      Present                  AC             
PS2 Status                      Present                  AC             

Sensor Type : TEMPERATURE
<Sensor Name>                   <Status>    <Reading>   <lc>        <uc>        
System Board Inlet Temp         Ok          22 C        -7 C        47 C        
System Board Exhaust Temp       Ok          36 C        3 C         75 C        

Sensor Type : FAN
<Sensor Name>                   <Status>    <Reading>   <lc>        <uc>        
System Board Fan1A RPM          Ok          4440 RPM    720 RPM     NA          
System Board Fan2A RPM          Ok          4560 RPM    720 RPM     NA          
System Board Fan3A RPM          Ok          4320 RPM    720 RPM     NA          
System Board Fan4A RPM          Ok          4200 RPM    720 RPM     NA          
System Board Fan5A RPM          Ok          4680 RPM    720 RPM     NA          
System Board Fan6A RPM          Ok          4560 RPM    720 RPM     NA          
System Board Fan7A RPM          Ok          4560 RPM    720 RPM     NA          
System Board Fan1B RPM          Ok          4200 RPM    720 RPM     NA          
System Board Fan2B RPM          Ok          4080 RPM    720 RPM     NA          
System Board Fan3B RPM          Ok          4200 RPM    720 RPM     NA          
System Board Fan4B RPM          Ok          3960 RPM    720 RPM     NA          
System Board Fan5B RPM          Ok          4200 RPM    720 RPM     NA          
System Board Fan6B RPM          Ok          4200 RPM    720 RPM     NA          
System Board Fan7B RPM          Ok          4200 RPM    720 RPM     NA          

Sensor Type : VOLTAGE
<Sensor Name>                   <Status>    <Reading>   <lc>        <uc>        
CPU1 VCORE PG                   Ok          Good        NA          NA          
CPU2 VCORE PG                   Ok          Good        NA          NA          
System Board 3.3V PG            Ok          Good        NA          NA          
System Board 5V PG              Ok          Good        NA          NA          
CPU2 PLL PG                     Ok          Good        NA          NA          
CPU1 PLL PG                     Ok          Good        NA          NA          
System Board 1.1V PG            Ok          Good        NA          NA          
CPU1 M23 VDDQ PG                Ok          Good        NA          NA          
CPU1 M23 VTT PG                 Ok          Good        NA          NA          
System Board FETDRV PG          Ok          Good        NA          NA          
CPU2 VSA PG                     Ok          Good        NA          NA          
CPU1 VSA PG                     Ok          Good        NA          NA          
CPU2 M01 VDDQ PG                Ok          Good        NA          NA          
CPU1 M01 VDDQ PG                Ok          Good        NA          NA          
CPU2 M23 VTT PG                 Ok          Good        NA          NA          
CPU2 M01 VTT PG                 Ok          Good        NA          NA          
System Board NDC PG             Ok          Good        NA          NA          
CPU2 VTT PG                     Ok          Good        NA          NA          
CPU1 VTT PG                     Ok          Good        NA          NA          
CPU2 M23 VDDQ PG                Ok          Good        NA          NA          
System Board 1.5V PG            Ok          Good        NA          NA          
System Board BP1 5V PG          Ok          Good        NA          NA          
CPU1 M01 VTT PG                 Ok          Good        NA          NA          
PS1 Voltage 1                   Ok          122 V       NA          NA          
PS2 Voltage 2                   Ok          130 V       NA          NA          

Sensor Type : CURRENT
<Sensor Name>                   <Status>    <Reading>   <lc>        <uc>        
PS1 Current 1                   Ok          1.2 Amps    NA          NA          
PS2 Current 2                   Ok          0.0 Amps    NA          NA          
System Board Pwr Consumption    Ok          154 Watts   NA          1344 Watts  

Sensor Type : PROCESSOR
<Sensor Name>                   <Status>    <Reading>   <lc>        <uc>        
CPU1 Status                     Ok          Present     NA          NA          
CPU2 Status                     Ok          Present     NA          NA          

Sensor Type : BATTERY
<Sensor Name>                   <Status>    <Reading>   <lc>        <uc>        
System Board CMOS Battery       Ok          Present     NA          NA          

Sensor Type : PERFOMANCE
<Sensor Name>                   <Status>    <State>        <lc>      <uc>      
System Board Power Optimized    Ok          Not Degraded   NA        NA        

Sensor Type : INTRUSION
<Sensor Name>                   <Intrusion>    <Status>       
System Board Intrusion          Closed         Power ON       

Sensor Type : REDUNDANCY
<Sensor Name>                   <Status>                 <Type>         
System Board Fan Redundancy     Full Redundant           Fan            
System Board PS Redundancy      Full Redundant           PSU            
racadm>> 
racadm>> quit

/admin1-> exit
CLP Session terminated
Connection to 10.10.8.10 closed.
lnevers@bbn-cam-ctrl-1:~$ 

Email help@geni.net for GENI support or email me with feedback on this page!

Attachments (4)

Download all attachments as: .zip