wiki:GENIRacksHome/InstageniRacks/ConfirmationTestStatus/UCSD

Version 11 (modified by lnevers@bbn.com, 23 months ago) (diff)

--

University of California San Diego InstaGENI Confirmation Tests

For details about the tests in this page, see the InstaGENI Confirmation Tests page.
For site status see the InstaGENI New Site Confirmation Tests Status page.

Note: Omni nick_names for site aggregates used for these tests are:

ucsd-ig=urn:publicid:IDN+instageni.ucsd.edu+authority+cm,https://instageni.ucsd.edu:12369/protogeni/xmlrpc/am/2.0

IG-CT-1 - Access to New Site VM resources

Aggregate Version:

$ omni getversion -a ucsd-ig

The InstaGENI version in "'code_tag':'a4dcba972ec27a89499cbe5500ed6d071a854551'" is the same as the other available InstaGENI sites:

Site InstaGENI Code tag
geni-case-edu a4dcba972ec27a89499cbe5500ed6d071a854551
geni-it-cornell-edu a4dcba972ec27a89499cbe5500ed6d071a854551
geni-kettering-edu a4dcba972ec27a89499cbe5500ed6d071a854551
genirack-nyu-edu a4dcba972ec27a89499cbe5500ed6d071a854551
clemson-edu a4dcba972ec27a89499cbe5500ed6d071a854551
colorado-edu a4dcba972ec27a89499cbe5500ed6d071a854551
cs-princeton-edu a4dcba972ec27a89499cbe5500ed6d071a854551
gpolab-bbn-com a4dcba972ec27a89499cbe5500ed6d071a854551
hawaii-edu a4dcba972ec27a89499cbe5500ed6d071a854551
idre-ucla-edu a4dcba972ec27a89499cbe5500ed6d071a854551
illinois-edu a4dcba972ec27a89499cbe5500ed6d071a854551
iu-edu a4dcba972ec27a89499cbe5500ed6d071a854551
ku-gpeni-net a4dcba972ec27a89499cbe5500ed6d071a854551
maxgigapop-net a4dcba972ec27a89499cbe5500ed6d071a854551
metrodatacenter-com a4dcba972ec27a89499cbe5500ed6d071a854551
northwestern-edu a4dcba972ec27a89499cbe5500ed6d071a854551
nps-edu a4dcba972ec27a89499cbe5500ed6d071a854551
nysernet-org a4dcba972ec27a89499cbe5500ed6d071a854551
rnet-missouri-edu a4dcba972ec27a89499cbe5500ed6d071a854551
rnoc-gatech-edu a4dcba972ec27a89499cbe5500ed6d071a854551
rutgers-edu a4dcba972ec27a89499cbe5500ed6d071a854551
sox-net a4dcba972ec27a89499cbe5500ed6d071a854551
ucsd-edu a4dcba972ec27a89499cbe5500ed6d071a854551
umkc-edu a4dcba972ec27a89499cbe5500ed6d071a854551
utc-edu a4dcba972ec27a89499cbe5500ed6d071a854551
lan-sdn-uky-edu a4dcba972ec27a89499cbe5500ed6d071a854551
mcv-sdn-uky-edu a4dcba972ec27a89499cbe5500ed6d071a854551
pks2-sdn-uky-edu a4dcba972ec27a89499cbe5500ed6d071a854551

Get list of "available" compute resources:

$ omni -a ucsd-ig listresources --available -o

Verified that Advertisement RSpec only includes available resources, as requested:

$ egrep "node comp|available now" rspec-instageni-ucsd-edu.xml 
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="procurve2"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+procurve2"  exclusive="true" >
  <available now="true" />
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="pc3"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc3"  exclusive="false" >
  <available now="true" />
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="interconnect-al2s"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+interconnect-al2s"  exclusive="false" >
  <available now="true" />
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="pc5"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc5"  exclusive="true" >
  <available now="true" />
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="pc4"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc4"  exclusive="true" >
  <available now="true" />
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="pc1"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc1"  exclusive="false" >
  <available now="true" />
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="pc2"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc2"  exclusive="false" >
  <available now="true" />
<node component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" component_name="internet"  component_id="urn:publicid:IDN+instageni.ucsd.edu+node+internet"  exclusive="true" >
  <available now="true" />
$

Created a slice and a 4 VMs sliver using the RSpec IG-CT-1-ucsd.rspec:

$ stitcher createsliver -a ucsd-ig IG-CT-1 IG-CT-1.rspec
11:33:48 INFO    : Configured logging from file /home/lnevers/geni-tools-2.10/src/gcf/stitcher_logging.conf
11:33:48 INFO    : Not a bound multi-aggregate request - let Omni handle this.
11:33:48 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
11:33:48 INFO    : Loading config file '/home/lnevers/.gcf/omni_config'
11:33:48 INFO    : Using control framework portal
11:33:48 INFO    : Member Authority is https://ch.geni.net/MA (from config)
11:33:48 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
11:33:48 INFO    : Substituting AM nickname ucsd-ig with URL https://instageni.ucsd.edu:12369/protogeni/xmlrpc/am/2.0, URN urn:publicid:IDN+instageni.ucsd.edu+authority+cm
11:33:48 INFO    : Slice urn:publicid:IDN+ch.geni.net:ln-test+slice+IG-CT-1 expires on 2017-06-01 15:32:41 UTC
11:33:48 INFO    : Creating sliver(s) from rspec file IG-CT-1.rspec for slice urn:publicid:IDN+ch.geni.net:ln-test+slice+IG-CT-1
11:34:08 INFO    :  (PG log url - look here for details on any failures: https://www.instageni.ucsd.edu/spewlogfile.php3?logfile=0c99e2acbdfb5f81bb41b6c589173934)
11:34:08 INFO    : Got return from CreateSliver for slice IG-CT-1 at ucsd-ig:
11:34:08 INFO    : <?xml version="1.0" ?>
11:34:08 INFO    :   <!-- Reserved resources for:
	Slice: IG-CT-1
	at AM:
	URN: urn:publicid:IDN+instageni.ucsd.edu+authority+cm
	URL: https://instageni.ucsd.edu:12369/protogeni/xmlrpc/am/2.0
 -->
11:34:08 INFO    :   <rspec expires="2017-06-01T15:32:41Z" type="manifest" xmlns="http://www.geni.net/resources/rspec/3" xmlns:flack="http://www.protogeni.net/resources/rspec/ext/flack/1" xmlns:planetlab="http://www.planet-lab.org/resources/sfa/ext/planetlab/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3   http://www.geni.net/resources/rspec/3/manifest.xsd">    

    <node client_id="xen1" component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc1" component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" exclusive="false" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+30">    
        <sliver_type name="emulab-xen"/>    
        <services>             <execute command="sudo apt-get install iperf -y" shell="sh"/>             <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25170" username="asydne01"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25170" username="lnevers1"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25170" username="lnevers2"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25170" username="lnevers"/>      <rs:console server="pc1.instageni.ucsd.edu" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    </services>    
        <interface client_id="xen1:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc1:eth1" mac_address="02669693ef36" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+35">      
            <ip address="192.168.1.1" netmask="255.255.255.0" type="ipv4"/>      
        </interface>    
      <rs:vnode hardware_type="pcvm" name="pcvm1-1" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    <host name="xen1.IG-CT-1.ch-geni-net.instageni.ucsd.edu"/>  </node>  
    <node client_id="xen2" component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc2" component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" exclusive="false" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+32">    
        <sliver_type name="emulab-xen"/>    
        <services>             <execute command="sudo apt-get install iperf -y" shell="sh"/>             <login authentication="ssh-keys" hostname="pc2.instageni.ucsd.edu" port="25170" username="asydne01"/>      <login authentication="ssh-keys" hostname="pc2.instageni.ucsd.edu" port="25170" username="lnevers1"/>      <login authentication="ssh-keys" hostname="pc2.instageni.ucsd.edu" port="25170" username="lnevers2"/>      <login authentication="ssh-keys" hostname="pc2.instageni.ucsd.edu" port="25170" username="lnevers"/>      <rs:console server="pc2.instageni.ucsd.edu" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    </services>    
        <interface client_id="xen2:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc2:eth1" mac_address="02e9d4f0510e" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+36">      
            <ip address="192.168.1.2" netmask="255.255.255.0" type="ipv4"/>      
        </interface>    
      <rs:vnode hardware_type="pcvm" name="pcvm2-2" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    <host name="xen2.IG-CT-1.ch-geni-net.instageni.ucsd.edu"/>  </node>  
    <node client_id="xen3" component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc1" component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" exclusive="false" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+31">    
        <sliver_type name="emulab-xen"/>    
        <services>             <execute command="sudo apt-get install iperf -y" shell="sh"/>             <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25171" username="asydne01"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25171" username="lnevers1"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25171" username="lnevers2"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25171" username="lnevers"/>      <rs:console server="pc1.instageni.ucsd.edu" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    </services>    
        <interface client_id="xen3:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc1:eth1" mac_address="02d0b99abafd" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+37">      
            <ip address="192.168.1.3" netmask="255.255.255.0" type="ipv4"/>      
        </interface>    
      <rs:vnode hardware_type="pcvm" name="pcvm1-2" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    <host name="xen3.IG-CT-1.ch-geni-net.instageni.ucsd.edu"/>  </node>  
    <node client_id="xen4" component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc3" component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" exclusive="false" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+29">    
        <sliver_type name="emulab-xen"/>    
        <services>             <execute command="sudo apt-get install iperf -y" shell="sh"/>             <login authentication="ssh-keys" hostname="pc3.instageni.ucsd.edu" port="25170" username="asydne01"/>      <login authentication="ssh-keys" hostname="pc3.instageni.ucsd.edu" port="25170" username="lnevers1"/>      <login authentication="ssh-keys" hostname="pc3.instageni.ucsd.edu" port="25170" username="lnevers2"/>      <login authentication="ssh-keys" hostname="pc3.instageni.ucsd.edu" port="25170" username="lnevers"/>      <rs:console server="pc3.instageni.ucsd.edu" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    </services>    
        <interface client_id="xen4:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc3:eth1" mac_address="02f4dc141a0a" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+38">      
            <ip address="192.168.1.4" netmask="255.255.255.0" type="ipv4"/>      
        </interface>    
      <rs:vnode hardware_type="pcvm" name="pcvm3-1" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    <host name="xen4.IG-CT-1.ch-geni-net.instageni.ucsd.edu"/>  </node>  
    <link client_id="lan0" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+34" vlantag="258">    
        <component_manager name="urn:publicid:IDN+instageni.ucsd.edu+authority+cm"/>    
        <interface_ref client_id="xen1:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc1:eth1" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+35"/>    
        <interface_ref client_id="xen2:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc2:eth1" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+36"/>    
        <interface_ref client_id="xen3:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc1:eth1" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+37"/>    
        <interface_ref client_id="xen4:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc3:eth1" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+38"/>    
        <link_type name="lan"/>    
    </link>  
  <rs:site_info xmlns:rs="http://www.protogeni.net/resources/rspec/ext/site-info/1">    <rs:location country="US" latitude="32.888" longitude="-117.239"/>  </rs:site_info></rspec>
11:34:08 INFO    : Reservation at ucsd-ig in slice IG-CT-1 expires at 2017-06-01 15:32:41 (UTC).
Got Reserved resources RSpec from instageni-ucsd-edu. Reservation at ucsd-ig in slice IG-CT-1 expires at 2017-06-01 15:32:41 (UTC).

The following is login information for the sliver:

$ readyToLogin -a ucsd-ig IG-CT-1
<...>
xen4's geni_status is: ready 
User lnevers logs in to xen4 using:
	ssh -p 25170  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc3.instageni.ucsd.edu

xen3's geni_status is: ready 
User lnevers logs in to xen3 using:
	ssh -p 25171  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc1.instageni.ucsd.edu

xen2's geni_status is: ready 
User lnevers logs in to xen2 using:
	ssh -p 25170  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc2.instageni.ucsd.edu

xen1's geni_status is: ready 
User lnevers logs in to xen1 using:
	ssh -p 25170  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc1.instageni.ucsd.edu

Measurements

Log into specified host and collect iperf and ping statistics. All measurements are collected over 60 seconds, using default images and default link bandwidth:

Iperf InstaGENI UCSD VM-2 to VM-1 (TCP) - TCP window size: 85.0 KByte (default)

Collected: 2017-05-25

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.1 sec   688 MBytes  96.0 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-60.2 sec   107 MBytes  14.9 Mbits/sec
[  5]  0.0-60.4 sec   104 MBytes  14.4 Mbits/sec
[  6]  0.0-60.4 sec   117 MBytes  16.2 Mbits/sec
[  7]  0.0-60.4 sec   231 MBytes  32.1 Mbits/sec
[  3]  0.0-60.5 sec   142 MBytes  19.6 Mbits/sec
[SUM]  0.0-60.5 sec   700 MBytes  97.1 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[ 11]  0.0-60.2 sec  73.0 MBytes  10.2 Mbits/sec
[  7]  0.0-60.2 sec  72.5 MBytes  10.1 Mbits/sec
[  3]  0.0-60.2 sec  65.5 MBytes  9.12 Mbits/sec
[ 10]  0.0-60.3 sec  63.4 MBytes  8.82 Mbits/sec
[  6]  0.0-60.5 sec  49.5 MBytes  6.87 Mbits/sec
[  8]  0.0-60.5 sec  63.5 MBytes  8.81 Mbits/sec
[  4]  0.0-60.5 sec  74.2 MBytes  10.3 Mbits/sec
[  9]  0.0-60.5 sec  72.4 MBytes  10.0 Mbits/sec
[ 12]  0.0-60.5 sec  94.6 MBytes  13.1 Mbits/sec
[  5]  0.0-60.6 sec  66.9 MBytes  9.26 Mbits/sec
[SUM]  0.0-60.6 sec   696 MBytes  96.3 Mbits/sec

Iperf InstaGENI UCSD VM-2 to the VM-1 (UDP) - UDP buffer size: 208 KByte (default)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512798 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   685 MBytes  95.8 Mbits/sec   0.035 ms 24192/512797 (4.7%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from InstaGENI UCSD VM-2 to the VM-1

60 packets transmitted, 60 received, 0% packet loss, time 59002ms
rtt min/avg/max/mdev = 0.682/0.816/3.578/0.362 ms

IG-CT-2 - Access to New Site bare metal and VM resources

Created a slice and a sliver with one VM and one Raw PC using RSpec IG-CT-2.rspec

$ omni createsliver IG-CT-2 -a ucsd-ig IG-CT-2.rspec 
10:17:16 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
10:17:16 INFO    : Loading config file '/home/lnevers/.gcf/omni_config'
10:17:16 INFO    : Using control framework portal
10:17:16 INFO    : Member Authority is https://ch.geni.net/MA (from config)
10:17:16 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
10:17:16 INFO    : Substituting AM nickname ucsd-ig with URL https://instageni.ucsd.edu:12369/protogeni/xmlrpc/am/2.0, URN urn:publicid:IDN+instageni.ucsd.edu+authority+cm
10:17:16 INFO    : Slice urn:publicid:IDN+ch.geni.net:ln-test+slice+IG-CT-2 expires on 2017-06-01 15:44:06 UTC
10:17:16 INFO    : Creating sliver(s) from rspec file IG-CT-2.rspec for slice urn:publicid:IDN+ch.geni.net:ln-test+slice+IG-CT-2
10:17:36 INFO    :  (PG log url - look here for details on any failures: https://www.instageni.ucsd.edu/spewlogfile.php3?logfile=500baa7b9781d65337f3b8de65162a7a)
10:17:36 INFO    : Got return from CreateSliver for slice IG-CT-2 at ucsd-ig:
10:17:36 INFO    : <?xml version="1.0" ?>
10:17:36 INFO    :   <!-- Reserved resources for:
	Slice: IG-CT-2
	at AM:
	URN: urn:publicid:IDN+instageni.ucsd.edu+authority+cm
	URL: https://instageni.ucsd.edu:12369/protogeni/xmlrpc/am/2.0
 -->
10:17:36 INFO    :   <rspec expires="2017-06-01T15:44:06Z" type="manifest" xmlns="http://www.geni.net/resources/rspec/3" xmlns:flack="http://www.protogeni.net/resources/rspec/ext/flack/1" xmlns:planetlab="http://www.planet-lab.org/resources/sfa/ext/planetlab/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3   http://www.geni.net/resources/rspec/3/manifest.xsd">    

   <node client_id="VM" component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc1" component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" exclusive="false" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+86">    
        <sliver_type name="emulab-xen"/>    
        <interface client_id="VM:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc1:eth1" mac_address="0237956a2bbd" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+89">      
            <ip address="192.168.1.1" netmask="255.255.255.0" type="ipv4"/>      
        </interface>    
      <rs:vnode hardware_type="pcvm" name="pcvm1-1" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    <host name="VM.IG-CT-2.ch-geni-net.instageni.ucsd.edu"/>    <services>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25042" username="asydne01"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25042" username="lnevers1"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25042" username="lnevers2"/>      <login authentication="ssh-keys" hostname="pc1.instageni.ucsd.edu" port="25042" username="lnevers"/>      <rs:console server="pc1.instageni.ucsd.edu" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    </services>  </node>  
    <node client_id="PC" component_id="urn:publicid:IDN+instageni.ucsd.edu+node+pc4" component_manager_id="urn:publicid:IDN+instageni.ucsd.edu+authority+cm" exclusive="true" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+85">    
       <sliver_type name="raw-pc"> </sliver_type>    
        <interface client_id="PC:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc4:eth1" mac_address="02f60e78d7ac" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+90">      
            <ip address="192.168.1.2" netmask="255.255.255.0" type="ipv4"/>      
        </interface>    
      <rs:vnode hardware_type="dl360" name="pc4" xmlns:rs="http://www.protogeni.net/resources/rspec/ext/emulab/1"/>    <host ipv4="137.110.252.19" name="PC.IG-CT-2.ch-geni-net.instageni.ucsd.edu"/>    <services>      <login authentication="ssh-keys" hostname="pc4.instageni.ucsd.edu" port="22" username="asydne01"/>      <login authentication="ssh-keys" hostname="pc4.instageni.ucsd.edu" port="22" username="lnevers1"/>      <login authentication="ssh-keys" hostname="pc4.instageni.ucsd.edu" port="22" username="lnevers2"/>      <login authentication="ssh-keys" hostname="pc4.instageni.ucsd.edu" port="22" username="lnevers"/>    </services>  </node>  
    <link client_id="lan0" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+88" vlantag="258">    
        <component_manager name="urn:publicid:IDN+instageni.ucsd.edu+authority+cm"/>    
        <interface_ref client_id="VM:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc1:eth1" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+89"/>    
        <interface_ref client_id="PC:if0" component_id="urn:publicid:IDN+instageni.ucsd.edu+interface+pc4:eth1" sliver_id="urn:publicid:IDN+instageni.ucsd.edu+sliver+90"/>    
        <link_type name="lan"/>    
    </link>  
  <rs:site_info xmlns:rs="http://www.protogeni.net/resources/rspec/ext/site-info/1">    <rs:location country="US" latitude="32.888" longitude="-117.239"/>  </rs:site_info></rspec>
10:17:36 INFO    : Reservation at ucsd-ig in slice IG-CT-2 expires at 2017-06-01 15:44:06 (UTC).
10:17:37 INFO    :  ------------------------------------------------------
10:17:37 INFO    :  Completed createsliver:

  Options as run:
		aggregate: ['ucsd-ig']
		framework: portal
		project: ln-test

  Args: createsliver IG-CT-2 IG-CT-2.rspec

  Result Summary: Got Reserved resources RSpec from instageni-ucsd-edu. Reservation at ucsd-ig in slice IG-CT-2 expires at 2017-06-01 15:44:06 (UTC). 
10:17:37 INFO    :  ======================================================

Determined login information:

$ readyToLogin -a ucsd-ig IG-CT-2
<...>
PC's geni_status is: ready 
User lnevers logs in to PC using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc4.instageni.ucsd.edu

VM's geni_status is: ready 
User lnevers logs in to VM using:
	ssh -p 25042  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc1.instageni.ucsd.edu

Measurements

Log into specified host and collect iperf and ping statistics. All measurements are collected over 60 seconds, using default images and default link bandwidth:

Iperf InstaGENI UCSD PC to VM (TCP) - TCP window size: 16.0 KByte (default)

Collected: 2017-05-30

One Client

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   686 MBytes  95.9 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  7]  0.0-60.0 sec   105 MBytes  14.7 Mbits/sec
[  3]  0.0-60.0 sec   100 MBytes  14.0 Mbits/sec
[  6]  0.0-60.0 sec   176 MBytes  24.6 Mbits/sec
[  4]  0.0-60.1 sec   142 MBytes  19.9 Mbits/sec
[  5]  0.0-60.1 sec   163 MBytes  22.8 Mbits/sec
[SUM]  0.0-60.1 sec   688 MBytes  95.9 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-60.0 sec  68.8 MBytes  9.61 Mbits/sec
[  8]  0.0-60.1 sec  68.8 MBytes  9.60 Mbits/sec
[  9]  0.0-60.1 sec  68.8 MBytes  9.59 Mbits/sec
[  3]  0.0-60.2 sec  68.9 MBytes  9.60 Mbits/sec
[ 10]  0.0-60.2 sec  69.0 MBytes  9.62 Mbits/sec
[ 12]  0.0-60.2 sec  68.9 MBytes  9.60 Mbits/sec
[ 11]  0.0-60.2 sec  68.9 MBytes  9.60 Mbits/sec
[  6]  0.0-60.2 sec  68.9 MBytes  9.60 Mbits/sec
[  4]  0.0-60.2 sec  68.9 MBytes  9.60 Mbits/sec
[  7]  0.0-60.3 sec  69.0 MBytes  9.60 Mbits/sec
[SUM]  0.0-60.3 sec   689 MBytes  95.9 Mbits/sec

Iperf InstaGENI UCSD PC to the VM (UDP) - UDP buffer size: 114 KByte (default)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   690 MBytes  96.4 Mbits/sec
[  3] Sent 492015 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   690 MBytes  96.5 Mbits/sec   0.006 ms    9/492014 (0.0018%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from InstaGENI UCSD PC to VM

60 packets transmitted, 60 received, 0% packet loss, time 58997ms
rtt min/avg/max/mdev = 0.472/0.555/0.635/0.029 ms

Iperf InstaGENI UCSD VM to PC (TCP) - TCP window size: 85.0 KByte (default)

Collected: 2017-05-30

One Client

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   686 MBytes  95.9 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-59.1 sec   125 MBytes  17.7 Mbits/sec
[  7]  0.0-59.1 sec   126 MBytes  17.9 Mbits/sec
[  4]  0.0-59.1 sec   137 MBytes  19.5 Mbits/sec
[  5]  0.0-60.0 sec   155 MBytes  21.7 Mbits/sec
[  6]  0.0-60.0 sec   141 MBytes  19.6 Mbits/sec
[SUM]  0.0-60.0 sec   685 MBytes  95.7 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-59.1 sec  64.6 MBytes  9.17 Mbits/sec
[  3]  0.0-59.1 sec  71.8 MBytes  10.2 Mbits/sec
[  9]  0.0-59.1 sec  65.8 MBytes  9.33 Mbits/sec
[  6]  0.0-59.1 sec  62.8 MBytes  8.90 Mbits/sec
[  8]  0.0-59.2 sec  79.8 MBytes  11.3 Mbits/sec
[ 11]  0.0-59.2 sec  73.9 MBytes  10.5 Mbits/sec
[  5]  0.0-59.2 sec  65.4 MBytes  9.26 Mbits/sec
[  7]  0.0-59.4 sec  64.9 MBytes  9.16 Mbits/sec
[ 12]  0.0-60.0 sec  71.0 MBytes  9.93 Mbits/sec
[ 10]  0.0-60.0 sec  64.6 MBytes  9.03 Mbits/sec
[SUM]  0.0-60.0 sec   684 MBytes  95.6 Mbits/sec

Iperf InstaGENI UCSD VM to the PC (UDP) - UDP buffer size: 208 KByte (default)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512807 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   694 MBytes  97.1 Mbits/sec   0.106 ms 17577/512806 (3.4%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from InstaGENI UCSD VM to PC

60 packets transmitted, 60 received, 0% packet loss, time 59000ms
rtt min/avg/max/mdev = 0.446/0.527/0.617/0.037 ms

IG-CT-3 - Multiple sites experiment

Created a slice and a sliver with one VM at UCSD and one VMi at NYSERNET using RSpec IG-CT-3.rspec. Used stitcher to create both the HAWAII and GPO slivers:

$ stitcher createsliver IG-CT-3a -a ucsd-ig ./IG-CT-3.rspec 
10:16:28 INFO    : Configured logging from file /home/lnevers/geni-tools-2.10/src/gcf/stitcher_logging.conf
10:16:28 INFO    : Reading slice IG-CT-3a credential...
10:16:28 INFO    : Slice urn:publicid:IDN+ch.geni.net:ln-test+slice+IG-CT-3a expires on 2017-06-01 15:47:04 UTC
10:16:29 INFO    : Multi-AM reservation will include resources from these aggregates:
10:16:29 INFO    : 	<Aggregate nysernet-ig>
10:16:29 INFO    : 	<Aggregate ucsd-ig>
10:16:29 INFO    : Stitcher doing createsliver at <Aggregate nysernet-ig>...
10:16:47 INFO    : ... Allocation at <Aggregate nysernet-ig> complete.
10:16:47 INFO    : Stitcher doing createsliver at <Aggregate ucsd-ig>...
10:17:09 INFO    : ... Allocation at <Aggregate ucsd-ig> complete.
10:17:09 INFO    : All aggregates are complete.
10:17:09 INFO    : Your resources expire at 2017-06-01T14:06:29 (UTC). 
10:17:09 INFO    : Saved combined reservation RSpec at 2 AM(s) to file '/home/lnevers/gcf-test/instarspec/UCSD/IG-CT-3a-manifest-rspec-multiam-combined.xml'
Success: Reserved resources in slice IG-CT-3a at 2 Aggregates, creating 1 GRE link(s).

Determined login information at each UCSD and NYSERNet aggregate:

$ readyToLogin IG-CT-3a --useSliceAggregates
 ....
ig-ucsd's geni_status is: notready 
User lnevers logs in to ig-ha using:
	ssh -p 25202  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc2.instageni.ucsd.edu

ig-nyse's geni_status is: ready 
User lnevers logs in to ig-gpo using:
	ssh -p 25074  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc1.instageni.nysernet.org

Measurements

Iperf InstaGENI NYSERNet VM to UCSD VM (TCP) - TCP window size: 16.0 KByte (default)

Collected: 2017-05-XX

One Client

Five Clients

Ten Clients

Iperf InstaGENI NYSERNet VM to UCSD VM (UDP) - UDP buffer size: 136 KByte (default)

Ping from InstaGENI NYSERNet VM to the UCSD VM

Iperf InstaGENI UCSD VM to NYSERNet VM (TCP) - TCP window size: 16.0 KByte (default)

Collected: 2017-05-XX

One Client

Five Clients

Ten Clients

Iperf InstaGENI UCSD VM to NYSERNet VM (UDP) - 136 KByte (default)

Ping from InstaGENI UCSD VM to NYSERNet VM

IG-CT-4 - Multiple sites OpenFlow experiment and interoperability

No meso-scale available, see HAWII Stitching OpenFlow test [wiki:GeniNetworkStitchingConfirmationTestStatus/UHawaii#IG-ST-6NewSiteOpenFlowtopology? IG-ST-6 status.

IG-CT-5 - Experiment Monitoring

Check for site's compute aggregate availability and External Checks for site aggregates:

Check for status for one of the site VM Servers:

Check for status of GPO Check for Stitching:

IG-CT-6 - Administrative Tests

Sent request for administrative account to site contact from the UCSD InstaGENI aggregate page. Followed instructions at the InstaGENI Administration page for account request. A local administrator account was requested by joining the emulab-ops group at https://www.instageni.ucsd.edu/joinproject.php3. Once the administrative account was approved and the membership to emulab-ops was granted, proceeded to execute administrative tests.

LNM:~$ ssh lneversu@control.instageni.ucsd.edu
The authenticity of host 'control.instageni.ucsd.edu (137.110.252.3)' can't be established.
ECDSA key fingerprint is SHA256:MWg1PPkOwto+dpX2N6vcjaQjBtW5mIvu6lj9Jya6M/8.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'control.instageni.ucsd.edu,137.110.252.3' (ECDSA) to the list of known hosts.
Welcome to Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-117-generic x86_64)

 * Documentation:  https://help.ubuntu.com/

  System information as of Wed Jun  7 13:23:03 PDT 2017

  System load:     0.0               IP address for xenbr0: 137.110.252.3
  Usage of /:      25.6% of 5.65GB   IP address for xenbr1: 10.1.1.254
  Memory usage:    7%                IP address for xenbr2: 10.2.1.254
  Swap usage:      0%                IP address for xenbr3: 10.3.1.254
  Processes:       237               IP address for tun0:   10.8.0.1
  Users logged in: 1

  Graph this data and manage this system at:
    https://landscape.canonical.com/
New release '16.04.2 LTS' available.
Run 'do-release-upgrade' to upgrade to it.


The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

lneversu@ucsd:~$ sudo whoami
root
lneversu@ucsd:~$ uname -a
Linux ucsd.control-nodes.geniracks.net 3.13.0-117-generic #164-Ubuntu SMP Fri Apr 7 11:05:26 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
lneversu@ucsd:~$ 

Also access the boss node:

LNM:~$ ssh lneversu@boss.instageni.ucsd.edu
FreeBSD 9.0-STABLE (TESTBED-XEN) #0: Mon Mar  3 15:37:17 MST 2014

Welcome to FreeBSD!

If you `set watch = (0 any any)' in tcsh, you will be notified when
someone logs in or out of your system.
> bash
[lneversu@boss ~]$ sudo whoami 
root
[lneversu@boss ~]$ uname -a
FreeBSD boss.instageni.ucsd.edu 9.0-STABLE FreeBSD 9.0-STABLE #0: Mon Mar  3 15:37:17 MST 2014     root@node.freebsd90-node.testbed.emulab.net:/usr/obj/usr/src/sys/TESTBED-XEN  i386
[lneversu@boss ~]$ 

From boss node accessed each of the experiment nodes that support VMs:

[lneversu@boss ~]$ for i in pc1 pc2 pc3; do ssh $i "echo -n '===> Host: ';hostname;sudo whoami;uname -a;echo"; done
Warning: Permanently added 'pc1.instageni.ucsd.edu' (RSA) to the list of known hosts.
===> Host: vhost1.shared-nodes.emulab-ops.instageni.ucsd.edu
root
Linux vhost1.shared-nodes.emulab-ops.instageni.ucsd.edu 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc2.instageni.ucsd.edu' (RSA) to the list of known hosts.
===> Host: vhost2.shared-nodes.emulab-ops.instageni.ucsd.edu
root
Linux vhost2.shared-nodes.emulab-ops.instageni.ucsd.edu 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Warning: Permanently added 'pc3.instageni.ucsd.edu' (RSA) to the list of known hosts.
===> Host: vhost3.shared-nodes.emulab-ops.instageni.ucsd.edu
root
Linux vhost3.shared-nodes.emulab-ops.instageni.ucsd.edu 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

[lneversu@boss ~]$ 

In order to access Dedicated Nodes some experiment must be running on the raw-pc device. At the time of this capture two raw-pc nodes were in use (pc4 and pc5):

[lneversu@boss ~]$  for i in pc4 pc5 ; do sudo ssh $i "echo -n '===> Host: ';hostname;whoami;uname -a;echo"; done 
===> Host: pc2.2pc.ch-geni-net.instageni.ucsd.edu
root
Linux pc2.2pc.ch-geni-net.instageni.ucsd.edu 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

===> Host: pc.2pc.ch-geni-net.instageni.ucsd.edu
root
Linux pc.2pc.ch-geni-net.instageni.ucsd.edu 4.4.0-45-generic #66-Ubuntu SMP Wed Oct 19 14:12:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

[lneversu@boss ~]$ 

Further verified access by ssh from ops.instageni.ucsd.edu to boss.instageni.ucsd.edu, which is usually restricted for non-admin users:

LNM:~$ ssh lneversu@ops.instageni.ucsd.edu
Last login: Thu Jun  1 12:40:37 2017 from 128.89.73.1
FreeBSD 9.0-STABLE (TESTBED-XEN) #0: Mon Mar  3 15:37:17 MST 2014

Welcome to FreeBSD!

Need to quickly return to your home directory? Type "cd".
		-- Dru <genesis@istar.ca>
> bash
[lneversu@ops ~]$ sudo whoami
root
[lneversu@ops ~]$ uname -a
FreeBSD ops.instageni.ucsd.edu 9.0-STABLE FreeBSD 9.0-STABLE #0: Mon Mar  3 15:37:17 MST 2014     root@node.freebsd90-node.testbed.emulab.net:/usr/obj/usr/src/sys/TESTBED-XEN  i386
[lneversu@ops ~]$ ssh boss
The authenticity of host 'boss.instageni.ucsd.edu (137.110.252.4)' can't be established.
ECDSA key fingerprint is bd:05:23:a7:5b:cc:78:c8:8c:a8:d3:e9:f7:27:53:cb.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'boss.instageni.ucsd.edu' (ECDSA) to the list of known hosts.
Last login: Thu Jun  1 12:40:57 2017 from 128.89.73.1
FreeBSD 9.0-STABLE (TESTBED-XEN) #0: Mon Mar  3 15:37:17 MST 2014

Welcome to FreeBSD!

To read a compressed file without having to first uncompress it, use
"zcat" or "zmore" to view it.
		-- Dru <genesis@istar.ca>
> bash
[lneversu@boss ~]$

Access infrastructure switches using documented password. First connect to the switch named procurve1 the control network switch:

[lnevers@boss ~]$ sudo more /usr/testbed/etc/switch.pswd
XXXXXXXXX
[lneversu@boss ~]$ sudo ssh procurve1
We'd like to keep you up to date about:
  * Software feature updates
  * New product announcements
  * Special events
Please register your products now at:  www.hp.com/networking/register


HP J9623A E2620-24 Switch
Software revision RA.15.08.0009

Copyright (C) 1991-2012 Hewlett-Packard Development Company, L.P.

                   RESTRICTED RIGHTS LEGEND
 Confidential computer software.  Valid license from HP required for possession,
 use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer
 Software, Computer Software Documentation, and Technical Data for Commercial
 Items are licensed to the U.S. Government under vendor's standard commercial
 license.
                   HEWLETT-PACKARD DEVELOPMENT COMPANY, L.P. 
                   20555 State Highway 249, Houston, TX 77070

Press any key to continue

HP-E2620-24# show version 
Image stamp:    /ws/swbuildm/rel_galt_qaoff/code/build/xform(rel_galt_qaoff)
                May  9 2012 15:28:43
                RA.15.08.0009
                474
Boot Image:     Primary
HP-E2620-24# show vlan

 Status and Counters - VLAN Information

  Maximum VLANs to support : 50                   
  Primary VLAN : DEFAULT_VLAN     
  Management VLAN : control-hardware 

  VLAN ID Name                             | Status     Voice Jumbo
  ------- -------------------------------- + ---------- ----- -----
  1       DEFAULT_VLAN                     | Port-based No    No   
  10      control-hardware                 | Port-based No    No   
  11      control-alternate                | Port-based No    No   
 
HP-E2620-24# show interfaces brief 

 Status and Counters - Port Status

                  | Intrusion                           MDI  Flow Bcast
  Port  Type      | Alert     Enabled Status Mode       Mode Ctrl Limit
  ----- --------- + --------- ------- ------ ---------- ---- ---- -----
  1     10/100TX  | No        Yes     Up     100FDx     MDI  off  0    
  2     10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  3     10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  4     10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  5     10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  6     10/100TX  | No        Yes     Up     100FDx     MDI  off  0    
  7     10/100TX  | No        Yes     Up     100FDx     MDI  off  0    
  8     10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  9     10/100TX  | No        Yes     Up     100FDx     MDI  off  0    
  10    10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  11    10/100TX  | No        Yes     Down   10FDx      MDIX off  0    
  12    10/100TX  | No        Yes     Down   10FDx      MDI  off  0    
  13    10/100TX  | No        Yes     Down   10FDx      MDI  off  0    
  14    10/100TX  | No        Yes     Down   10FDx      MDI  off  0    
  15    10/100TX  | No        Yes     Down   10FDx      MDIX off  0    
  16    10/100TX  | No        Yes     Down   10FDx      MDIX off  0    
  17    10/100TX  | No        Yes     Down   10FDx      MDIX off  0    
  18    10/100TX  | No        Yes     Down   10FDx      MDIX off  0    
  19    10/100TX  | No        Yes     Down   10FDx      MDIX off  0    
  20    10/100TX  | No        Yes     Down   10FDx      MDI  off  0    
  21    10/100TX  | No        Yes     Down   10FDx      MDIX off  0    
  22    10/100TX  | No        Yes     Up     100FDx     MDI  off  0    
  23    10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  24    10/100TX  | No        Yes     Up     100FDx     MDIX off  0    
  25    100/1000T | No        Yes     Up     1000FDx    MDIX off  0    
  26    100/1000T | No        Yes     Down   1000FDx    MDIX off  0    
  27              | No        Yes     Down                   off  0    
  28    1000LX    | No        Yes     Up     1000FDx    NA   off  0    
 
HP-E2620-24# show running-config 

Running configuration:

; J9623A Configuration Editor; Created on release #RA.15.08.0009
; Ver #02:13.2d:3c
hostname "HP-E2620-24"
max-vlans 50
no stack
no web-management
ip default-gateway 10.1.1.254
snmp-server community "xxx" unrestricted
aaa authentication ssh login public-key
aaa authentication ssh enable public-key
vlan 1
   name "DEFAULT_VLAN"
   no untagged 23-24
   untagged 1-22,25-28
   ip address 10.254.254.253 255.255.255.0
   ip igmp
   exit
vlan 10
   name "control-hardware"
   untagged 23
   ip address 10.1.1.253 255.255.255.0
   exit
vlan 11
   name "control-alternate"
   untagged 24
   ip address 10.2.1.253 255.255.255.0
   exit
management-vlan 10
no dhcp config-file-update
password xxx
password xxx

HP-E2620-24# 

Connect to the switch named procurve2 the dataplane network switch via ssh using the documented password:

[lneversu@boss ~]$ sudo ssh procurve2
We'd like to keep you up to date about:
  * Software feature updates
  * New product announcements
  * Special events
Please register your products now at:  www.hp.com/networking/register


HP J8697A Switch E5406zl
Software revision K.15.06.5008

Copyright (C) 1991-2012 Hewlett-Packard Development Company, L.P.

                   RESTRICTED RIGHTS LEGEND
 Confidential computer software.  Valid license from HP required for possession,
 use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer
 Software, Computer Software Documentation, and Technical Data for Commercial
 Items are licensed to the U.S. Government under vendor's standard commercial
 license.
                   HEWLETT-PACKARD DEVELOPMENT COMPANY, L.P. 
                   20555 State Highway 249, Houston, TX 77070

Press any key to continue

xxxxxxx
[lneversu@boss ~]$ sudo ssh procurve2
We'd like to keep you up to date about:
  * Software feature updates
  * New product announcements
  * Special events
Please register your products now at:  www.hp.com/networking/register


HP J8697A Switch E5406zl
Software revision K.15.06.5008

Copyright (C) 1991-2012 Hewlett-Packard Development Company, L.P.

                   RESTRICTED RIGHTS LEGEND
 Confidential computer software.  Valid license from HP required for possession,
 use or copying. Consistent with FAR 12.211 and 12.212, Commercial Computer
 Software, Computer Software Documentation, and Technical Data for Commercial
 Items are licensed to the U.S. Government under vendor's standard commercial
 license.
                   HEWLETT-PACKARD DEVELOPMENT COMPANY, L.P. 
                   20555 State Highway 249, Houston, TX 77070

Press any key to continue


HP-E5406zl# show version
Image stamp:    /ws/swbuildm/of_bridge_qaoff/code/build/btm(of_bridge_qaoff)
                Feb 18 2012 11:26:28
                K.15.06.5008
                79
Boot Image:     Primary
HP-E5406zl# show vlan 

 Status and Counters - VLAN Information

  Maximum VLANs to support : 256                  
  Primary VLAN : DEFAULT_VLAN    
  Management VLAN : control-hardware

  VLAN ID Name                             | Status     Voice Jumbo
  ------- -------------------------------- + ---------- ----- -----
  1       DEFAULT_VLAN                     | Port-based No    No   
  10      control-hardware                 | Port-based No    No   
  257     5012                             | Port-based No    No   
  258     5042                             | Port-based No    No   
  1720    5039                             | Port-based No    No   
  1729    5035                             | Port-based No    No   
  1731    5036                             | Port-based No    No   
  1733    5038                             | Port-based No    No   
  1734    5040                             | Port-based No    No   
  1735    5037                             | Port-based No    No   
  1739    5041                             | Port-based No    No   
 

HP-E5406zl# show running

Running configuration:

; J8697A Configuration Editor; Created on release #K.15.06.5008
; Ver #02:10.0d:1f

hostname "HP-E5406zl" 
module 1 type J9549A 
interface A1 
   speed-duplex auto-1000 
exit
interface A2 
   speed-duplex auto-1000 
exit
interface A3 
   speed-duplex auto-1000 
exit
interface A4 
   speed-duplex auto-1000 
exit
interface A5 
   speed-duplex auto-1000 
exit
interface A6 
   speed-duplex auto-1000 
exit
interface A7 
   speed-duplex auto-1000 
exit
interface A8 
   speed-duplex auto-1000 
exit
interface A9 
   speed-duplex auto-1000 
exit
interface A10 
   speed-duplex auto-1000 
exit
interface A13 
   speed-duplex auto-1000 
exit
ip default-gateway 10.3.1.7 
vlan 1 
   name "DEFAULT_VLAN" 
   forbid A1-A9 
   untagged A11-A12,A14-A19,A21-A23 
   no untagged A1-A10,A13,A20,A24 
   no ip address 
   exit 
vlan 10 
   name "control-hardware" 
   untagged A20 
   ip address 10.3.1.253 255.255.255.0 
   exit 
vlan 257 
   name "5012" 
   untagged A1-A9 
   no ip address 
   exit 
vlan 1729 
   name "5035" 
   tagged A4,A24 
   no ip address 
   exit 
vlan 1731 
   name "5036" 
   tagged A1,A24 
   no ip address 
   exit 
vlan 1735 
   name "5037" 
   tagged A1,A24 
   no ip address 
   exit 
vlan 1733 
   name "5038" 
   tagged A1,A24 
   no ip address 
   exit 
vlan 1720 
   name "5039" 
   tagged A1,A24 
   no ip address 
   exit 
vlan 1734 
   name "5040" 
   tagged A4,A24 
   no ip address 
   exit 
vlan 1739 
   name "5041" 
   tagged A1,A24 
   no ip address 
   exit 
vlan 258 
   name "5042" 
   untagged A10,A13 
   no ip address 
   exit 
no web-management
openflow
   vlan 1734
      enable
      controller "tcp:128.95.190.50:6633" listener "ptcp:5000" fail-secure on
      exit
   exit
snmp-server community "xxx" unrestricted
aaa authentication ssh login public-key
aaa authentication ssh enable public-key
management-vlan 10
no autorun
no dhcp config-file-update
no dhcp image-file-update
password xxx
password xxx

HP-E5406zl# ping 172.217.7.228     
172.217.7.228 is alive, time = 65 ms
HP-E5406zl# 

Access the FlowVisor VM and gather version information:

LNM:~$ ssh lneversu@flowvisor.instageni.ucsd.edu
The authenticity of host 'flowvisor.instageni.ucsd.edu (137.110.252.7)' can't be established.
ECDSA key fingerprint is SHA256:WcB/cfDifjBbVJmjCp4pJOqLBNjQl3ICmB15uZlc5oU.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'flowvisor.instageni.ucsd.edu,137.110.252.7' (ECDSA) to the list of known hosts.
Welcome to Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-112-generic x86_64)

 * Documentation:  https://help.ubuntu.com/
New release '16.04.2 LTS' available.
Run 'do-release-upgrade' to upgrade to it.


The programs included with the Ubuntu system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

lneversu@SDNnat:~$ sudo whoami
root
lneversu@SDNnat:~$ uname -a
Linux SDNnat 3.13.0-112-generic #159-Ubuntu SMP Fri Mar 3 15:26:07 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
lneversu@SDNnat:~$ exit
logout
Connection to flowvisor.instageni.ucsd.edu closed.
LNM:~$ 


Email help@geni.net for GENI support or email me with feedback on this page!

Attachments (3)

Download all attachments as: .zip