wiki:GENIRacksHome/ExogeniRacks/ConfirmationTestStatus/StarLight

Version 20 (modified by lnevers@bbn.com, 4 years ago) (diff)

--

StarLight ExoGENI Confirmation Tests

For details about the tests in this page, see the ExoGENI Confirmation Tests page.
For site status see the ExoGENI New Site Confirmation Tests Status page.

Note: Omni nick_names for site aggregates used for these tests are:

sl-eg=urn:publicid:IDN+exogeni.net:slvmsite+authority+am,https://sl-hn.exogeni.net:11443/orca/xmlrpc
sl-eg-of=urn:publicid:IDN+openflow:foam:sl-hn.exogeni.net+authority+am,https://sl-hn.exogeni.net:3626/foam/gapi/2

EG-CT-1 - Access to New Site VM resources

First determine orca_version running at this aggregate:

$ omni -a sl-eg getversion   
13:10:41 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
13:10:41 INFO    : Loading config file /home/lnevers/.gcf/omni_config
13:10:41 INFO    : Using control framework portal
13:10:41 INFO    : Member Authority is https://ch.geni.net/MA (from config)
13:10:41 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
13:10:41 INFO    : Substituting AM nickname sl-eg with URL https://sl-hn.exogeni.net:11443/orca/xmlrpc, URN urn:publicid:IDN+exogeni.net:slvmsite+authority+am
13:10:41 INFO    : AM sl-eg URN: urn:publicid:IDN+exogeni.net:slvmsite+authority+am (url: https://sl-hn.exogeni.net:11443/orca/xmlrpc) has version:
13:10:41 INFO    : {   'geni_ad_rspec_versions': [   {   'extensions': [   'http://hpn.east.isi.edu/rspec/ext/stitch/0.1/stitch-schema.xsd',
                                                        'http://www.protogeni.net/resources/rspec/ext/emulab/1/ptop_extension.xsd'],
                                      'namespace': 'http://www.geni.net/resources/rspec/3',
                                      'schema': 'http://www.geni.net/resources/rspec/3/ad.xsd',
                                      'type': 'GENI',
                                      'version': '3'}],
    'geni_am_type': 'orca',
    'geni_api': 2,
    'geni_api_versions': {   '2': 'https://sl-hn.exogeni.net:11443/orca/geni'},
    'geni_request_rspec_versions': [   {   'extensions': [   'http://www.geni.net/resources/rspec/ext/shared-vlan/1',
                                                             'http://www.geni.net/resources/rspec/ext/postBootScript/1',
                                                             'http://hpn.east.isi.edu/rspec/ext/stitch/0.1/'],
                                           'namespace': 'http://www.geni.net/resources/rspec/3',
                                           'schema': 'http://www.geni.net/resources/rspec/3/request.xsd',
                                           'type': 'GENI',
                                           'version': '3'}],
    'orca_version': 'ORCA Dungeness: v.4.0-SNAPSHOT.build-6427'}
13:10:41 INFO    :  ------------------------------------------------------
13:10:41 INFO    :  Completed getversion:
  Options as run:
		aggregate: ['sl-eg']
		framework: portal
		noGetVersionCache: True
		project: Luisa_Nevers-Test-Proj_01
  Args: getversion
  Result Summary: 
Got version for sl-eg
13:10:41 INFO    :  ======================================================

Compared with versions in other racks, the following version were found:

getversion-exogeni-net-bbnvmsite.json:    'orca_version': 'ORCA Dungeness: v.4.0-SNAPSHOT.build-6427'}
getversion-exogeni-net-fiuvmsite.json:    'orca_version': 'ORCA Dungeness: v.4.0-SNAPSHOT.build-6427'}
getversion-exogeni-net-rcivmsite.json:    'orca_version': 'ORCA Dungeness: v.4.0-SNAPSHOT.build-6427'}
getversion-exogeni-net-slvmsite.json:    'orca_version': 'ORCA Dungeness: v.4.0-SNAPSHOT.build-6427'}
getversion-exogeni-net-uhvmsite.json:    'orca_version': 'ORCA Dungeness: v.4.0-SNAPSHOT.build-6427'}
getversion-exogeni-net.json:             'orca_version': 'ORCA Dungeness: v.4.0-SNAPSHOT.build-6427'}

Created a slice:

$  omni createslice EG-CT-1
13:14:58 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
13:14:58 INFO    : Loading config file /home/lnevers/.gcf/omni_config
13:14:58 INFO    : Using control framework portal
13:14:58 INFO    : Member Authority is https://ch.geni.net/MA (from config)
13:14:58 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
13:14:59 INFO    : Created slice with Name EG-CT-1, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-1, Expiration 2014-06-18 17:14:58+00:00
13:14:59 INFO    :  ------------------------------------------------------
13:14:59 INFO    :  Completed createslice:
  Options as run:
		framework: portal
		project: Luisa_Nevers-Test-Proj_01
  Args: createslice EG-CT-1
  Result Summary: Created slice with Name EG-CT-1, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-1, Expiration 2014-06-18 17:14:58+00:00
13:14:59 INFO    :  ======================================================

Created a 4 VMs sliver using the RSpec EG-CT-1-sl.rspec

$ omni createsliver -a sl-eg EG-CT-1 EG-CT-1-sl.rspec 
13:15:27 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
13:15:27 INFO    : Loading config file /home/lnevers/.gcf/omni_config
13:15:27 INFO    : Using control framework portal
13:15:27 INFO    : Member Authority is https://ch.geni.net/MA (from config)
13:15:27 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
13:15:27 INFO    : Substituting AM nickname sl-eg with URL https://sl-hn.exogeni.net:11443/orca/xmlrpc, URN urn:publicid:IDN+exogeni.net:slvmsite+authority+am
13:15:27 INFO    : Slice urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-1 expires on 2014-06-18 17:14:58 UTC
13:15:27 INFO    : Creating sliver(s) from rspec file EG-CT-1-sl.rspec for slice urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-1
13:15:32 INFO    : Got return from CreateSliver for slice EG-CT-1 at sl-eg:
13:15:32 INFO    : <?xml version="1.0" ?>
13:15:32 INFO    :   <!-- Reserved resources for:
	Slice: EG-CT-1
	at AM:
	URN: urn:publicid:IDN+exogeni.net:slvmsite+authority+am
	URL: https://sl-hn.exogeni.net:11443/orca/xmlrpc
 -->
13:15:32 INFO    :   
<rspec type="manifest" xmlns="http://www.geni.net/resources/rspec/3" xmlns:ns2="http://hpn.east.isi.edu/rspec/ext/stitch/0.1/" xmlns:ns3="http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1" xmlns:ns4="http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1" xmlns:ns5="http://www.geni.net/resources/rspec/ext/postBootScript/1" xmlns:ns6="http://www.geni.net/resources/rspec/ext/color/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3 http://www.geni.net/resources/rspec/3/manifest.xsd http://hpn.east.isi.edu/rspec/ext/stitch/0.1/ http://hpn.east.isi.edu/rspec/ext/stitch/0.1/stitch-schema.xsd http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1 http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1/slice_info.xsd?format=raw http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1 http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1/sliver_info.xsd?format=raw http://www.geni.net/resources/rspec/ext/postBootScript/1 http://www.geni.net/resources/rspec/ext/postBootScript/1/request.xsd http://www.geni.net/resources/rspec/ext/color/2 http://www.geni.net/resources/rspec/ext/color/2/color.xsd">  
      <node client_id="VM-1" component_id="urn:publicid:IDN+exogeni.net:slvmsite+node+orca-vm-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:slvmsite+authority+am" component_name="orca-vm-cloud" exclusive="false" sliver_id="urn:publicid:IDN+exogeni.net:slvmslite+sliver+d89a7638-4c01-49f2-b9b6-d245c5c5c986:VM-1">    
            <location country="Unspecified" latitude="42.05286" longitude="-87.681564"/>    
            <sliver_type name="m1.large">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="VM-1:if0" mac_address="fe:16:3e:00:56:90">      
                  <ip address="172.16.1.1" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-06-11T17:15:29.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-06-18T17:14:58.000Z" start_time="2014-06-11T17:15:29.000Z" state="configuring"/>    
      </node>  
      <node client_id="VM-2" component_id="urn:publicid:IDN+exogeni.net:slvmsite+node+orca-vm-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:slvmsite+authority+am" component_name="orca-vm-cloud" exclusive="false" sliver_id="urn:publicid:IDN+exogeni.net:slvmslite+sliver+d89a7638-4c01-49f2-b9b6-d245c5c5c986:VM-2">    
            <location country="Unspecified" latitude="42.05286" longitude="-87.681564"/>    
            <sliver_type name="m1.large">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="VM-2:if0" mac_address="fe:16:3e:00:75:6f">      
                  <ip address="172.16.1.2" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-06-11T17:15:29.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-06-18T17:14:58.000Z" start_time="2014-06-11T17:15:29.000Z" state="configuring"/>    
      </node>  
      <node client_id="VM-3" component_id="urn:publicid:IDN+exogeni.net:slvmsite+node+orca-vm-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:slvmsite+authority+am" component_name="orca-vm-cloud" exclusive="false" sliver_id="urn:publicid:IDN+exogeni.net:slvmslite+sliver+d89a7638-4c01-49f2-b9b6-d245c5c5c986:VM-3">    
            <location country="Unspecified" latitude="42.05286" longitude="-87.681564"/>    
            <sliver_type name="m1.large">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="VM-3:if0" mac_address="fe:16:3e:00:52:e6">      
                  <ip address="172.16.1.3" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-06-11T17:15:29.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-06-18T17:14:58.000Z" start_time="2014-06-11T17:15:29.000Z" state="configuring"/>    
      </node>  
      <node client_id="VM-4" component_id="urn:publicid:IDN+exogeni.net:slvmsite+node+orca-vm-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:slvmsite+authority+am" component_name="orca-vm-cloud" exclusive="false" sliver_id="urn:publicid:IDN+exogeni.net:slvmslite+sliver+d89a7638-4c01-49f2-b9b6-d245c5c5c986:VM-4">    
            <location country="Unspecified" latitude="42.05286" longitude="-87.681564"/>    
            <sliver_type name="m1.large">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="VM-4:if0" mac_address="fe:16:3e:00:7b:04">      
                  <ip address="172.16.1.4" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-06-11T17:15:29.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-06-18T17:14:58.000Z" start_time="2014-06-11T17:15:29.000Z" state="configuring"/>    
      </node>  
      <link client_id="lan0" sliver_id="urn:publicid:IDN+exogeni.net:slvmslite+sliver+d89a7638-4c01-49f2-b9b6-d245c5c5c986:lan0" vlantag="unknown">    
            <interface_ref client_id="VM-4:if0"/>    
            <property capacity="0" dest_id="VM-2:if0" source_id="VM-4:if0"/>    
            <property capacity="0" dest_id="VM-3:if0" source_id="VM-4:if0"/>    
            <property capacity="0" dest_id="VM-1:if0" source_id="VM-4:if0"/>    
            <interface_ref client_id="VM-2:if0"/>    
            <property capacity="0" dest_id="VM-4:if0" source_id="VM-2:if0"/>    
            <property capacity="0" dest_id="VM-3:if0" source_id="VM-2:if0"/>    
            <property capacity="0" dest_id="VM-1:if0" source_id="VM-2:if0"/>    
            <interface_ref client_id="VM-3:if0"/>    
            <property capacity="0" dest_id="VM-4:if0" source_id="VM-3:if0"/>    
            <property capacity="0" dest_id="VM-2:if0" source_id="VM-3:if0"/>    
            <property capacity="0" dest_id="VM-1:if0" source_id="VM-3:if0"/>    
            <interface_ref client_id="VM-1:if0"/>    
            <property capacity="0" dest_id="VM-4:if0" source_id="VM-1:if0"/>    
            <property capacity="0" dest_id="VM-2:if0" source_id="VM-1:if0"/>    
            <property capacity="0" dest_id="VM-3:if0" source_id="VM-1:if0"/>    
            <ns4:geni_sliver_info creation_time="2014-06-11T17:15:29.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-06-18T17:14:58.000Z" start_time="2014-06-11T17:15:29.000Z" state="configuring"/>    
      </link>  
      <ns3:geni_slice_info state="configuring" urn="urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-1" uuid="acf47029-2bc5-47fe-bd0d-bd1895650de2"/>  
</rspec>
13:15:32 INFO    :  ------------------------------------------------------
13:15:32 INFO    :  Completed createsliver:
  Options as run:
		aggregate: ['sl-eg']
		framework: portal
		project: Luisa_Nevers-Test-Proj_01
  Args: createsliver EG-CT-1 EG-CT-1-sl.rspec
  Result Summary: Got Reserved resources RSpec from exogeni-net-slvmsite 
13:15:32 INFO    :  ======================================================

When the sliver was ready determine login information:

$ readyToLogin -a sl-eg EG-CT-1
  <....>
================================================================================
LOGIN INFO for AM: https://sl-hn.exogeni.net:11443/orca/xmlrpc
================================================================================

For more login info, see the section entitled:
	 'Providing a private key to ssh' in 'readyToLogin.py -h'

VM-4's geni_status is: ready (am_status:ready) 
User lnevers logs in to VM-4 using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.7

VM-1's geni_status is: ready (am_status:ready) 
User lnevers logs in to VM-1 using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.10

VM-2's geni_status is: ready (am_status:ready) 
User lnevers logs in to VM-2 using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.8

VM-3's geni_status is: ready (am_status:ready) 
User lnevers logs in to VM-3 using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.9

Measurements

Login to two of the nodes and collect iperf and ping statistics. All measurements are collected over 60 seconds:

Collected: 2014-06-11

Iperf ExoGENI VM-2 to VM-1 (TCP) - TCP window size: 16.0 KB

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  29.9 GBytes  4.29 Gbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  8.46 GBytes  1.21 Gbits/sec
[  5]  0.0-60.0 sec  8.43 GBytes  1.21 Gbits/sec
[  6]  0.0-60.0 sec  8.45 GBytes  1.21 Gbits/sec
[  4]  0.0-60.0 sec  8.45 GBytes  1.21 Gbits/sec
[  7]  0.0-60.0 sec  8.49 GBytes  1.22 Gbits/sec
[SUM]  0.0-60.0 sec  42.3 GBytes  6.05 Gbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  3.92 GBytes    561 Mbits/sec
[  5]  0.0-60.0 sec  3.97 GBytes    568 Mbits/sec
[  6]  0.0-60.0 sec  3.97 GBytes    569 Mbits/sec
[  7]  0.0-60.0 sec  4.02 GBytes    575 Mbits/sec
[  8]  0.0-60.0 sec  3.96 GBytes    566 Mbits/sec
[  9]  0.0-60.0 sec  3.88 GBytes    556 Mbits/sec
[ 10]  0.0-60.0 sec  3.87 GBytes    553 Mbits/sec
[ 11]  0.0-60.0 sec  3.90 GBytes    558 Mbits/sec
[  4]  0.0-60.0 sec  4.01 GBytes    575 Mbits/sec
[ 12]  0.0-60.0 sec  3.88 GBytes    556 Mbits/sec
[SUM]  0.0-60.0 sec  39.4 GBytes  5.64 Gbits/sec

Iperf ExoGENI VM-2 to the VM-1 (UDP) - 1470 byte datagrams & UDP buffer size: 136 KByte

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec
[  3] Sent 512822 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec  0.130 ms    1/512821 (0.00019%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping ExoGENI VM-2 to the VM-1

60 packets transmitted, 60 received, 0% packet loss, time 59013ms
rtt min/avg/max/mdev = 0.803/0.949/1.370/0.115 ms

EG-CT-2 - Access to New Site bare metal and VM resources

Create a slice:

$ omni createslice EG-CT-2
11:40:28 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
11:40:28 INFO    : Loading config file /home/lnevers/.gcf/omni_config
11:40:28 INFO    : Using control framework portal
11:40:28 INFO    : Member Authority is https://ch.geni.net/MA (from config)
11:40:28 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
11:40:28 INFO    : Created slice with Name EG-CT-2, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-2, Expiration 2014-07-24 15:40:28+00:00
11:40:28 INFO    :  ------------------------------------------------------
11:40:28 INFO    :  Completed createslice:

  Options as run:
		framework: portal
		project: Luisa_Nevers-Test-Proj_01

  Args: createslice EG-CT-2

  Result Summary: Created slice with Name EG-CT-2, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-2, Expiration 2014-07-24 15:40:28+00:00
 
11:40:28 INFO    :  ======================================================

Create a sliver with one VM and one bare metal node using RSpec EG-CT-2-sl.rspec. Note: Bare metal only available via ExoSM.

$ omni createsliver EG-CT-2 -a eg-sm ./EG-CT-2-sl.rspec 
11:40:49 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
11:40:49 INFO    : Loading config file /home/lnevers/.gcf/omni_config
11:40:49 INFO    : Using control framework portal
11:40:49 INFO    : Member Authority is https://ch.geni.net/MA (from config)
11:40:49 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
11:40:49 INFO    : Substituting AM nickname eg-sm with URL https://geni.renci.org:11443/orca/xmlrpc, URN urn:publicid:IDN+exogeni.net+authority+am
11:40:50 INFO    : Slice urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-2 expires on 2014-07-24 15:40:28 UTC
11:40:50 INFO    : Creating sliver(s) from rspec file ./EG-CT-2-sl.rspec for slice urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-2
11:41:18 INFO    : Got return from CreateSliver for slice EG-CT-2 at eg-sm:
11:41:18 INFO    : <?xml version="1.0" ?>
11:41:18 INFO    :   <!-- Reserved resources for:
	Slice: EG-CT-2
	at AM:
	URN: urn:publicid:IDN+exogeni.net+authority+am
	URL: https://geni.renci.org:11443/orca/xmlrpc
 -->
11:41:18 INFO    :   
<rspec type="manifest" xmlns="http://www.geni.net/resources/rspec/3" xmlns:ns2="http://hpn.east.isi.edu/rspec/ext/stitch/0.1/" xmlns:ns3="http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1" xmlns:ns4="http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1" xmlns:ns5="http://www.geni.net/resources/rspec/ext/postBootScript/1" xmlns:ns6="http://www.geni.net/resources/rspec/ext/color/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3 http://www.geni.net/resources/rspec/3/manifest.xsd http://hpn.east.isi.edu/rspec/ext/stitch/0.1/ http://hpn.east.isi.edu/rspec/ext/stitch/0.1/stitch-schema.xsd http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1 http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1/slice_info.xsd?format=raw http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1 http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1/sliver_info.xsd?format=raw http://www.geni.net/resources/rspec/ext/postBootScript/1 http://www.geni.net/resources/rspec/ext/postBootScript/1/request.xsd http://www.geni.net/resources/rspec/ext/color/2 http://www.geni.net/resources/rspec/ext/color/2/color.xsd">  
      <node client_id="BM-1" component_id="urn:publicid:IDN+exogeni.net:slvmsite+node+orca-xcat-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:slvmsite+authority+am" component_name="orca-xcat-cloud" exclusive="true" sliver_id="urn:publicid:IDN+exogeni.net+sliver+eaa312cc-0a5b-4adb-8d04-795e78e50aa1:BM-1">    
            <location country="Unspecified" latitude="42.05286" longitude="-87.681564"/>    
            <sliver_type name="ExoGENI-M4">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="BM-1:if0" mac_address="fe:16:3e:00:61:62">      
                  <ip address="172.16.1.1" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-07-17T15:40:50.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-07-24T15:40:28.000Z" start_time="2014-07-17T15:40:50.000Z" state="configuring"/>    
      </node>  
      <node client_id="VM-1" component_id="urn:publicid:IDN+exogeni.net:slvmsite+node+orca-vm-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:slvmsite+authority+am" component_name="orca-vm-cloud" exclusive="false" sliver_id="urn:publicid:IDN+exogeni.net+sliver+eaa312cc-0a5b-4adb-8d04-795e78e50aa1:VM-1">    
            <location country="Unspecified" latitude="42.05286" longitude="-87.681564"/>    
            <sliver_type name="m1.large">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="VM-1:if0" mac_address="fe:16:3e:00:2a:1d">      
                  <ip address="172.16.1.2" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-07-17T15:40:50.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-07-24T15:40:28.000Z" start_time="2014-07-17T15:40:50.000Z" state="configuring"/>    
      </node>  
      <link client_id="lan0" sliver_id="urn:publicid:IDN+exogeni.net+sliver+eaa312cc-0a5b-4adb-8d04-795e78e50aa1:lan0" vlantag="2">    
            <interface_ref client_id="BM-1:if0"/>    
            <property capacity="0" dest_id="VM-1:if0" source_id="BM-1:if0"/>    
            <interface_ref client_id="VM-1:if0"/>    
            <property capacity="0" dest_id="BM-1:if0" source_id="VM-1:if0"/>    
            <ns4:geni_sliver_info creation_time="2014-07-17T15:40:50.000Z" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-07-24T15:40:28.000Z" resource_id="2" start_time="2014-07-17T15:40:50.000Z" state="ready"/>    
      </link>  
      <ns3:geni_slice_info state="configuring" urn="urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-2" uuid="8e15b4a3-0187-4f87-a7db-bab880325dcb"/>  
</rspec>
11:41:18 INFO    :  ------------------------------------------------------
11:41:18 INFO    :  Completed createsliver:

  Options as run:
		aggregate: ['eg-sm']
		framework: portal
		project: Luisa_Nevers-Test-Proj_01

  Args: createsliver EG-CT-2 ./EG-CT-2-sl.rspec

  Result Summary: Got Reserved resources RSpec from exogeni-net 
11:41:18 INFO    :  ======================================================

When sliver is ready, check for login information:

$ readyToLogin EG-CT-2 -a eg-sm 
<...> 
BM-1's geni_status is: ready 
User lnevers logs in to BM-1 using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.126

VM-1's geni_status is: ready 
User lnevers logs in to VM-1 using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.7

Measurements

Collected: 2014-07-17

Iperf ExoGENI BM-1 to VM-1 (TCP) - TCP window size: 16.0 KB

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  51.4 GBytes  7.36 Gbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  7]  0.0-60.0 sec  12.0 GBytes  1.72 Gbits/sec
[  5]  0.0-60.0 sec  12.4 GBytes  1.77 Gbits/sec
[  6]  0.0-60.0 sec  9.94 GBytes  1.42 Gbits/sec
[  3]  0.0-60.0 sec  12.2 GBytes  1.74 Gbits/sec
[  4]  0.0-60.0 sec  11.3 GBytes  1.62 Gbits/sec
[SUM]  0.0-60.0 sec  57.8 GBytes  8.27 Gbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  7]  0.0-60.0 sec  5.00 GBytes   715 Mbits/sec
[  5]  0.0-60.0 sec  5.12 GBytes   732 Mbits/sec
[  9]  0.0-60.0 sec  5.06 GBytes   725 Mbits/sec
[  3]  0.0-60.0 sec  5.17 GBytes   740 Mbits/sec
[  4]  0.0-60.0 sec  5.15 GBytes   738 Mbits/sec
[  6]  0.0-60.0 sec  5.16 GBytes   739 Mbits/sec
[ 10]  0.0-60.0 sec  5.11 GBytes   732 Mbits/sec
[ 11]  0.0-60.0 sec  5.15 GBytes   737 Mbits/sec
[ 12]  0.0-60.0 sec  5.07 GBytes   725 Mbits/sec
[  8]  0.0-60.0 sec  5.05 GBytes   723 Mbits/sec
[SUM]  0.0-60.0 sec  51.0 GBytes  7.31 Gbits/sec

Iperf ExoGENI BM-1 to the VM-1 (UDP) - 1470 byte datagrams & UDP buffer size: 136 KByte

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec   0.014 ms   37/512820 (0.0072%)
[  3]  0.0-60.0 sec  54 datagrams received out-of-order

Ping from ExoGENI BM-1 the VM-1

60 packets transmitted, 60 received, 0% packet loss, time 59001ms
rtt min/avg/max/mdev = 0.356/0.555/0.751/0.092 ms

Collected: 2014-07-17

Iperf ExoGENI VM-1 to BM-1 (TCP) - TCP window size: 16.0 KB

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  41.1 GBytes  5.89 Gbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  8.66 GBytes  1.24 Gbits/sec
[  6]  0.0-60.0 sec  8.60 GBytes  1.23 Gbits/sec
[  4]  0.0-60.0 sec  8.54 GBytes  1.22 Gbits/sec
[  5]  0.0-60.0 sec  8.41 GBytes  1.20 Gbits/sec
[  7]  0.0-60.0 sec  8.50 GBytes  1.22 Gbits/sec
[SUM]  0.0-60.0 sec  42.7 GBytes  6.11 Gbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[ 11]  0.0-60.0 sec  5.11 GBytes    732 Mbits/sec
[  7]  0.0-60.0 sec  4.51 GBytes    646 Mbits/sec
[  5]  0.0-60.0 sec  4.05 GBytes    579 Mbits/sec
[  4]  0.0-60.0 sec  4.20 GBytes    601 Mbits/sec
[  9]  0.0-60.0 sec  4.06 GBytes    581 Mbits/sec
[  3]  0.0-60.0 sec  4.13 GBytes    592 Mbits/sec
[  8]  0.0-60.0 sec  4.14 GBytes    592 Mbits/sec
[  6]  0.0-60.0 sec  4.27 GBytes    612 Mbits/sec
[ 10]  0.0-60.0 sec  4.21 GBytes    603 Mbits/sec
[ 12]  0.0-60.0 sec  4.10 GBytes    587 Mbits/sec
[SUM]  0.0-60.0 sec  42.8 GBytes  6.13 Gbits/sec

Iperf ExoGENI VM-1 to BM-1 (UDP) - 1470 byte datagrams & UDP buffer size: 136 KByte

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec  0.127 ms   44/512820 (0.0086%)
[  3]  0.0-60.0 sec  44 datagrams received out-of-order

Ping from ExoGENI VM-1 to BM-1

60 packets transmitted, 60 received, 0% packet loss, time 58998ms
rtt min/avg/max/mdev = 0.460/0.536/0.803/0.050 ms

EG-CT-3 - Multiple sites experiment

The GPO and SL racks are used in this experiment. First create a slice:

$ omni createslice EG-CT-3
14:07:47 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
14:07:47 INFO    : Loading config file /home/lnevers/.gcf/omni_config
14:07:47 INFO    : Using control framework portal
14:07:47 INFO    : Member Authority is https://ch.geni.net/MA (from config)
14:07:47 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
14:07:48 INFO    : Created slice with Name EG-CT-3, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-3, Expiration 2014-06-18 18:07:48+00:00
14:07:48 INFO    :  ------------------------------------------------------
14:07:48 INFO    :  Completed createslice:

  Options as run:
		framework: portal
		project: Luisa_Nevers-Test-Proj_01

  Args: createslice EG-CT-3

  Result Summary: Created slice with Name EG-CT-3, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-3, Expiration 2014-06-18 18:07:48+00:00
 
14:07:48 INFO    :  ======================================================

Then create a sliver via the ExoSM that includes both GPO and SL VMs using the RSpec the RSpec EG-CT-3-sl.rspec

$ omni createsliver -a eg-sm EG-CT-3 EG-CT-3-sl.rspec 
14:08:08 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
14:08:08 INFO    : Loading config file /home/lnevers/.gcf/omni_config
14:08:08 INFO    : Using control framework portal
14:08:08 INFO    : Member Authority is https://ch.geni.net/MA (from config)
14:08:08 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
14:08:08 INFO    : Substituting AM nickname eg-sm with URL https://geni.renci.org:11443/orca/xmlrpc, URN urn:publicid:IDN+exogeni.net+authority+am
14:08:09 INFO    : Slice urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-3 expires on 2014-06-18 18:07:48 UTC
14:08:09 INFO    : Creating sliver(s) from rspec file EG-CT-3-sl.rspec for slice urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-3
14:08:23 INFO    : Got return from CreateSliver for slice EG-CT-3 at eg-sm:
14:08:23 INFO    : <?xml version="1.0" ?>
14:08:23 INFO    :   <!-- Reserved resources for:
	Slice: EG-CT-3
	at AM:
	URN: urn:publicid:IDN+exogeni.net+authority+am
	URL: https://geni.renci.org:11443/orca/xmlrpc
 -->
14:08:23 INFO    :   
<rspec type="manifest" xmlns="http://www.geni.net/resources/rspec/3" xmlns:ns2="http://hpn.east.isi.edu/rspec/ext/stitch/0.1/" xmlns:ns3="http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1" xmlns:ns4="http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1" xmlns:ns5="http://www.geni.net/resources/rspec/ext/postBootScript/1" xmlns:ns6="http://www.geni.net/resources/rspec/ext/color/2" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.geni.net/resources/rspec/3 http://www.geni.net/resources/rspec/3/manifest.xsd http://hpn.east.isi.edu/rspec/ext/stitch/0.1/ http://hpn.east.isi.edu/rspec/ext/stitch/0.1/stitch-schema.xsd http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1 http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/slice-info/1/slice_info.xsd?format=raw http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1 http://groups.geni.net/exogeni/attachment/wiki/RspecExtensions/sliver-info/1/sliver_info.xsd?format=raw http://www.geni.net/resources/rspec/ext/postBootScript/1 http://www.geni.net/resources/rspec/ext/postBootScript/1/request.xsd http://www.geni.net/resources/rspec/ext/color/2 http://www.geni.net/resources/rspec/ext/color/2/color.xsd">  
      <node client_id="gpo" component_id="urn:publicid:IDN+exogeni.net:bbnvmsite+node+orca-vm-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:bbnvmsite+authority+am" component_name="orca-vm-cloud" exclusive="false" sliver_id="urn:publicid:IDN+exogeni.net+sliver+cf6ca1ca-9edb-4d1f-9b0e-f59432ffdbd2:gpo">    
            <location country="Unspecified" latitude="42.38974" longitude="-71.14751"/>    
            <sliver_type name="m1.large">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="gpo:0" mac_address="fe:16:3e:00:5e:7d">      
                  <ip address="192.168.1.1" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-06-11T14:08:09.000-04:00" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-06-18T14:07:48.000-04:00" start_time="2014-06-11T14:08:09.000-04:00" state="configuring"/>    
      </node>  
      <node client_id="sl" component_id="urn:publicid:IDN+exogeni.net:slvmsite+node+orca-vm-cloud" component_manager_id="urn:publicid:IDN+exogeni.net:slvmsite+authority+am" component_name="orca-vm-cloud" exclusive="false" sliver_id="urn:publicid:IDN+exogeni.net+sliver+cf6ca1ca-9edb-4d1f-9b0e-f59432ffdbd2:sl">    
            <location country="Unspecified" latitude="42.05286" longitude="-87.681564"/>    
            <sliver_type name="m1.large">      
                  <disk_image name="http://geni-images.renci.org/images/standard/debian/deb6.v1.0.10.xml" version="c120b9d79d3f3882114c0e59cce14f671ef9b0db"/>      
            </sliver_type>    
            <services/>    
            <interface client_id="sl:0" mac_address="fe:16:3e:00:27:ce">      
                  <ip address="192.168.1.2" netmask="255.255.255.0" type="ipv4"/>      
            </interface>    
            <ns4:geni_sliver_info creation_time="2014-06-11T14:08:09.000-04:00" creator_urn="lnevers@bbn.com, urn:publicid:IDN+ch.geni.net+user+lnevers" expiration_time="2014-06-18T14:07:48.000-04:00" start_time="2014-06-11T14:08:09.000-04:00" state="configuring"/>    
      </node>  
      <link client_id="link" sliver_id="urn:publicid:IDN+exogeni.net+sliver+cf6ca1ca-9edb-4d1f-9b0e-f59432ffdbd2:link" vlantag="unknown">    
            <interface_ref client_id="gpo:0"/>    
            <property capacity="0" dest_id="sl:0" source_id="gpo:0"/>    
            <interface_ref client_id="sl:0"/>    
            <property capacity="0" dest_id="gpo:0" source_id="sl:0"/>    
      </link>  
      <ns2:stitching lastUpdateTime="Wed Jun 11 14:08:23 EDT 2014">    
            <ns2:path id="link">      
                  <ns2:hop id="hop1">        
                        <ns2:link id="urn:publicid:IDN+exogeni.net:bbnNet+interface+bbnNet:Domain:vlan:5344e2b1-5a3c-4e7b-b11e-5198e284a875:vlan">          
                              <ns2:trafficEngineeringMetric>            10          </ns2:trafficEngineeringMetric>          
                              <ns2:capacity>            10000000000          </ns2:capacity>          
                              <ns2:switchingCapabilityDescriptor>            
                                    <ns2:switchingcapType>              l2sc            </ns2:switchingcapType>            
                                    <ns2:encodingType>              ethernet            </ns2:encodingType>            
                                    <ns2:switchingCapabilitySpecificInfo>              
                                          <ns2:switchingCapabilitySpecificInfo_L2sc>                
                                                <ns2:vlanRangeAvailability>                  1-4096                </ns2:vlanRangeAvailability>                
                                                <ns2:suggestedVLANRange>                  1-4096                </ns2:suggestedVLANRange>                
                                                <ns2:vlanTranslation>                  false                </ns2:vlanTranslation>                
                                          </ns2:switchingCapabilitySpecificInfo_L2sc>              
                                    </ns2:switchingCapabilitySpecificInfo>            
                              </ns2:switchingCapabilityDescriptor>          
                        </ns2:link>        
                        <ns2:nextHop>          hop2        </ns2:nextHop>        
                  </ns2:hop>      
                  <ns2:hop id="hop2">        
                        <ns2:link id="urn:publicid:IDN+exogeni.net:ion+interface+ion:Domain:vlan:d508ddab-acd5-40d3-8805-0c1eb1334cfa:vlan">          
                              <ns2:trafficEngineeringMetric>            10          </ns2:trafficEngineeringMetric>          
                              <ns2:capacity>            10000000000          </ns2:capacity>          
                              <ns2:switchingCapabilityDescriptor>            
                                    <ns2:switchingcapType>              l2sc            </ns2:switchingcapType>            
                                    <ns2:encodingType>              ethernet            </ns2:encodingType>            
                                    <ns2:switchingCapabilitySpecificInfo>              
                                          <ns2:switchingCapabilitySpecificInfo_L2sc>                
                                                <ns2:vlanRangeAvailability>                  1-4096                </ns2:vlanRangeAvailability>                
                                                <ns2:suggestedVLANRange>                  1-4096                </ns2:suggestedVLANRange>                
                                                <ns2:vlanTranslation>                  false                </ns2:vlanTranslation>                
                                          </ns2:switchingCapabilitySpecificInfo_L2sc>              
                                    </ns2:switchingCapabilitySpecificInfo>            
                              </ns2:switchingCapabilityDescriptor>          
                        </ns2:link>        
                        <ns2:nextHop>          hop3        </ns2:nextHop>        
                  </ns2:hop>      
                  <ns2:hop id="hop3">        
                        <ns2:link id="urn:publicid:IDN+exogeni.net:slNet+interface+slNet:Domain:vlan:b973a36e-223d-4b70-b0cb-816a3d25ab9b:vlan">          
                              <ns2:trafficEngineeringMetric>            10          </ns2:trafficEngineeringMetric>          
                              <ns2:capacity>            10000000000          </ns2:capacity>          
                              <ns2:switchingCapabilityDescriptor>            
                                    <ns2:switchingcapType>              l2sc            </ns2:switchingcapType>            
                                    <ns2:encodingType>              ethernet            </ns2:encodingType>            
                                    <ns2:switchingCapabilitySpecificInfo>              
                                          <ns2:switchingCapabilitySpecificInfo_L2sc>                
                                                <ns2:vlanRangeAvailability>                  1-4096                </ns2:vlanRangeAvailability>                
                                                <ns2:suggestedVLANRange>                  1-4096                </ns2:suggestedVLANRange>                
                                                <ns2:vlanTranslation>                  false                </ns2:vlanTranslation>                
                                          </ns2:switchingCapabilitySpecificInfo_L2sc>              
                                    </ns2:switchingCapabilitySpecificInfo>            
                              </ns2:switchingCapabilityDescriptor>          
                        </ns2:link>        
                        <ns2:nextHop>          null        </ns2:nextHop>        
                  </ns2:hop>      
            </ns2:path>    
      </ns2:stitching>  
      <ns3:geni_slice_info state="configuring" urn="urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-3" uuid="5fc11a79-cf70-484c-823e-d1a25c533ae8"/>  
</rspec>
14:08:23 INFO    :  ------------------------------------------------------
14:08:23 INFO    :  Completed createsliver:

  Options as run:
		aggregate: ['eg-sm']
		framework: portal
		project: Luisa_Nevers-Test-Proj_01

  Args: createsliver EG-CT-3 EG-CT-3-sl.rspec

  Result Summary: Got Reserved resources RSpec from exogeni-net 
14:08:23 INFO    :  ======================================================

Determine login information for allocated nodes:

$ readyToLogin -a eg-sm EG-CT-3      
 <...>
================================================================================
LOGIN INFO for AM: https://geni.renci.org:11443/orca/xmlrpc
================================================================================

For more login info, see the section entitled:
	 'Providing a private key to ssh' in 'readyToLogin.py -h'

gpo's geni_status is: ready (am_status:ready) 
User lnevers logs in to gpo using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@192.1.242.8

sl's geni_status is: ready (am_status:ready) 
User lnevers logs in to sl using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.7

Measurements

Collected: 2014-06-11

Iperf ExoGENI GPO VM to SL VM (TCP) - TCP window size: 16.0 KB

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  2.38 GBytes    341 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec    917 MBytes    128 Mbits/sec
[  5]  0.0-60.0 sec    922 MBytes    129 Mbits/sec
[  6]  0.0-60.0 sec  1016 MBytes    142 Mbits/sec
[  7]  0.0-60.0 sec  1.21 GBytes    173 Mbits/sec
[  4]  0.0-60.0 sec  1.01 GBytes    144 Mbits/sec
[SUM]  0.0-60.0 sec  5.00 GBytes    716 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  6]  0.0-60.0 sec    503 MBytes  70.3 Mbits/sec
[  9]  0.0-60.0 sec    442 MBytes  61.8 Mbits/sec
[ 12]  0.0-60.0 sec    732 MBytes    102 Mbits/sec
[ 11]  0.0-60.0 sec    677 MBytes  94.5 Mbits/sec
[  3]  0.0-60.0 sec    571 MBytes  79.7 Mbits/sec
[ 10]  0.0-60.0 sec    688 MBytes  96.2 Mbits/sec
[  7]  0.0-60.0 sec    601 MBytes  84.0 Mbits/sec
[  4]  0.0-60.0 sec    458 MBytes  64.0 Mbits/sec
[  8]  0.0-60.1 sec    480 MBytes  67.1 Mbits/sec
[  5]  0.0-60.1 sec    695 MBytes  97.1 Mbits/sec
[SUM]  0.0-60.1 sec  5.71 GBytes    816 Mbits/sec

Iperf ExoGENI GPO VM to SL VM (UDP) - 1470 byte datagrams & UDP buffer size: 136 KByte

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec
[  3] Sent 512822 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec  0.130 ms    6/512821 (0.0012%)
[  3]  0.0-60.0 sec  1 datagrams received out-of-order

Ping from GPO VM to SL VM

60 packets transmitted, 60 received, 0% packet loss, time 59100ms
rtt min/avg/max/mdev = 32.614/32.895/33.425/0.295 ms

Collected: 2014-06-11

Iperf ExoGENI SL VM to GPO VM (TCP) - TCP window size: 16.0 KB

Iperf (TCP) - TCP window size: 16.0 KB

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.1 sec    654 MBytes  91.4 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-60.0 sec    155 MBytes  21.7 Mbits/sec
[  4]  0.0-60.0 sec    635 MBytes  88.8 Mbits/sec
[  3]  0.0-60.1 sec    205 MBytes  28.6 Mbits/sec
[  6]  0.0-60.1 sec    240 MBytes  33.5 Mbits/sec
[  7]  0.0-60.1 sec    107 MBytes  14.9 Mbits/sec
[SUM]  0.0-60.1 sec  1.31 GBytes    187 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  6]  0.0-60.0 sec  63.6 MBytes  8.89 Mbits/sec
[ 10]  0.0-60.0 sec  66.5 MBytes  9.29 Mbits/sec
[  9]  0.0-60.1 sec    228 MBytes  31.8 Mbits/sec
[  8]  0.0-60.1 sec    153 MBytes  21.4 Mbits/sec
[  7]  0.0-60.1 sec    127 MBytes  17.7 Mbits/sec
[ 11]  0.0-60.1 sec    153 MBytes  21.3 Mbits/sec
[  5]  0.0-60.1 sec    262 MBytes  36.6 Mbits/sec
[ 12]  0.0-60.1 sec    190 MBytes  26.5 Mbits/sec
[  4]  0.0-60.1 sec  70.9 MBytes  9.89 Mbits/sec
[  3]  0.0-60.2 sec  92.0 MBytes  12.8 Mbits/sec
[SUM]  0.0-60.2 sec  1.37 GBytes    196 Mbits/sec

Iperf ExoGENI SL VM to GPO VM (UDP) - 1470 byte datagrams & UDP buffer size: 136 KByte

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec    719 MBytes    101 Mbits/sec  0.131 ms   28/512820 (0.0055%)
[  3]  0.0-60.0 sec  38 datagrams received out-of-order

Ping from GPO VM to SL VM

60 packets transmitted, 60 received, 0% packet loss, time 59089ms
rtt min/avg/max/mdev = 32.626/32.935/33.639/0.257 ms

EG-CT-4 - Multiple sites OpenFlow experiment and interoperability

First create a slice:

$ omni createslice EG-CT-4
14:57:13 INFO    : Loading agg_nick_cache file '/home/lnevers/.gcf/agg_nick_cache'
14:57:13 INFO    : Loading config file /home/lnevers/.gcf/omni_config
14:57:13 INFO    : Using control framework portal
14:57:13 INFO    : Member Authority is https://ch.geni.net/MA (from config)
14:57:13 INFO    : Slice Authority is https://ch.geni.net/SA (from config)
14:57:14 INFO    : Created slice with Name EG-CT-4, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-4, Expiration 2014-07-24 18:57:14+00:00
14:57:14 INFO    :  ------------------------------------------------------
14:57:14 INFO    :  Completed createslice:

  Options as run:
		framework: portal
		project: Luisa_Nevers-Test-Proj_01

  Args: createslice EG-CT-4

  Result Summary: Created slice with Name EG-CT-4, URN urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-4, Expiration 2014-07-24 18:57:14+00:00
 
14:57:14 INFO    :  ======================================================

Then create slivers at all OpenFlow aggregates. This confirmation test creates a sliver at each of the following aggregates using the RSpec specified. RSpecs can be found here

$ omni createsliver -a of-i2 EG-CT-4 EG-CT-4-openflow-internet2.rspec 
$ omni createsliver -a gpo-of EG-CT-4 EG-CT-4-openflow-gpo.rspec 
$ omni createsliver -a gpo-eg-of EG-CT-4 EG-CT-4-openflow-eg-gpo.rspec 
$ omni createsliver -a uen-of EG-CT-4 EG-CT-4-openflow-uen.rspec
$ omni createsliver -a sl-eg-of EG-CT-4 EG-CT-4-openflow-eg-sl.rspec 
$ omni createsliver -a sl-of EG-CT-4 EG-CT-4-openflow-sl.rspec 
$ omni createsliver -a gpo-ig-of EG-CT-4 EG-CT-4-openflow-ig-gpo.rspec 

Then create a sliver at each of the compute resource aggregates, RSpecs used can be found here

$ omni createsliver -a pg-utah EG-CT-4 EG-CT-4-pg-utah.rspec
$ omni createsliver -a gpo-ig EG-CT-4 EG-CT-4-ig-gpo.rspec
$ omni createsliver -a eg-sm EG-CT-4 EG-CT-4-eg-gpo.rspec
$ omni.py createslice EG-CT-4a; omni createsliver -a eg-sm EG-CT-4 EG-CT-4-eg-sl.rspec

Once the slivers were ready, determined login for PG and Indiana hosts on shared VLAN 1750:

$ readyToLogin -a pg-utah EG-CT-4
<...>
utah-pg's geni_status is: ready 
User lnevers logs in to utah-pg using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc477.emulab.net

Determined login for GPO InstaGENI:

$ readyToLogin -a gpo-ig EG-CT-4
<...>
gpo-ig's geni_status is: ready 
User lnevers logs in to gpo-ig using:
	ssh -p 33594  -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc5.instageni.gpolab.bbn.com

Determined login for GPO ExoGENI via ExoSM:

$ readyToLogin -a eg-sm EG-CT-4
<...>
eg-gpo's geni_status is: ready 
User lnevers logs in to eg-gpo using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@pc2.instageni.gpolab.bbn.com

Determined login for SL ExoGENI:

$ readyToLogin -a eg-sm EG-CT-4a
<...>
sl-bm1's geni_status is: ready 
User lnevers logs in to sl-bm1 using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.125

sl-bm's geni_status is: ready 
User lnevers logs in to sl-bm using:
	ssh -i /home/lnevers/.ssh/geni_cert_portal_key lnevers@165.124.159.126

Measurements

This section captures measurements collected between the following endpoints:

  1. SL ExoGENI Bare Metal and SL ExoGENI Bare Metal
  2. SL ExoGENI Bare Metal and GPO ExoGENI Bare Metal
  3. SL ExoGENI Bare Metal and GPO InstaGENI Raw-PC
  4. SL ExoGENI Bare Metal and Utah PG Raw-PC
  1. The measurements collected for SL ExoGENI Bare Metal and SL ExoGENI Bare Metal

Iperf SL ExoGENI Bare Metal to SL ExoGENI Bare Metal - TCP window size: 23.2 KByte (default)

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  50.0 GBytes  7.16 Gbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec  13.9 GBytes  1.99 Gbits/sec
[  4]  0.0-60.0 sec  17.1 GBytes  2.45 Gbits/sec
[  6]  0.0-60.0 sec  9.41 GBytes  1.35 Gbits/sec
[  7]  0.0-60.0 sec  14.1 GBytes  2.01 Gbits/sec
[  5]  0.0-60.0 sec  10.4 GBytes  1.50 Gbits/sec
[SUM]  0.0-60.0 sec  65.0 GBytes  9.30 Gbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  7]  0.0-60.0 sec  6.27 GBytes   898 Mbits/sec
[  4]  0.0-60.0 sec  6.48 GBytes   928 Mbits/sec
[  3]  0.0-60.0 sec  6.60 GBytes   945 Mbits/sec
[  5]  0.0-60.0 sec  6.45 GBytes   923 Mbits/sec
[  6]  0.0-60.0 sec  6.58 GBytes   942 Mbits/sec
[ 12]  0.0-60.0 sec  6.29 GBytes   900 Mbits/sec
[  8]  0.0-60.0 sec  6.66 GBytes   953 Mbits/sec
[ 10]  0.0-60.0 sec  6.66 GBytes   953 Mbits/sec
[  9]  0.0-60.0 sec  6.57 GBytes   941 Mbits/sec
[ 11]  0.0-60.0 sec  6.49 GBytes   929 Mbits/sec
[SUM]  0.0-60.0 sec  65.0 GBytes  9.31 Gbits/sec

Iperf SL ExoGENI Bare Metal to SL ExoGENI Bare Metal (UDP) - UDP buffer size: 224 KByte (default)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec   0.001 ms  317/512820 (0.062%)
[  3]  0.0-60.0 sec  317 datagrams received out-of-order

Ping from SL ExoGENI Bare Metal to SL ExoGENI Bare Metal

60 packets transmitted, 60 received, 0% packet loss, time 59003ms
rtt min/avg/max/mdev = 0.118/1.093/54.334/6.931 ms
  1. The measurements collected for SL ExoGENI Bare Metal and GPO ExoGENI Bare Metal:

Iperf SL ExoGENI Bare Metal to GPO ExoGENI Bare Metal (TCP)

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.1 sec  1006 MBytes   141 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-59.4 sec   300 MBytes  42.3 Mbits/sec
[  4]  0.0-59.6 sec   613 MBytes  86.2 Mbits/sec
[  5]  0.0-59.8 sec   283 MBytes  39.7 Mbits/sec
[  6]  0.0-60.0 sec   208 MBytes  29.0 Mbits/sec
[  7]  0.0-60.1 sec   205 MBytes  28.7 Mbits/sec
[SUM]  0.0-60.1 sec  1.57 GBytes   225 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-58.2 sec   207 MBytes  29.8 Mbits/sec
[  5]  0.0-58.4 sec   227 MBytes  32.6 Mbits/sec
[  3]  0.0-58.7 sec   203 MBytes  29.0 Mbits/sec
[  6]  0.0-58.8 sec   277 MBytes  39.5 Mbits/sec
[  7]  0.0-59.0 sec   162 MBytes  23.1 Mbits/sec
[  9]  0.0-59.6 sec   177 MBytes  24.9 Mbits/sec
[  8]  0.0-59.7 sec   148 MBytes  20.8 Mbits/sec
[ 10]  0.0-59.8 sec   467 MBytes  65.5 Mbits/sec
[ 11]  0.0-59.9 sec   157 MBytes  22.0 Mbits/sec
[ 12]  0.0-60.1 sec   181 MBytes  25.2 Mbits/sec
[SUM]  0.0-60.1 sec  2.15 GBytes   308 Mbits/sec

Iperf SL ExoGENI Bare Metal to GPO ExoGENI Bare Metal (UDP)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-58.6 sec   703 MBytes   101 Mbits/sec   0.048 ms 11163/512820 (2.2%)
[  3]  0.0-58.6 sec  799 datagrams received out-of-order

Ping from SL ExoGENI Bare Metal to GPO ExoGENI Bare Metal

60 packets transmitted, 60 received, 0% packet loss, time 59116ms
rtt min/avg/max/mdev = 41.829/58.514/1031.943/126.729 ms, pipe 2
  1. The measurements collected for SL ExoGENI VM and GPO InstaGENI VM:

Iperf SL ExoGENI Bare Metal to GPO InstaGENI Raw-PC (TCP) - TCP window size: 23.2 KByte

One Client_

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   773 MBytes   108 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-59.4 sec   283 MBytes  40.0 Mbits/sec
[  7]  0.0-59.9 sec   431 MBytes  60.4 Mbits/sec
[  4]  0.0-59.9 sec   216 MBytes  30.3 Mbits/sec
[  6]  0.0-60.1 sec   276 MBytes  38.5 Mbits/sec
[  5]  0.0-60.3 sec   218 MBytes  30.3 Mbits/sec
[SUM]  0.0-60.3 sec  1.39 GBytes   198 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-57.7 sec   220 MBytes  32.0 Mbits/sec
[  3]  0.0-58.5 sec   174 MBytes  25.0 Mbits/sec
[  5]  0.0-58.7 sec   204 MBytes  29.1 Mbits/sec
[  6]  0.0-58.9 sec   128 MBytes  18.3 Mbits/sec
[  7]  0.0-59.1 sec   174 MBytes  24.7 Mbits/sec
[  8]  0.0-59.3 sec   161 MBytes  22.7 Mbits/sec
[  9]  0.0-59.7 sec   271 MBytes  38.1 Mbits/sec
[ 10]  0.0-59.9 sec   209 MBytes  29.2 Mbits/sec
[ 11]  0.0-59.9 sec   213 MBytes  29.8 Mbits/sec
[ 12]  0.0-60.1 sec   250 MBytes  34.9 Mbits/sec
[SUM]  0.0-60.1 sec  1.96 GBytes   280 Mbits/sec

Iperf SL ExoGENI Bare Metal to GPO InstaGENI Raw-PC (UDP) - UDP buffer size: 224 KByte

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-58.8 sec   705 MBytes   101 Mbits/sec   0.043 ms 9614/512820 (1.9%)
[  3]  0.0-58.8 sec  544 datagrams received out-of-order

Ping from SL ExoGENI Bare Metal to GPO InstaGENI Raw-PC

60 packets transmitted, 60 received, 0% packet loss, time 59128ms
rtt min/avg/max/mdev = 41.852/57.165/954.198/116.783 ms
  1. The measurements collected for SL ExoGENI Bare Metal and Utah PG Raw-PC:

Iperf SL ExoGENI VM to Utah PG VM (TCP) - TCP window size: 16.0 KByte (default)

One Client

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   342 MBytes  47.8 Mbits/sec

Five Clients

[ ID] Interval       Transfer     Bandwidth
[  6]  0.0-59.6 sec   160 MBytes  22.5 Mbits/sec
[  3]  0.0-59.9 sec   183 MBytes  25.7 Mbits/sec
[  4]  0.0-60.0 sec   114 MBytes  15.9 Mbits/sec
[  7]  0.0-60.1 sec   191 MBytes  26.6 Mbits/sec
[  5]  0.0-60.2 sec   110 MBytes  15.4 Mbits/sec
[SUM]  0.0-60.2 sec   758 MBytes   106 Mbits/sec

Ten Clients

[ ID] Interval       Transfer     Bandwidth
[  5]  0.0-58.9 sec   100 MBytes  14.3 Mbits/sec
[  3]  0.0-58.9 sec  93.2 MBytes  13.3 Mbits/sec
[  4]  0.0-59.1 sec   151 MBytes  21.4 Mbits/sec
[  7]  0.0-59.3 sec   106 MBytes  15.0 Mbits/sec
[  8]  0.0-59.5 sec   154 MBytes  21.8 Mbits/sec
[  6]  0.0-59.6 sec   141 MBytes  19.9 Mbits/sec
[  9]  0.0-59.8 sec   121 MBytes  17.0 Mbits/sec
[ 10]  0.0-59.9 sec  87.5 MBytes  12.3 Mbits/sec
[ 11]  0.0-60.2 sec   146 MBytes  20.3 Mbits/sec
[ 12]  0.0-60.3 sec   212 MBytes  29.5 Mbits/sec
[SUM]  0.0-60.3 sec  1.28 GBytes   183 Mbits/sec

Iperf SL ExoGENI Bare Metal to Utah PG Raw-PC (UDP) - UDP buffer size: 122 KByte (default)

[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-60.0 sec   719 MBytes   101 Mbits/sec
[  3] Sent 512821 datagrams
[  3] Server Report:
[  3]  0.0-58.7 sec   704 MBytes   101 Mbits/sec   0.089 ms 10411/512820 (2%)
[  3]  0.0-58.7 sec  475 datagrams received out-of-order

Ping from SL ExoGENI Bare Metal to Utah PG Raw-PC

60 packets transmitted, 60 received, 0% packet loss, time 59161ms
rtt min/avg/max/mdev = 124.256/148.471/1330.721/156.806 ms, pipe 2

EG-CT-5 - Experiment Monitoring

GMOC Monitoring

No GMOC Monitoring for this site's FOAM and Compute aggregates.

GENI Monitoring

Checked for site's compute and foam aggregates:

ONLY FOAM

EG-CT-6 - Administrative Tests

Administrator accounts on an ExoGENI rack are documented at https://wiki.exogeni.net/doku.php?id=public:operators:start, with https://wiki.exogeni.net/doku.php?id=public:operators:start#authentication_authorization proving insight into accounts creation and usage.

With requested account accessed rack head node and verified root access and group membership:

LNM:~$ ssh sl-hn.exogeni.net
The authenticity of host 'sl-hn.exogeni.net (165.124.159.5)' can't be established.
RSA key fingerprint is 17:f6:3c:75:16:ed:d1:99:b7:c9:d2:2d:b3:b3:1b:2e.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'sl-hn.exogeni.net,165.124.159.5' (RSA) to the list of known hosts.
lnevers@sl-hn.exogeni.net's password: 
Creating home directory for lnevers.
|-----------------------------------------------------------------|
|		 ____ ____ ____ ____ ____ ____ ____ 		  |
|		||E |||x |||o |||G |||E |||N |||I ||		  |
|		||__|||__|||__|||__|||__|||__|||__||		  |
|		|/__\|/__\|/__\|/__\|/__\|/__\|/__\|		  |
|                                                                 |
|-----------------------------------------------------------------|
[lnevers@sl-hn ~]$ sudo whoami

We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:

    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.

[sudo] password for lnevers: 
root
[lnevers@sl-hn ~]$ id
uid=2107(lnevers) gid=2000(nonrenci) groups=2000(nonrenci),2508(osfadmins),2509(ucdadmins),2510(sladmins),2513(tamuadmins),9510(bbnadmins)
[lnevers@sl-hn ~]$ 

From head node verified login and administrative access to each of the worker nodes:

[lnevers@sl-hn ~]$ for i in 1 2 3 4 5 6 7 8 9 10; do sudo ssh root@sl-w$i "echo -n 'Executing on: ' ; hostname;whoami;uname -a"; done
Executing on: sl-w1
root
Linux sl-w1 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-w2
root
Linux sl-w2 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-w3
root
Linux sl-w3 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-w4
root
Linux sl-w4 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-w5
root
Linux sl-w5 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-w6
root
Linux sl-w6 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-w7
root
Linux sl-w7 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-w8
root
Linux sl-w8 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-bm1
root
Linux sl-bm1 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Executing on: sl-bm
root
Linux sl-bm 2.6.32-358.el6.x86_64 #1 SMP Fri Feb 22 00:31:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
[lnevers@sl-hn ~]$ 

Connect to the management switch:

[lnevers@sl-hn ~]$  ssh sl-8052.sl.xo
The authenticity of host 'sl-8052.sl.xo (192.168.112.2)' can't be established.
DSA key fingerprint is f4:c8:0d:47:bd:a6:8a:d9:e3:9b:1d:46:fd:2a:68:e6.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'sl-8052.sl.xo,192.168.112.2' (DSA) to the list of known hosts.
Enter radius password: 

IBM Networking Operating System RackSwitch G8052.


sl-8052.sl.xo>ena

Enable privilege granted.
sl-8052.sl.xo#show version
System Information at  1:07:11 Tue Feb 12, 2001
Time zone: America/US/Eastern
Daylight Savings Time Status: Enabled

IBM Networking Operating System RackSwitch G8052

Switch has been up for 292 days, 20 hours, 28 minutes and 51 seconds.
Last boot:  3:48:15 Sat Apr 28, 2000 (power cycle)

MAC address: 74:99:75:fa:71:00    IP (If 1) address: 192.168.49.50
Hardware Revision: 0
Board Revision: 2
Switch Serial No: Y010CM365080
Hardware Part No: BAC-00069-00        Spare Part No: BAC-00069-00
Manufacturing date: 13/22

MTM: 7309HC1
ESN: MM08892
Software Version 7.2.2.0 (FLASH image1), active configuration.


Temperature    Top: 34 C
Temperature Bottom: 40 C
Temperature Fan Ctrl 88: 36 C
Temperature Fan Ctrl 8a: 63 C
Temperature Fan Ctrl 8c: 72 C
Temperature Phy 0x01: 73 C
Temperature Phy 0x09: 64 C
Temperature Phy 0x11: 75 C
Temperature Phy 0x21: 75 C
Temperature Phy 0x29: 75 C
Temperature Phy 0x31: 71 C

Warning at 55 C and Recover at 80 C

Fan 1 in Module 1: Not Installed
Fan 2 in Module 1: Not Installed
Fan 3 in Module 2: RPM= 9262 PWM= 25 ( 9%) Back-To-Front [J]
Fan 4 in Module 2: RPM= 3413 PWM= 25 ( 9%) Back-To-Front [J]
Fan 5 in Module 3: RPM= 9625 PWM= 25 ( 9%) Back-To-Front [J]
Fan 6 in Module 3: RPM= 3368 PWM= 25 ( 9%) Back-To-Front [J]
Fan 7 in Module 4: RPM= 7479 PWM= 25 ( 9%) Back-To-Front [J]
Fan 8 in Module 4: RPM= 4891 PWM= 25 ( 9%) Back-To-Front [J]

System Fan Airflow: Back-To-Front

Power Supply 1: OK
Power Supply 2: OK

  Power Faults: ()
    Fan Faults: ()
Service Faults: ()

sl-8052.sl.xo#show interface status
------------------------------------------------------------------
Alias   Port   Speed    Duplex     Flow Ctrl      Link       Name
------- ----   -----   --------  --TX-----RX--   ------     ------
1        1        100     full      no     no       up       1       
2        2       1000     full      no     no       up       2       
3        3       1000     full      no     no       up       3       
4        4       1000     full      no     no       up       4       
5        5       1000     full      no     no       up       5       
6        6       1000     full      no     no       up       6       
7        7       1000     full      no     no       up       7       
8        8       1000     full      no     no       up       8       
9        9       1000     full      no     no       up       9       
10       10      1000     full      no     no       up       10      
11       11      1000     full      no     no       up       11      
12       12       100     half      no     no       up       12      
13       13      1000     full      no     no       up       13      
14       14      1000     full      no     no       up       14      
15       15       100     half      no     no       up       15      
16       16       100     half      no     no       up       16      
17       17      1000     full      no     no       up       Headnode eth4
18       18      1000     full      no     no       up       Headnode eth5
19       19      1000     full      no     no       up       Headnode eth1
20       20      1000     full      no     no       up       Headnode eth0
21       21      1000     full      no     no       up       21      
22       22      1000     full      no     no       up       22      
23       23      1000     full      no     no       up       23      
24       24      1000     full      no     no       up       24      
25       25      1000     full      no     no       up       25      
26       26      1000     full      no     no       up       26      
27       27      1000     full      no     no       up       27      
28       28      1000     full      no     no       up       28      
29       29      1000     full      no     no       up       29      
30       30      1000     full      no     no       up       30      
31       31      1000     full      no     no       up       31      
32       32      1000     full      no     no       up       32      
33       33      1000     full      no     no       up       33      
34       34      1000     full      no     no       up       Campus 1Gb Uplink to G8052
35       35      1000     full      no     no       up       35      
36       36       any      any      no     no      down      36      
37       37      1000     full      no     no       up       37      
38       38      1000     full      no     no       up       38      
39       39      1000     full      no     no       up       39      
40       40      1000     full      no     no       up       40      
41       41      1000     full      no     no       up       41      
42       42      1000     full      no     no       up       42      
43       43      1000     full      no     no       up       43      
44       44      1000     full      no     no       up       44      
45       45      1000     full      no     no       up       45      
46       46      1000     full      no     no       up       46      
47       47      1000     full      no     no       up       Public from G8052 to Headnode
48       48       any      any      no     no      down      48      
XGE1     49     1G/10G    full      no     no      down      XGE1    
XGE2     50     10000     full      no     no      down      XGE2    
XGE3     51     10000     full      no     no      down      XGE3    
XGE4     52     10000     full      no     no       up       XGE4    
sl-8052.sl.xo# show run
sl-8052.sl.xo# show running-config 
Current configuration:
!
version "7.2.2"
switch-type "IBM Networking Operating System RackSwitch G8052"
!
system timezone 145
! America/US/Eastern
system daylight
!
ssh enable
!
access https enable

!
errdisable recovery
no system dhcp
hostname "sl-8052.sl.xo"
!
!
no access http enable
no access telnet enable
access user administrator-password "xxx"
!
!
interface port 1
	pvid 1006
	spanning-tree edge
	exit
!
interface port 2
	pvid 1006
	spanning-tree edge
	exit
!
interface port 3
	pvid 1006
	spanning-tree edge
	exit
!
interface port 4
	pvid 1006
	spanning-tree edge
	exit
!
interface port 5
	pvid 1006
!
...many lines not shown...

Connect to the OpenFlow switch:

LNM:~$ ssh sl-hn.exogeni.net
lnevers@sl-hn.exogeni.net's password: 
Last login: Mon Jul 21 12:20:37 2014 from 128.89.73.116
|-----------------------------------------------------------------|
|		 ____ ____ ____ ____ ____ ____ ____ 		  |
|		||E |||x |||o |||G |||E |||N |||I ||		  |
|		||__|||__|||__|||__|||__|||__|||__||		  |
|		|/__\|/__\|/__\|/__\|/__\|/__\|/__\|		  |
|                                                                 |
|-----------------------------------------------------------------|
[lnevers@sl-hn ~]$  ssh lnevers@sl-8264.sl.xo
Enter radius password: 

IBM Networking Operating System RackSwitch G8264.


sl-8264.sl.xo>ena

Enable privilege granted.
sl-8264.sl.xo#show version
System Information at  8:30:03 Mon Jul 21, 2014
Time zone: America/US/Eastern
Daylight Savings Time Status: Enabled

IBM Networking Operating System RackSwitch G8264

Switch has been up for 45 days, 19 hours, 38 minutes and 10 seconds.
Last boot: 12:52:28 Thu Jun  5, 2014 (reset from Telnet/SSH)

MAC address: 74:99:75:e3:c0:00    IP (If 1) address: 192.168.49.50
Management Port MAC Address: 74:99:75:e3:c0:fe
Management Port IP Address (if 128): 0.0.0.0
Hardware Revision: 0
Hardware Part No:  BAC-00065-00
Switch Serial No:  Y010CM35X068
Manufacturing date: 13/22

MTM Value: 7309-HC3
ESN: 23A8900
Software Version 7.6.1.0                    (FLASH image2), active configuration.



Temperature Mother      Top: 41 C
Temperature Mother   Bottom: 33 C
Temperature Daughter    Top: 38 C
Temperature Daughter Bottom: 29 C

Warning at 75 C and Recover at 90 C

Fan 1 in Module 1: RPM= 7397 PWM= 15( 5%) Back-To-Front
Fan 2 in Module 1: RPM= 3411 PWM= 15( 5%) Back-To-Front
Fan 3 in Module 2: RPM= 9294 PWM= 15( 5%) Back-To-Front
Fan 4 in Module 2: RPM= 4821 PWM= 15( 5%) Back-To-Front
Fan 5 in Module 3: RPM= 7637 PWM= 15( 5%) Back-To-Front
Fan 6 in Module 3: RPM= 4808 PWM= 15( 5%) Back-To-Front
Fan 7 in Module 4: RPM= 9294 PWM= 15( 5%) Back-To-Front
Fan 8 in Module 4: RPM= 4599 PWM= 15( 5%) Back-To-Front

System Fan Airflow: Back-To-Front


Power Supply 1: OK
Power Supply 2: OK

  Power Faults: ()
    Fan Faults: ()
Service Faults: ()


sl-8264.sl.xo#show interface status 
-----------------------------------------------------------------------
Alias   Port   Speed    Duplex     Flow Ctrl      Link     Description
------- ----   -----   --------  --TX-----RX--   ------   -------------
1        1     40000     full      no     no       up        1       
5        5     40000     full      no     no      down       5       
9        9     40000     full      no     no       up        9       
13       13    40000     full      no     no       up        13      
17       17    10000     full      no     no       up        17      
18       18    10000     full      no     no       up        18      
19       19    10000     full      no     no       up        19      
20       20    10000     full      no     no       up        20      
21       21    10000     full      no     no       up        21      
22       22    10000     full      no     no       up        22      
23       23    10000     full      no     no       up        23      
24       24    10000     full      no     no       up        24      
25       25    10000     full      no     no       up        25      
26       26    10000     full      no     no       up        26      
27       27    1G/10G    full      no     no      down       27      
28       28    1G/10G    full      no     no      down       28      
29       29    1G/10G    full      no     no      down       29      
30       30    1G/10G    full      no     no      down       30      
31       31    1G/10G    full      no     no      down       31      
32       32    1G/10G    full      no     no      down       32      
33       33    1G/10G    full      no     no      down       33      
34       34    1G/10G    full      no     no      down       34      
35       35     1000     full      no     no       up        iSCSI storage/date plane
36       36     1000     full      no     no       up        iSCSI storage/date plane
37       37    10000     full      no     no    disabled     Connected to port 38
38       38    10000     full      no     no    disabled     Connected to port 37
39       39    1G/10G    full      no     no      down       39      
40       40    1G/10G    full      no     no      down       40      
41       41    10000     full      no     no       up        41      
42       42    10000     full      no     no       up        42      
43       43    10000     full      no     no       up        43      
44       44    10000     full      no     no       up        44      
45       45    10000     full      no     no       up        45      
46       46    10000     full      no     no       up        46      
47       47    10000     full      no     no       up        47      
48       48    10000     full      no     no       up        48      
49       49    10000     full      no     no       up        49      
50       50    10000     full      no     no       up        50      
51       51    1G/10G    full      no     no      down       51      
52       52    1G/10G    full      no     no      down       52      
53       53    1G/10G    full      no     no      down       53      
54       54    1G/10G    full      no     no      down       54      
55       55    1G/10G    full      no     no      down       55      
56       56    1G/10G    full      no     no      down       56      
57       57    1G/10G    full      no     no      down       57      
58       58    1G/10G    full      no     no      down       58      
59       59    1G/10G    full      no     no      down       59      
60       60    10000     full      no     no       up        StarLight OpenFlow switch connection
61       61    1G/10G    full      no     no      down       61      
62       62    1G/10G    full      no     no      down       62      
63       63    10000     full      no     no       up        Management plane connection (to 8052)
64       64    10000     full      no     no       up        64      
MGT      65     1000     full     yes    yes       up        MGT     
           
sl-8264.sl.xo#show running-config 
Current configuration:
!
version "7.6.1"
switch-type "IBM Networking Operating System RackSwitch G8264"
iscli-new
!
system timezone 145
! America/US/Eastern
system daylight
!
ssh enable
!

!
openflow enable
!
no system bootp
no system dhcp
no system default-ip mgt
hostname "sl-8264.sl.xo"
!
!
access snmp read-only
no access http enable
no access telnet enable
access user administrator-password "xxx"
!
!
interface port 1
	switchport mode trunk
	switchport trunk allowed vlan 1921-1930,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 5
	switchport mode trunk
	switchport trunk allowed vlan 1921-1930,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 9
	switchport mode trunk
	switchport trunk allowed vlan 1921-1930,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 13
	switchport mode trunk
	switchport trunk allowed vlan 1921-1930,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 17
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	exit
!
interface port 18
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 19
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 20
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 21
        switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 22
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 23
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 24
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 25
        switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 26
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 27
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 28
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 29
        switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 30
	switchport mode trunk
	switchport trunk allowed vlan 1009,4000
	switchport trunk native vlan 4000
	spanning-tree portfast
	exit
!
interface port 35
	description "iSCSI storage/date plane"
	switchport access vlan 1009
	spanning-tree portfast
	exit
!
interface port 36
	description "iSCSI storage/date plane"
	switchport access vlan 1009
	spanning-tree portfast
	exit
!
interface port 37
	description "Connected to port 38"
	shutdown
        exit
!
interface port 38
	description "Connected to port 37"
	shutdown
	exit
!
interface port 41
	no learning
	flood-blocking
	exit
!
interface port 42
	no learning
	flood-blocking
	exit
!
interface port 43
	no learning
	flood-blocking
	exit
!
interface port 44
	no learning
	flood-blocking
	exit
!
...many lines of output not shown....

Verify FOAM and FlowVisor configuration files ownership and paths:

[lnevers@sl-hn ~]$ ls -l /etc/foam.passwd  /etc/flowvisor.passwd /etc/flowvisor/fvpasswd /opt/foam/etc/foampasswd
lrwxrwxrwx  1 root      flowvisor 21 Nov 11  2013 /etc/flowvisor/fvpasswd -> /etc/flowvisor.passwd
-r--r-----  1 flowvisor sladmins  25 Nov 11  2013 /etc/flowvisor.passwd
-r--r-----+ 1 root      sladmins  25 Nov 11  2013 /etc/foam.passwd
lrwxrwxrwx  1 root      root      16 Nov 11  2013 /opt/foam/etc/foampasswd -> /etc/foam.passwd
[lnevers@sl-hn ~]$ 

Check FOAM version and FOAM configuration for site.admin.email, geni.site-tag, email.from settings on the SL head node:

[lnevers@sl-hn ~]$ foamctl admin:get-version  --passwd-file=/etc/foam.passwd
{
 "version": "0.14.0"
}
[lnevers@sl-hn ~]$ foamctl config:get-value --key="site.admin.email"  --passwd-file=/opt/foam/etc/foampasswd
{
 "value": null
}

[lnevers@sl-hn ~]$ foamctl config:get-value --key="geni.site-tag"  --passwd-file=/opt/foam/etc/foampasswd
{
 "value": "sl-hn.exogeni.net"
}
[lnevers@sl-hn ~]$ foamctl config:get-value --key="email.from"  --passwd-file=/opt/foam/etc/foampasswd
{
 "value": "Jim Hao Chen <jim-chen@northwestern.edu>"
}
[lnevers@sl-hn ~]$ foamctl config:get-value --key="geni.approval.approve-on-creation"  --passwd-file=/opt/foam/etc/foampasswd
{
 "value": 2
}
[lnevers@sl-hn ~]$ 

Show FOAM slivers details:

[lnevers@sl-hn ~]$ foamctl geni:list-slivers --passwd-file=/opt/foam/etc/foampasswd 
{
 "slivers": [
  {
   "status": "approved", 
   "flowvisor_slice": "59d0e1a3-c0fe-442b-b1ca-64814ced147c", 
   "slice_urn": "urn:publicid:IDN+ch.geni.net:gpo-infra+slice+tupty3715", 
   "pend_reason": [], 
   "deleted": "False", 
   "user": "urn:publicid:IDN+ch.geni.net+user+tupty", 
   "creation": "2014-04-22 21:06:12.701819+00:00", 
   "enabled": true, 
   "uuid": "59d0e1a3-c0fe-442b-b1ca-64814ced147c", 
   "id": 5, 
   "expiration": "2014-08-27 00:00:00+00:00", 
   "sliver_urn": "urn:publicid:IDN+ch.geni.net:gpo-infra+slice+tupty3715:59d0e1a3-c0fe-442b-b1ca-64814ced147c", 
   "ref": null, 
   "email": "tupty@bbn.com", 
   "desc": "tupty3715 OpenFlow resources at Starlight"
  }, 
  {
   "status": "approved", 
   "flowvisor_slice": "bce2be4c-8c90-4b78-9306-ee1e0df1bf5a", 
   "slice_urn": "urn:publicid:IDN+ch.geni.net:gpoamcanary+slice+sitemon", 
   "pend_reason": [], 
   "deleted": "False", 
   "user": "urn:publicid:IDN+ch.geni.net+user+tupty", 
   "creation": "2014-05-29 18:31:45.738384+00:00", 
   "enabled": true, 
   "uuid": "bce2be4c-8c90-4b78-9306-ee1e0df1bf5a", 
   "id": 9, 
   "expiration": "2014-08-21 00:00:00+00:00", 
   "sliver_urn": "urn:publicid:IDN+ch.geni.net:gpoamcanary+slice+sitemon:bce2be4c-8c90-4b78-9306-ee1e0df1bf5a", 
   "ref": null, 
   "email": "tupty@bbn.com", 
   "desc": "sitemon OpenFlow resources at Starlight"
  }, 
  {
   "status": "approved", 
   "flowvisor_slice": "a604d584-2930-42a1-afa2-76031cae06c6", 
   "slice_urn": "urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-4", 
   "pend_reason": [], 
   "deleted": "False", 
   "user": "urn:publicid:IDN+ch.geni.net+user+lnevers", 
   "creation": "2014-07-17 18:59:10.834481+00:00", 
   "enabled": true, 
   "uuid": "a604d584-2930-42a1-afa2-76031cae06c6", 
   "id": 16, 
   "expiration": "2014-07-24 18:57:14+00:00", 
   "sliver_urn": "urn:publicid:IDN+ch.geni.net:Luisa_Nevers-Test-Proj_01+slice+EG-CT-4:a604d584-2930-42a1-afa2-76031cae06c6", 
   "ref": null, 
   "email": "lnevers@bbn.com", 
   "desc": "IG-CT-4 over 3716 "
  }
 ]
}
[lnevers@sl-hn ~]$ 

Check the FlowVisor version, list of devices, get details for a device, list of active slices, and details for one of the slices on the SL Head node:

[lnevers@sl-hn ~]$ /opt/flowvisor/bin/fvctl --passwd-file=/etc/flowvisor/fvpasswd ping hello
Got reply:
PONG(fvadmin): FV version=flowvisor-0.8.1::hello
[lnevers@sl-hn ~]$ /opt/flowvisor/bin/fvctl --passwd-file=/etc/flowvisor/fvpasswd listDevices
Device 0: 00:01:74:99:75:e3:c0:00
[lnevers@sl-hn ~]$ /opt/flowvisor/bin/fvctl --passwd-file=/etc/flowvisor/fvpasswd getDeviceInfo 00:01:74:99:75:e3:c0:00
nPorts=21
portList=41,42,43,44,45,46,47,48,51,52,53,54,55,56,57,58,59,60,64,50,49
dpid=00:01:74:99:75:e3:c0:00
remote=/192.168.112.10:6633-->/192.168.112.4:51319
portNames=41(41),42(42),43(43),44(44),45(45),46(46),47(47),48(48),51(51),52(52),53(53),54(54),55(55),56(56),57(57),58(58),59(59),StarLight OpenF(60),64(64),50(50),49(49)
[lnevers@sl-hn ~]$ /opt/flowvisor/bin/fvctl --passwd-file=/etc/flowvisor/fvpasswd listSlices
Slice 0: 59d0e1a3-c0fe-442b-b1ca-64814ced147c
Slice 1: bce2be4c-8c90-4b78-9306-ee1e0df1bf5a
Slice 2: a604d584-2930-42a1-afa2-76031cae06c6
Slice 3: fvadmin
[lnevers@sl-hn ~]$ /opt/flowvisor/bin/fvctl --passwd-file=/etc/flowvisor/fvpasswd getSliceInfo  59d0e1a3-c0fe-442b-b1ca-64814ced147c
Got reply:
connection_1=00:01:74:99:75:e3:c0:00-->/165.124.159.5:30244-->hafmet.gpolab.bbn.com/192.1.249.178:33012
contact_email=tupty@bbn.com
controller_hostname=hafmet.gpolab.bbn.com
controller_port=33012
creator=fvadmin
[lnevers@sl-hn ~]$ 

Email help@geni.net for GENI support or email me with feedback on this page!