Changes between Version 26 and Version 27 of AaronHelsinger/GAPI_AM_API_DRAFT


Ignore:
Timestamp:
03/29/12 15:53:11 (7 years ago)
Author:
Aaron Helsinger
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • AaronHelsinger/GAPI_AM_API_DRAFT

    v26 v27  
    174174Considering the clarified sliver definition, several API names are misleading. This change proposal modifies those method names to clarify that they may work with multiple slivers. Additionally, some methods can logically operate on individual slivers: this change modifies those methods' arguments to allow specifying a particular sliver.
    175175
    176 This proposal is missing a supplementary proposal of the semantics involved in operating on individual slivers, part of the slice at an AM. In particular, defining whether !CreateSlivers can be called multiple times, and the semantics of doing !DeleteSlivers or !RenewSlivers on only some of the slivers in a slice at an aggregate.
    177 
    178 '''The specifics of this proposal are superseded by proposal F3 and the proposed summary methods at the bottom of this page.'''
     176'''This proposal is missing a supplementary proposal of the semantics involved in operating on individual slivers, part of the slice at an AM.''' In particular, defining whether !CreateSlivers can be called multiple times, and the semantics of doing !DeleteSlivers or !RenewSlivers on only some of the slivers in a slice at an aggregate.
     177
     178'''The specific method signature changes of this proposal are superseded by proposal F3 and the proposed summary methods at the bottom of this page.'''
    179179
    180180 1. Rename some existing methods to clarify that they act on 1+ slivers: