Opened 5 years ago

Closed 5 years ago

#1289 closed (fixed)

AL2S OESS aggregate reports exception for stanford to missouri path

Reported by: lnevers@bbn.com Owned by: luke@grnoc.iu.edu
Priority: critical Milestone:
Component: STITCHING Version: SPIRAL6
Keywords: GENI Network Stitching Cc:
Dependencies:

Description

While running the very simple topology:

Stanford IG <->AL2S<-> Missouri IG

The following error is coninously reported:

08:56:43 INFO    : Stitcher doing createsliver at <Aggregate oess>...
08:56:45 ERROR   :  {'output': 'Exception: Unable to find a suitable 
path for this request.', 'code': {'geni_code': 2}}

Attaching the expanded stitching request RSpec.

Attachments (1)

lnoess-createsliver-request-11-al2s-internet2-edu.xml (4.9 KB) - added by lnevers@bbn.com 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by lnevers@bbn.com

comment:1 Changed 5 years ago by lnevers@bbn.com

Priority: majorcritical

comment:2 Changed 5 years ago by lnevers@bbn.com

This problem occurs only when AL2S Stanford IG is used. Other topologies with AL2S end-points at Missouri IG and UChicago IG do not show this symptom.

Also any sliver that includes Stanford IG eventually succeeds on the 3rd or 4th try.

comment:3 Changed 5 years ago by lnevers@bbn.com

Component: GPOSTITCHING

comment:4 Changed 5 years ago by luke@grnoc.iu.edu

Took a look at this this morning... A path could not be found because the VLAN ID requested on sdn-sw.sunn (1642) is not available.

Is there a different error that would be more appropriate to return in this case?

comment:5 Changed 5 years ago by luke@grnoc.iu.edu

clarification: sdn-sw.sunn port e5/1 VLAN 1642

comment:6 Changed 5 years ago by lnevers@bbn.com

Yes a clearer error would be more helpful. The error should capture the source of the problem, which is VLAN already in use.

comment:7 Changed 5 years ago by lnevers@bbn.com

Luke can you have the error return be "error code 24 (VLAN_UNAVAILABLE)" when the problem is that the requested VLAN tag is not available? This would make the error consistent with other aggregates.

Also a question does this error "Unable to find a suitable path" always means that the suggested VLAN tag is not available? Or can this error message also be reported for other potential errors?

comment:8 Changed 5 years ago by luke@grnoc.iu.edu

yes, I can.

You will also get the "unable to find a suitable path" error when it cannot find a set of trunks that connect interface A to interface Z across AL2S.

comment:9 in reply to:  8 Changed 5 years ago by lnevers@bbn.com

Replying to lnevers@…:

Luke can you have the error return be "error code 24 (VLAN_UNAVAILABLE)" when the problem is that the requested VLAN tag is not available? This would make the error consistent with other aggregates.

Replying to luke@…:

yes, I can.

---

Luke is there any chance of this being done soon? We are now finishing up gcf-2.7 to be released early next week and would like to have this fix for the stitcher to handle the failure.

comment:10 Changed 5 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

Verified that the expected error code is now returned:

15:41:18 WARNING : Failed CreateSliver for slice lndup at oess.  Error from Aggregate: code 24: Exception: requested VLAN unavailable: sdn-sw.kans.net.internet2.edu,eth5/1 VLAN=1162.

Closing ticket, no more issues for this one.

Note: See TracTickets for help on using tickets.