Opened 6 years ago

Closed 6 years ago

#1195 closed (fixed)

Delete of sliver whose circuit on longer exists in MAX causes subsequent circuits to not complete

Reported by: lnevers@bbn.com Owned by: xyang@maxgigapop.net
Priority: major Milestone:
Component: STITCHING Version: SPIRAL6
Keywords: Network Stitching Cc:
Dependencies:

Description

This ticket tracks the resolution of a problem identified in the an email exchange.

Symptoms seen in stitcher:

WARNING  stitch.Aggregate: sliverstatus #### is (still) changing at <Aggregate 
urn:publicid:IDN+dragon.maxgigapop.net+authority+am>. Delete and retry.

The above message is reported for all attempts to get a circuit at MAX aggregate.

Some additional details:

On 2/7/14 10:24 AM, Xi Yang wrote:

The problem we had yesterday at DRAGON layer left inconsistent states in OSCARS, 
which caused problem when OSCARS tried to delete a sliver whose circuit on longer 
existed in DRAGON. I restarted OSCARS-pss-dragon module. Please try again.

On 2/7/14 10:43 AM, Luisa Nevers wrote:

Deleting a sliver whose circuit is no longer available should  be handled because 
it is likely that an experimenter may just clean up some sliver that not longer 
working. A delete for a missing circuit should not impact all future attempts.

BTW, retried and it worked.

On 2/7/14 10:57 AM, Xi Yang wrote:

Yes it normally worked. But somehow the OSCARS dragonPSS gets stuck in a strange 
state due to some bug.
Part of the OSCARS dragonPSS is developed by me. I will try figuring it out but 
it is not my priority for now. 

Change History (1)

comment:1 Changed 6 years ago by xyang@maxgigapop.net

Resolution: fixed
Status: newclosed

The problem was caused by a bug in OSCARS dragonPSS module. It has been fixed.

Note: See TracTickets for help on using tickets.