Opened 6 years ago

Closed 6 years ago

#1175 closed (fixed)

VNODE and FLARE

Reported by: nakao@iii.u-tokyo.ac.jp Owned by: peter.stickney@bbn.com
Priority: major Milestone:
Component: GPO Version: SPIRAL6
Keywords: GEC19 Cc: toshiaki.tarui.my@hitachi.com, shu@iii.u-tokyo.ac.jp, minami.yuuki@lab.ntt.co.jp, tupty@bbn.com
Dependencies:

Description

  • Brief demo description

We updated VNode system to next version and we will be showing our progress of VNode system, especially focusing on applications working over VNode system. We are planning to prepare three kinds of demos, one for video multicasting and transcoding in virtual network, second for FLARE switch, and at last for federation between different virtualization platforms.

  • List of equipment that will need AC connections

8 (Laptop * 4, FLARE SW * 2, SW*2)

  • Number of wired network connections

6 (FLARE SW*2, Laptop*4)

  • Number of wireless network connection

None

  • Number of static addresses needed

Two VLAN addresses for VLANs described in the special requests.

  • Monitor

Two VGA

  • Number of posters

3(three)

  • Description of any special requests

It would be appreciated if you could allocate two tables. We need to extend those VLAN to the demo floor:

Transpacific VLAN 1593 VLAN extend from ProtoGENI Node (from Utah)

We will contact you about the more detailed VLAN configuration separately.

Attachments (3)

gec-19-demo-requests (version 1).pdf (190.9 KB) - added by hdempsey@bbn.com 6 years ago.
VNODE networking for GEC19
oscars.circuit.76141.pdf (168.1 KB) - added by tupty@bbn.com 6 years ago.
oscars.circuit.78301.pdf (167.8 KB) - added by tupty@bbn.com 6 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 6 years ago by peter.stickney@bbn.com

Status: newassigned

Thank you for your demo request. We will update this ticket when the resources have been confirmed.

Please update this ticket when you know more about the VLAN configuration, we'll want to arrange this with Georgia Tech soon.

comment:2 Changed 6 years ago by peter.stickney@bbn.com

We can now confirm that the resources you requested will be available for you on Demo Night. See you in Atlanta!

comment:3 Changed 6 years ago by hdempsey@bbn.com

Cc: tupty@bbn.com added

Aki contacted me to follow up on the specific VLANs he will need. He didn't specify how many besides 1593 they need. Rob says PG can extend Aki's VLANs to the ION endpoint in Atlanta, as they did before. We have to coordinate the VLANIDs and work with Georgia Tech on getting it from ION to the demo floor at Aki's tables. Adding Tim to the list to help check for VLANID collisions.

comment:4 Changed 6 years ago by tupty@bbn.com

Ok, so it sounds like there are two VLANs that will need to be extended to the demo floor (please correct me if that is wrong).

We might as well try to match the VLAN IDs on the two ends if it is easy. We can see if 1593 is available from SoX's ION end-point through to the demo floor. For the VLAN coming from Utah, is the VLAN ID known yet?

In the last GEC, for the 1593 connection we did the following:

  • JGN-X translated this 1593 to 3133 statically in Tokyo for VLAN range limitations in Transpac
  • We created an OSCARS interdomain circuit from a JGN-X endpoint to the ION endpoint facing the demo site

Do we want to create a single interdomain circuit again for this specific connection? If so, can someone fill me in on the details of the JGN-X side of things at this point in time?

comment:5 Changed 6 years ago by hdempsey@bbn.com

It's possible that the JGN-X side is still up, because Aki has continued to work with Rob. We aren't sure if this is the same demo as last time, since the description is a bit different. I've asked Aki/Rob to tell us more about the JGN-X side and the number of VLANs so we can figure this out.

Changed 6 years ago by hdempsey@bbn.com

VNODE networking for GEC19

comment:6 Changed 6 years ago by hdempsey@bbn.com

JGN-X side is different this time. However, Aki already has Jin and Rob working on that side, so we in GPO don't need to do anything for that. Aki just needs 2 VLANS (1593 and VLAN-X) extended from PG through the ION endpoint, and then to Georgia Tech campus. Rob can get the VLANs to the ION endpoint. (Aki also needs internet connectivity, but that is standard for the demo) VLANID for the second VLAN should be whatever is easiest to arrange with GT. Aki provided a .pdf of the whole demo for reference (attached).

comment:7 Changed 6 years ago by hdempsey@bbn.com

Cc: minami.yuuki@lab.ntt.co.jp added

Yuki Minami 南 勇貴 <minami.yuuki@lab.ntt.co.jp> would like the VLAN info for what will be at the demo table as soon as it is available. I told him we'd update this ticket with the information when it was available. I gave him the URL and added him to the cc: list

Here's his request:

Hello Heidi,

I'm Yuki Minami and member of VNode team. I'd like to know how will be the VLANs at the tables in the demo venue (i.e. tagged/untagged, D-plane's VLAN ID). So would you tell me contact of Georgia Tech networking people?

Thank you for your cooperation, Yuki


Yuuki Minami Researcher, NTT Network Innovation Laboratories NIPPON TELEGRAPH AND TELEPHONE CORPORATION 1-1 Hikarinooka Yokosuka-Shi Kanagawa 239-0847 Japan Mail: minami.yuuki@lab.ntt.co.jp Tel: +81-46-859-3165 Fax: +81-46-855-1284


comment:8 Changed 6 years ago by hdempsey@bbn.com

Toshiaki Tarui <toshiaki.tarui.my@hitachi.com> provided this info on the JGN-to-Utah part of the network VLANs, just FYI:

According to Jin's mail which I received end of last month, Followings are VLAN translation and routing plan from Tokyo(KOTE) to Utah.


KOTE US Utah 1593 <=> 3139 <=> 1593 1550 <=> 3115 <=> 1550 1551 <=> 3116 <=> 1551 1552 <=> 3117 <=> 1552 1553 <=> 3118 <=> 1553 1554 <=> 3119 <=> 1554

JGN-X<=>CENIC<=>PNWGP<=>NorthernWave<=>StarLight


comment:9 Changed 6 years ago by hdempsey@bbn.com

with better formatting:

KOTE US Utah

1593 <=> 3139 <=> 1593

1550 <=> 3115 <=> 1550

1551 <=> 3116 <=> 1551

1552 <=> 3117 <=> 1552

1553 <=> 3118 <=> 1553

1554 <=> 3119 <=> 1554

Domains: JGN-X<=>CENIC<=>PNWGP<=>NorthernWave<=>StarLight

comment:10 Changed 6 years ago by tupty@bbn.com

The folks at Georgia Tech have reserved 1593 and 1594 for the VNODE and FLARE demo.

This will connect to Georgia Tech through the SoX AL2S connector. We might need to know which workgroup to use in order to set up an OESS ACL for these circuits, although I am asking I2 about that. I'll try to get in touch with Rob to figure out specifics.

comment:11 Changed 6 years ago by tupty@bbn.com

Quick status update:

We will be using manual OSCARS circuits from an ION point that Utah will designate, and we will span that through ION and AL2S infrastructure into the SoX ATLA AL2S endpoint. We are currently waiting on Utah for the last few details. Once we have those, I'll go ahead and create the circuits.

Changed 6 years ago by tupty@bbn.com

Attachment: oscars.circuit.76141.pdf added

comment:12 Changed 6 years ago by tupty@bbn.com

I have attached details of two OSCARS circuits I have set up. The basic gist is this:

  • One circuit spans from the ProtoGENI ION connector in ATLA on VLAN 1593 to the SoX AL2S connector on VLAN 1593. This connection expires on March 25th.
  • One circuit spans from the ProtoGENI ION connector in ATLA on VLAN 1601 to the SoX AL2S connector on VLAN 1594. This connection expires on March 25th.

As far as I can tell, these are ready. I know Rob and his team are still working on some pieces from Utah.

Changed 6 years ago by tupty@bbn.com

Attachment: oscars.circuit.78301.pdf added

comment:13 in reply to:  12 Changed 6 years ago by tupty@bbn.com

Replying to tupty@bbn.com:

  • One circuit spans from the ProtoGENI ION connector in ATLA on VLAN 1601 to the SoX AL2S connector on VLAN 1594. This connection expires on March 25th.

At Utah's request, we have changed the VLAN on the ProtoGENI side to be VLAN 589. The new OSCARS circuit reflecting this change is up, and I have attached the circuit details for that new circuit to this ticket. I removed the attachment containing details for the circuit which is no longer available.

comment:14 Changed 6 years ago by peter.stickney@bbn.com

Resolution: fixed
Status: assignedclosed

Thanks for joining us in Atlanta this year. We hope everything worked as you expected.

Please feel free to update / append the wiki page for the Demo Night here:

http://groups.geni.net/geni/wiki:GEC19Agenda/EveningDemoSession

Note: See TracTickets for help on using tickets.