Opened 6 years ago

Closed 5 years ago

#1136 closed (fixed)

Links are listed twice in OESS Advertisement Rspecs

Reported by: lnevers@bbn.com Owned by: luke@grnoc.iu.edu
Priority: major Milestone:
Component: STITCHING Version: SPIRAL6
Keywords: oess Cc: matt@internet2.edu, eboyd@internet2.edu
Dependencies:

Description

OESS advertisement rspecs list links twice, once from the perspective of one side of the link and a second time from the perspective of the other side of the link.

For example the link <oess:link urn="urn:publicid:IDN+oess:foam:nddi+link+I2-CLEV-STAR-100GE-07736" /> is shown as follow in the advertisement:

<oess:link a_node="urn:publicid:IDN+oess:foam:nddi+sdn-sw.star.net.internet2.edu" 
urn="urn:publicid:IDN+oess:foam:nddi+link+I2-CLEV-STAR-100GE-07736" 
z_node="urn:publicid:IDN+oess:foam:nddi+sdn-sw.star.net.internet2.edu"/>

<oess:link a_node="urn:publicid:IDN+oess:foam:nddi+sdn-sw.clev.net.internet2.edu" 
urn="urn:publicid:IDN+oess:foam:nddi+link+I2-CLEV-STAR-100GE-07736" 
z_node="urn:publicid:IDN+oess:foam:nddi+sdn-sw.clev.net.internet2.edu"/>

There should only be one link entry.

Change History (4)

comment:1 Changed 6 years ago by nick.bastin@gmail.com

All network graph edges are simplex. The existence of one direction does not guarantee the reverse path.

comment:2 Changed 5 years ago by lnevers@bbn.com

Advertisement RSpecs still show links twice.

comment:3 Changed 5 years ago by nick.bastin@gmail.com

Again, this is not a bug. All circuit links are simplex, so these link entries are unique, not duplicates.

comment:4 Changed 5 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

You are right I was focusing on the link URN and not the a_node/z_node values.

Note: See TracTickets for help on using tickets.