Opened 6 years ago

Closed 6 years ago

#1062 closed (fixed)

Global Network Monitoring Based on Mininet Approach

Reported by: hdempsey@bbn.com Owned by: peter.stickney@bbn.com
Priority: major Milestone:
Component: GPO Version: SPIRAL5
Keywords: GEC17 Cc: rsmeliansky@redlab.ru, anvial@lvk.cs.msu.su
Dependencies:

Description

poster only demo request may be coming from V. Antonenko. This is a placeholder request, based on email from senior researcher Ruslan Smeliansky.

Change History (5)

comment:1 Changed 6 years ago by hdempsey@bbn.com

Owner: changed from pstickne@bbn.com to peter.stickney@bbn.com

comment:2 Changed 6 years ago by peter.stickney@bbn.com

Status: newassigned

Thank you for your demo request. We will update this ticket when the resources have been confirmed.

comment:3 Changed 6 years ago by tupty@bbn.com

Cc: anvial@lvk.cs.msu.su added

Brief demo description:

The problem of the Global network operation analysis has a variety of applications. In this paper we show an approach to this problem on example of malware propagation in the Global networks (Wide Area Network).

It is very important to be able to make accurate prediction of the consequences of such propagation. This paper introduces a new approach to malware propagation prediction based on the ideas presented by Mininet network rapid prototyping approach.

The major barriers to use simulation techniques for malware propagation analysis are enormous network size and low level granularity in protocol data unit processing. Mininet cannot be used for this purpose too because of its low level scalability. In this paper, we propose a new system called Mininet CE (Cluster Edition) which is based on the ideas of existent Mininet.

Mininet CE offers the solution of the Global network functionality analysis problems. In this paper, we focus on propagation analysis of a malware as network worm. The experiments with the worm Sasser demonstrate the ability of Mininet CE to be useful tool for worm propagation analysis in the Global network.

List of equipment that will need AC connections (e.g. laptop, monitor).

2

Number of wired network connections (include required bandwidth if significant)

0

Number of wireless network connections (include required bandwidth if significant)

2

Number of static addresses needed (if any)

0

Monitor (y/n, specify VGA or DVI) (Specify resolution only if your software has resolution restrictions.)

Yes, VGA

Number of posters (max size poster boards are 30" x 40")

1

Description of any special requests (include any specific network connectivity needs (e.g. layer2 VLAN to NLR), projects you'd like to be located near, etc.)

NO

comment:4 Changed 6 years ago by peter.stickney@bbn.com

We can now confirm that the resources you requested will be available for you on Demo Night. See you in Madison!

comment:5 Changed 6 years ago by peter.stickney@bbn.com

Resolution: fixed
Status: assignedclosed

Thanks again for participating in the GEC 17 evening demo session! We hope everything went as planned!

Feel free to edit the wiki to update any information about your demo here - GEC17Agenda/EveningDemoSession

Note: See TracTickets for help on using tickets.