GENIRacksHome/ExogeniRacks/AggregateSurvey: failed-v3-support.txt

File failed-v3-support.txt, 9.2 KB (added by lnevers@bbn.com, 7 years ago)
Line 
1th arguments from 04/11/2012:
2{{{
3lnevers@sendaria:~/gcf-1.6.1/acceptance_tests/AM_API$ ./am_api_accept.py -a am-undertest -V 2 --debug
4FFFFFFFFFFFFF
5======================================================================
6FAIL: test_CreateSliver: Passes if the sliver creation workflow succeeds.  Use --rspec-file to replace the default request RSpec.
7----------------------------------------------------------------------
8Traceback (most recent call last):
9  File "./am_api_accept.py", line 625, in test_CreateSliver
10    self.subtest_CreateSliverWorkflow()
11  File "./am_api_accept.py", line 652, in subtest_CreateSliverWorkflow
12    manifest = self.subtest_CreateSliver( slicename )
13  File "./am_api_accept.py", line 1098, in subtest_CreateSliver
14    self.assertTrue( self.checkRequestRSpecVersion() )
15  File "./am_api_accept.py", line 126, in checkRequestRSpecVersion
16    return self.checkRSpecVersion(type='request')
17  File "./am_api_accept.py", line 175, in checkRSpecVersion
18    "Agg doesn't support requested version: %s %s" % (rtype, rver))
19AssertionError: Agg doesn't support requested version: GENI 3
20
21======================================================================
22FAIL: test_CreateSliverWorkflow_fail_notexist:  Passes if the sliver creation workflow fails when the sliver has never existed.
23----------------------------------------------------------------------
24Traceback (most recent call last):
25  File "./am_api_accept.py", line 835, in test_CreateSliverWorkflow_fail_notexist
26    self.subtest_CreateSliverWorkflow_failure( slicename )
27  File "./am_api_accept.py", line 844, in subtest_CreateSliverWorkflow_failure
28    self.assertRaises(NotDictAssertionError, self.subtest_ListResources, slicename )
29AssertionError: Agg doesn't support requested version: GENI 3
30
31======================================================================
32FAIL: test_CreateSliverWorkflow_multiSlice: Do CreateSliver workflow with multiple slices and ensure can not do ListResources on slices with the wrong credential.
33----------------------------------------------------------------------
34Traceback (most recent call last):
35  File "./am_api_accept.py", line 931, in test_CreateSliverWorkflow_multiSlice
36    manifest[i] = "".join(self.subtest_CreateSliver( slicenames[i] ))
37  File "./am_api_accept.py", line 1098, in subtest_CreateSliver
38    self.assertTrue( self.checkRequestRSpecVersion() )
39  File "./am_api_accept.py", line 126, in checkRequestRSpecVersion
40    return self.checkRSpecVersion(type='request')
41  File "./am_api_accept.py", line 175, in checkRSpecVersion
42    "Agg doesn't support requested version: %s %s" % (rtype, rver))
43AssertionError: Agg doesn't support requested version: GENI 3
44
45======================================================================
46FAIL: test_CreateSliver_badrspec_emptyfile: Passes if the sliver creation workflow fails when the request RSpec is an empty file.
47----------------------------------------------------------------------
48Traceback (most recent call last):
49  File "./am_api_accept.py", line 1214, in test_CreateSliver_badrspec_emptyfile
50    self.subtest_MinCreateSliverWorkflow, slice_name )
51AssertionError: Agg doesn't support requested version: GENI 3
52
53======================================================================
54FAIL: test_CreateSliver_badrspec_malformed: Passes if the sliver creation workflow fails when the request RSpec is not well-formed XML.
55----------------------------------------------------------------------
56Traceback (most recent call last):
57  File "./am_api_accept.py", line 1242, in test_CreateSliver_badrspec_malformed
58    self.subtest_MinCreateSliverWorkflow, slice_name )
59AssertionError: Agg doesn't support requested version: GENI 3
60
61======================================================================
62FAIL: test_CreateSliver_badrspec_manifest: Passes if the sliver creation workflow fails when the request RSpec is a manifest RSpec.  --bad-rspec-file allows you to replace the RSpec with an alternative.
63----------------------------------------------------------------------
64Traceback (most recent call last):
65  File "./am_api_accept.py", line 1258, in test_CreateSliver_badrspec_manifest
66    self.subtest_MinCreateSliverWorkflow, slice_name)
67AssertionError: Agg doesn't support requested version: GENI 3
68
69======================================================================
70FAIL: test_GetVersion: Passes if a 'GetVersion' returns an XMLRPC struct containing 'geni_api' and other parameters defined in Change Set A.
71----------------------------------------------------------------------
72Traceback (most recent call last):
73  File "./am_api_accept.py", line 280, in test_GetVersion
74    % (agg, exp_type, exp_num) )
75AssertionError: Return from 'GetVersion' at https://bbn-hn.exogeni.net:11443/orca/xmlrpc expected to have entry 'geni_request_rspec_versions' of type='GENI' and value='3' but did not.
76
77======================================================================
78FAIL: test_ListResources: Passes if 'ListResources' returns an advertisement RSpec.
79----------------------------------------------------------------------
80Traceback (most recent call last):
81  File "./am_api_accept.py", line 328, in test_ListResources
82    self.subtest_ListResources()
83  File "./am_api_accept.py", line 502, in subtest_ListResources
84    self.assertTrue( self.checkAdRSpecVersion() )
85  File "./am_api_accept.py", line 124, in checkAdRSpecVersion
86    return self.checkRSpecVersion(type='ad')
87  File "./am_api_accept.py", line 175, in checkRSpecVersion
88    "Agg doesn't support requested version: %s %s" % (rtype, rver))
89AssertionError: Agg doesn't support requested version: GENI 3
90
91======================================================================
92FAIL: test_ListResources_badCredential_alteredObject: Run ListResources with a User Credential that has been altered (so the signature doesn't match).
93----------------------------------------------------------------------
94Traceback (most recent call last):
95  File "./am_api_accept.py", line 351, in test_ListResources_badCredential_alteredObject
96    self.subtest_ListResources_badCredential(self.alterSignedObject)
97  File "./am_api_accept.py", line 395, in subtest_ListResources_badCredential
98    self.assertRaises(NotDictAssertionError, self.subtest_ListResources, usercred=broken_usercred)
99AssertionError: Agg doesn't support requested version: GENI 3
100
101======================================================================
102FAIL: test_ListResources_badCredential_malformedXML: Run ListResources with a User Credential that is missing it's first character (so that it is invalid XML).
103----------------------------------------------------------------------
104Traceback (most recent call last):
105  File "./am_api_accept.py", line 347, in test_ListResources_badCredential_malformedXML
106    self.subtest_ListResources_badCredential(self.removeFirstChar)
107  File "./am_api_accept.py", line 395, in subtest_ListResources_badCredential
108    self.assertRaises(NotDictAssertionError, self.subtest_ListResources, usercred=broken_usercred)
109AssertionError: Agg doesn't support requested version: GENI 3
110
111======================================================================
112FAIL: test_ListResources_geni_available: Passes if 'ListResources' returns an advertisement RSpec.
113----------------------------------------------------------------------
114Traceback (most recent call last):
115  File "./am_api_accept.py", line 342, in test_ListResources_geni_available
116    self.subtest_ListResources()
117  File "./am_api_accept.py", line 502, in subtest_ListResources
118    self.assertTrue( self.checkAdRSpecVersion() )
119  File "./am_api_accept.py", line 124, in checkAdRSpecVersion
120    return self.checkRSpecVersion(type='ad')
121  File "./am_api_accept.py", line 175, in checkRSpecVersion
122    "Agg doesn't support requested version: %s %s" % (rtype, rver))
123AssertionError: Agg doesn't support requested version: GENI 3
124
125======================================================================
126FAIL: test_ListResources_geni_compressed: Passes if 'ListResources' returns an advertisement RSpec.
127----------------------------------------------------------------------
128Traceback (most recent call last):
129  File "./am_api_accept.py", line 335, in test_ListResources_geni_compressed
130    self.subtest_ListResources()
131  File "./am_api_accept.py", line 502, in subtest_ListResources
132    self.assertTrue( self.checkAdRSpecVersion() )
133  File "./am_api_accept.py", line 124, in checkAdRSpecVersion
134    return self.checkRSpecVersion(type='ad')
135  File "./am_api_accept.py", line 175, in checkRSpecVersion
136    "Agg doesn't support requested version: %s %s" % (rtype, rver))
137AssertionError: Agg doesn't support requested version: GENI 3
138
139======================================================================
140FAIL: test_ListResources_untrustedCredential: Passes if 'ListResources' FAILS to return an advertisement RSpec when using a credential from an untrusted Clearinghouse.
141----------------------------------------------------------------------
142Traceback (most recent call last):
143  File "./am_api_accept.py", line 496, in test_ListResources_untrustedCredential
144    self.assertRaises(NotDictAssertionError, self.subtest_ListResources, usercredfile=self.options_copy.untrusted_usercredfile)
145AssertionError: Agg doesn't support requested version: GENI 3
146
147----------------------------------------------------------------------
148Ran 13 tests in 176.410s
149
150FAILED (failures=13)