Opened 10 years ago

Closed 10 years ago

#95 closed (fixed)

FlowVisor version

Reported by: jbs@bbn.com Owned by: vjo@cs.duke.edu
Priority: major Milestone: EG-MON-1
Component: Administration Version: SPIRAL4
Keywords: Cc:
Dependencies:

Description

On both bbn-hn and rci-hn, 'rpm -qi flowvisor' says "Version : 0.8.2", but 'fvctl --passwd-file=/etc/flowvisor/fvpasswd ping ping' says "FV version=flowvisor-0.8.1". What version is actually running?

Change History (3)

comment:1 Changed 10 years ago by jbs@bbn.com

Component: AMAdministration
Milestone: EG-MON-1

comment:2 Changed 10 years ago by ibaldin@renci.org

Owner: changed from somebody to vjo@cs.duke.edu

comment:3 Changed 10 years ago by jbs@bbn.com

Resolution: fixed
Status: newclosed

Victor and I talked on IRC, and concluded:

13:47 < orlikowski> jbsbbn: we have onlab-flowvisor-8c2d617e870c

and

13:48 < orlikowski> [vjo@build onlab-flowvisor-8c2d617e870c]$ pwd
13:48 < orlikowski> /home/vjo/rpms/RPMBUILD/BUILD/onlab-flowvisor-8c2d617e870c
13:48 < orlikowski> [vjo@build onlab-flowvisor-8c2d617e870c]$ head -n 4 
                    RELEASE-NOTES
13:48 < orlikowski> FlowVisor 0.8.2 : Dec 13 2011 * Slice configuration 
                    parameter for controlling LLDP spam * JSON callbacks for 
                    fine-grained topology changes * FLOWVISOR-128: Warn users 
                    when adding flowspace rules for non-existing slices
13:49 < jbsbbn> Hmm, ok. So that looks suspiciously like "a thing tagged as 
                0.8.2, but the code incorrectly says 0.8.1".
13:49 < orlikowski> jbsbbn: I think it's mis-reporting
13:49 < orlikowski> jbsbbn: correct

So, we think this is really 0.8.2, and that's fine for now; when 0.10 comes out (probably next week), we'll make a ticket to upgrade to that (in the next maintenance window presumably).

I think that's it for this one.

Note: See TracTickets for help on using tickets.