Opened 10 years ago

Closed 10 years ago

#6 closed (fixed)

Manifest RSpec does not include valid stitching element and attribute 'lastUpdateTime'

Reported by: lnevers@bbn.com Owned by: ibaldin@renci.org
Priority: major Milestone:
Component: AM Version: SPIRAL4
Keywords: RSpec support Cc:
Dependencies:

Description

Using version ??? on 04/26/2012:

Manifest RSpec for slice generate the following failures:

$ rspeclint lnexo11-rspec-bbn-hn-exogeni-net-11443-orca.xml 
Line 34: Failed validation with root at element: Schemas validity error : Element '{http://hpn.east.isi.edu/rspec/ext/stitch/0.1/}stitching': The element is not 'nillable'.
Schemas validity error : Element '{http://hpn.east.isi.edu/rspec/ext/stitch/0.1/}stitching': The attribute 'lastUpdateTime' is required but missing.
: ns2:stitching

Attachments (1)

lnexo11-rspec-bbn-hn-exogeni-net-11443-orca.xml (2.9 KB) - added by lnevers@bbn.com 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by lnevers@bbn.com

comment:1 Changed 10 years ago by ibaldin@renci.org

Owner: changed from somebody to ibaldin@renci.org
Status: newassigned

Try again.

comment:2 Changed 10 years ago by lnevers@bbn.com

Just tried again at the BBN rack and the problem still occurs. Re-executed procedure that showed this error:

  1. Created a slice lnexo111
  2. Created a sliver with the same resources as the original problem.
  3. Got a listresources for the sliver
  4. Ran rspeclint on the output from 3.
    $ rspeclint lnexo111-rspec-bbn-hn-exogeni-net-11443-orca.xml 
    Line 34: Failed validation with root at element: Schemas validity error : Element '{http://hpn.east.isi.edu/rspec/ext/stitch/0.1/}stitching': The element is not 'nillable'.
    Schemas validity error : Element '{http://hpn.east.isi.edu/rspec/ext/stitch/0.1/}stitching': The attribute 'lastUpdateTime' is required but missing.
    : ns2:stitching
    

Is the fix at BBN rack?

comment:3 Changed 10 years ago by lnevers@bbn.com

Resolution: fixed
Status: assignedclosed

On 4/26/12 4:05 PM, Ilia Baldine wrote:

Try now. Conversion is rack-independent (and that's where the problem was). It was inserting an empty stitching element.

Re-executed procedure and the problem is solved. Closing ticket.

Note: See TracTickets for help on using tickets.