Opened 9 years ago

Closed 9 years ago

#133 closed (fixed)

Attempt to create a sliver with bare metal node at incorrect aggregate generates exception

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone:
Component: Experiment Version: SPIRAL5
Keywords: Cc:
Dependencies:

Description

Accidentally submitted a request for one bare metal node at the BBN SM and the request resulted in the following failure:

$ omni.py createsliver -a eg-gpo bare1 exorspec/exo-1baremetal-1lan.rspec  INFO:omni:Loading config file /home/lnevers/.gcf/omni_config
INFO:omni:Using control framework pg
INFO:omni:Slice urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+bare1 expires on 2012-12-06 19:51:04 UTC
INFO:omni:Substituting AM nickname eg-gpo with URL https://bbn-hn.exogeni.net:11443/orca/xmlrpc, URN unspecified_AM_URN
INFO:omni:Substituting AM nickname eg-gpo with URL https://bbn-hn.exogeni.net:11443/orca/xmlrpc, URN unspecified_AM_URN
INFO:omni:Creating sliver(s) from rspec file exorspec/exo-1baremetal-1lan.rspec for slice urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+bare1
WARNING:omni:Failed CreateSliver for slice bare1 at https://bbn-hn.exogeni.net:11443/orca/xmlrpc.  Error from Aggregate: code 2: ERROR: Exception encountered: java.io.IOException: No space left on device.
INFO:omni: ------------------------------------------------------------
INFO:omni: Completed createsliver:

  Options as run:
		aggregate: ['eg-gpo']
		framework: pg

  Args: createsliver bare1 exorspec/exo-1baremetal-1lan.rspec

  Result Summary: Failed CreateSliver for slice bare1 at https://bbn-hn.exogeni.net:11443/orca/xmlrpc.  Error from Aggregate: code 2: ERROR: Exception encountered: java.io.IOException: No space left on device. 

I am able to request VM from the aggregate after this failure.

Change History (1)

comment:1 Changed 9 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

Unable to reproduce the error shown in the original description. The error reported is now the same as when requesting VMs at the wrong SM. Closing ticket.

Note: See TracTickets for help on using tickets.