Opened 7 years ago

Closed 7 years ago

#117 closed (fixed)

listreources for sliver hangs

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone: EG-EXP-6
Component: AM Version: SPIRAL4
Keywords: sliver status Cc:
Dependencies:

Description

Created a sliver named "EG-EXP-6-exp1" which was successfully created and is ready according to sliverstatus:

INFO:omni:Sliver status for Slice urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+EG-EXP-6-exp1 at AM URL https://bbn-hn.exogeni.net:11443/orca/xmlrpc
INFO:omni:{
  "geni_status": "ready", 
  "geni_urn": "urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+EG-EXP-6-exp1", 
  "geni_resources": [
    {
      "orca_expires": "Fri Oct 12 17:56:27 UTC 2012", 
      "geni_urn": "urn:publicid:IDN+exogeni.net:bbnvmsite+sliver+c0505466-19dd-4e18-8426-ae7727d61598#VM", 
      "geni_error": "", 
      "geni_status": "Active"
    

But, attempts to get listresources on this sliver hang every time:

omni.py -a https://bbn-hn.exogeni.net:11443/orca/xmlrpc  listresources EG-EXP-6-exp1

Waited as long as 10 minutes for this sliver listresources to return sliver details. Leaving the sliver running.

Change History (2)

comment:1 Changed 7 years ago by lnevers@bbn.com

Left the listresource for the sliver running and eventually failed as follows:

No resources from AM https://bbn-hn.exogeni.net:11443/orca/xmlrpc: . 
(Error from Aggregate: code 2: Error encountered converting manifest to 
RSpec: ERROR encountered while converting the manifest: 
com.hp.hpl.jena.shared.ClosedException: already closed.) 

comment:2 Changed 7 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

Checking status on unresolved tickets. Re-ran this scenario several times and was not able to reproduce. Closing ticket.

Note: See TracTickets for help on using tickets.