Opened 8 years ago

Closed 8 years ago

#108 closed (fixed)

Unable to renew sliver at ExoSM

Reported by: lnevers@bbn.com Owned by: somebody
Priority: major Milestone:
Component: AM Version: SPIRAL4
Keywords: sliver renew Cc:
Dependencies:

Description

Attempts to renew several slivers each fail as follows:

  Result Summary: Slice urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+lnexo expires on 2012-09-04 00:00:00 UTC
Failed to renew sliver urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+lnexo on unspecified_AM_URN (https://geni.renci.org:11443/orca/xmlrpc) (no reason given)

Change History (8)

comment:1 Changed 8 years ago by lnevers@bbn.com

The "no reason" failure occurs at the ExoSM and at BBN and it is reported for both "renewsliver" and "deletesliver":

Failed to renew sliver urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+acclne-192709 on
 unspecified_AM_URN (https://bbn-hn.exogeni.net:11443/orca/xmlrpc) (no reason given)
 Result Summary: Failed to delete sliver urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+acclne-1929492 
on unspecified_AM_URN at https://bbn-hn.exogeni.net:11443/orca/xmlrpc. (no reason given) 

comment:2 Changed 8 years ago by lnevers@bbn.com

Still unable to renew slivers, problem occurs with slivers at RENCI and at BBN ExoGENI whether through local or global SM.

Failed to renew sliver urn:publicid:IDN+pgeni.gpolab.bbn.com+slice+xyz on unspecified_AM_URN (https://rci-hn.exogeni.net:11443/orca/xmlrpc) (no reason given)

comment:3 Changed 8 years ago by ibaldin@renci.org

Nothing has changed with respect to renew support on our end.

comment:4 Changed 8 years ago by lnevers@bbn.com

The 'orca_expires' seems to be playing a role in this problem. If the renewsliver time is less than or equal to orca_expires time, than renewsliver fails. If the renewsliver time is greater than 'orca_expires' time, than renew sliver works.

Background:

Initial expiration for experiment is 2012-09-04. Modified slice expiration to 2012-09-10, and tried setting the sliver expiration to 2012-09-08, and to the same date as the slice expiration (2012-09-10), but both have the same "no reason" failure.

The sliver status shows that my sliver's 'orca_expires' is actuallt "Tue Sep 18 14:39:09 UTC 2012". So I renewed my slice to 2012-09-22 and then renewed the sliver:

  • first renewed to 2012-09-17, failed.
  • then renewed to 2012-09-18, failed.
  • and finally renewed the sliver to "2012-09-19" and now it worked.

Should orca_expires impact sliver expiration date?

comment:5 Changed 8 years ago by ahelsing@bbn.com

Does Orca allow renewing slivers to a sooner date / shorter duration?

comment:6 Changed 8 years ago by ahelsing@bbn.com

Does Orca limit sliver expiration to no later than the slice expiration? It should.

comment:7 Changed 8 years ago by ibaldin@renci.org

This ticket is a duplicate of #59. There are bugs in renew implementation that have not been addressed.

comment:8 Changed 8 years ago by lnevers@bbn.com

Resolution: fixed
Status: newclosed

Closing this ticket and tracking issue resolution in ticket #59.

Note: See TracTickets for help on using tickets.